summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-02-07 21:31:48 +0000
committerMike Frysinger <vapier@gentoo.org>2013-02-07 21:31:48 +0000
commitfd53f8e1664318efebf52a4a4fc02700cc8a3651 (patch)
tree436bf3a2824a8122d78b9b468b148ac3cb105dff /sys-libs/uclibc
parentMove Creative Commons licenses to shorter names. (diff)
downloadgentoo-2-fd53f8e1664318efebf52a4a4fc02700cc8a3651.tar.gz
gentoo-2-fd53f8e1664318efebf52a4a4fc02700cc8a3651.tar.bz2
gentoo-2-fd53f8e1664318efebf52a4a4fc02700cc8a3651.zip
Handle bfin-* targets as pointed out by Luca.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs/uclibc')
-rw-r--r--sys-libs/uclibc/ChangeLog6
-rw-r--r--sys-libs/uclibc/uclibc-0.9.33.2-r3.ebuild3
-rw-r--r--sys-libs/uclibc/uclibc-9999.ebuild7
3 files changed, 12 insertions, 4 deletions
diff --git a/sys-libs/uclibc/ChangeLog b/sys-libs/uclibc/ChangeLog
index 158922bcb413..daae1021ec41 100644
--- a/sys-libs/uclibc/ChangeLog
+++ b/sys-libs/uclibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/uclibc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/ChangeLog,v 1.72 2013/01/26 19:18:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/ChangeLog,v 1.73 2013/02/07 21:31:48 vapier Exp $
+
+ 07 Feb 2013; Mike Frysinger <vapier@gentoo.org> uclibc-0.9.33.2-r3.ebuild,
+ uclibc-9999.ebuild:
+ Handle bfin-* targets as pointed out by Luca.
26 Jan 2013; Mike Frysinger <vapier@gentoo.org> uclibc-0.9.33.2-r3.ebuild:
Add fix from upstream for cleaning up undefined syscalls. #425006 by Kiichiro.
diff --git a/sys-libs/uclibc/uclibc-0.9.33.2-r3.ebuild b/sys-libs/uclibc/uclibc-0.9.33.2-r3.ebuild
index 13d82caa3248..c748992866d2 100644
--- a/sys-libs/uclibc/uclibc-0.9.33.2-r3.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.33.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.33.2-r3.ebuild,v 1.2 2013/01/26 19:18:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.33.2-r3.ebuild,v 1.3 2013/02/07 21:31:48 vapier Exp $
inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
if [[ ${PV} == "9999" ]] ; then
@@ -281,6 +281,7 @@ src_unpack() {
amd64) target="x86_64"; config_target="no cpu-specific options";;
arm) target="arm"; config_target="GENERIC_ARM";;
avr) target="avr32"; config_target="no cpu-specific options";;
+ bfin) target="bfin"; config_target="no cpu-specific options";;
ia64) target="ia64"; config_target="no cpu-specific options";;
m68k) target="m68k"; config_target="no cpu-specific options";;
mips) target="mips"; config_target="MIPS_ISA_1";;
diff --git a/sys-libs/uclibc/uclibc-9999.ebuild b/sys-libs/uclibc/uclibc-9999.ebuild
index 65eb2d0855dd..00321edeb20b 100644
--- a/sys-libs/uclibc/uclibc-9999.ebuild
+++ b/sys-libs/uclibc/uclibc-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-9999.ebuild,v 1.3 2012/06/09 06:47:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-9999.ebuild,v 1.4 2013/02/07 21:31:48 vapier Exp $
inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
if [[ ${PV} == "9999" ]] ; then
@@ -176,9 +176,11 @@ src_config() {
UCLIBC_HAS_RESOLVER_SUPPORT
UCLIBC_HAS_TZ_FILE_READ_MANY
UCLIBC_HAS_UTMPX
+ UCLIBC_SUPPORT_AI_ADDRCONFIG
UCLIBC_SUSV3_LEGACY
UCLIBC_SUSV3_LEGACY_MACROS
UCLIBC_SUSV4_LEGACY
+ UCLIBC_USE_NETLINK
PTHREADS_DEBUG_SUPPORT
)
kconfig_q_opt y "${defs[@]}"
@@ -279,6 +281,7 @@ src_unpack() {
amd64) target="x86_64"; config_target="no cpu-specific options";;
arm) target="arm"; config_target="GENERIC_ARM";;
avr) target="avr32"; config_target="no cpu-specific options";;
+ bfin) target="bfin"; config_target="no cpu-specific options";;
ia64) target="ia64"; config_target="no cpu-specific options";;
m68k) target="m68k"; config_target="no cpu-specific options";;
mips) target="mips"; config_target="MIPS_ISA_1";;