summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-30 16:04:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-30 16:04:26 +0000
commit0ec246efae1f53876f1a38ee855872a221833e73 (patch)
treea598ab505d2fdcc1487054b48120b82e7021ad3b /sys-libs/slang
parentStable on sparc (version bump). (diff)
downloadgentoo-2-0ec246efae1f53876f1a38ee855872a221833e73.tar.gz
gentoo-2-0ec246efae1f53876f1a38ee855872a221833e73.tar.bz2
gentoo-2-0ec246efae1f53876f1a38ee855872a221833e73.zip
Add patch to use linux-style linking on FreeBSD and keyworded ~x86-fbsd.
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'sys-libs/slang')
-rw-r--r--sys-libs/slang/ChangeLog6
-rw-r--r--sys-libs/slang/files/slang-1.4.9-fbsdlink.patch26
-rw-r--r--sys-libs/slang/slang-1.4.9-r2.ebuild7
3 files changed, 36 insertions, 3 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index 1c34acdf9181..25bd4502cff3 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/slang
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.48 2006/03/14 20:33:21 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.49 2006/03/30 16:04:26 flameeyes Exp $
+
+ 30 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/slang-1.4.9-fbsdlink.patch, slang-1.4.9-r2.ebuild:
+ Add patch to use linux-style linking on FreeBSD and keyworded ~x86-fbsd.
14 Mar 2006; Chris White <chriswhite@gentoo.org> slang-1.4.9-r2.ebuild:
1.4.9-r2 amd64 stable.
diff --git a/sys-libs/slang/files/slang-1.4.9-fbsdlink.patch b/sys-libs/slang/files/slang-1.4.9-fbsdlink.patch
new file mode 100644
index 000000000000..472348fbbc03
--- /dev/null
+++ b/sys-libs/slang/files/slang-1.4.9-fbsdlink.patch
@@ -0,0 +1,26 @@
+Index: slang-1.4.9/autoconf/aclocal.m4
+===================================================================
+--- slang-1.4.9.orig/autoconf/aclocal.m4
++++ slang-1.4.9/autoconf/aclocal.m4
+@@ -489,7 +489,7 @@ ELFLIB_MAJOR="\$(ELFLIB).\$(ELF_MAJOR_VE
+ ELFLIB_MAJOR_MINOR="\$(ELFLIB).\$(ELF_MAJOR_VERSION).\$(ELF_MINOR_VERSION)"
+
+ case "$host_os" in
+- *linux* )
++ *linux* | *freebsd* )
+ DYNAMIC_LINK_FLAGS="-Wl,-export-dynamic"
+ ELF_CC="gcc"
+ ELF_CFLAGS="$ELF_CFLAGS -fPIC"
+Index: slang-1.4.9/configure
+===================================================================
+--- slang-1.4.9.orig/configure
++++ slang-1.4.9/configure
+@@ -489,7 +489,7 @@ ELFLIB_MAJOR="\$(ELFLIB).\$(ELF_MAJOR_VE
+ ELFLIB_MAJOR_MINOR="\$(ELFLIB).\$(ELF_MAJOR_VERSION).\$(ELF_MINOR_VERSION)"
+
+ case "$host_os" in
+- *linux* )
++ *linux* | *freebsd* )
+ DYNAMIC_LINK_FLAGS="-Wl,-export-dynamic"
+ ELF_CC="gcc"
+ ELF_CFLAGS="$ELF_CFLAGS -fPIC"
diff --git a/sys-libs/slang/slang-1.4.9-r2.ebuild b/sys-libs/slang/slang-1.4.9-r2.ebuild
index 381f319f1f02..0516fa1ae303 100644
--- a/sys-libs/slang/slang-1.4.9-r2.ebuild
+++ b/sys-libs/slang/slang-1.4.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9-r2.ebuild,v 1.10 2006/03/14 20:33:21 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9-r2.ebuild,v 1.11 2006/03/30 16:04:26 flameeyes Exp $
inherit eutils
@@ -14,7 +14,7 @@ SRC_URI="ftp://space.mit.edu/pub/davis/slang/v1.4/${P}.tar.bz2
LICENSE="|| ( GPL-2 Artistic )"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ~mips ppc ~ppc-macos ppc64 ~s390 ~sh sparc x86"
+KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ~mips ppc ~ppc-macos ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
IUSE="cjk unicode"
DEPEND=">=sys-libs/ncurses-5.2-r2"
@@ -32,6 +32,9 @@ src_unpack() {
epatch ${WORKDIR}/slang-utf8-fix.patch
epatch ${WORKDIR}/slang-utf8-fix2.patch
fi
+
+ epatch "${FILESDIR}/${P}-fbsdlink.patch"
+
if use cjk ; then
sed -i \
-e "/SLANG_HAS_KANJI_SUPPORT/s/0/1/" \