summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2013-11-04 21:50:32 +0000
committerSven Vermeulen <swift@gentoo.org>2013-11-04 21:50:32 +0000
commitba5e0f8302044b6b8929989e9fdd7c9cd946afa7 (patch)
tree6123792e2c1b7db0d01bf62c25bf57dc22b9880e /sys-libs/libsepol
parentStable for ppc64, wrt bug #488536 (diff)
downloadgentoo-2-ba5e0f8302044b6b8929989e9fdd7c9cd946afa7.tar.gz
gentoo-2-ba5e0f8302044b6b8929989e9fdd7c9cd946afa7.tar.bz2
gentoo-2-ba5e0f8302044b6b8929989e9fdd7c9cd946afa7.zip
New libsepol release
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2EDD52403B68AF47)
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/ChangeLog7
-rw-r--r--sys-libs/libsepol/libsepol-2.2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index fc511fa6ab77..ab5fcbae1c12 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.60 2013/11/04 18:50:00 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.61 2013/11/04 21:50:32 swift Exp $
+
+*libsepol-2.2 (04 Nov 2013)
+
+ 04 Nov 2013; Sven Vermeulen <swift@gentoo.org> +libsepol-2.2.ebuild:
+ New libsepol release
04 Nov 2013; Sven Vermeulen <swift@gentoo.org> libsepol-2.1.9-r3.ebuild:
Stabilize
diff --git a/sys-libs/libsepol/libsepol-2.2.ebuild b/sys-libs/libsepol/libsepol-2.2.ebuild
new file mode 100644
index 000000000000..cbfd43ce8778
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.2.ebuild,v 1.1 2013/11/04 21:50:32 swift Exp $
+
+EAPI="4"
+
+inherit multilib toolchain-funcs eutils multilib-minimal
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="http://userspace.selinuxproject.org"
+SRC_URI="http://userspace.selinuxproject.org/releases/20131030/${P}.tar.gz"
+# http://dev.gentoo.org/~swift/patches/${PN}/patchbundle-${P}-r1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+# EPATCH_MULTI_MSG="Applying libsepol patches ... " \
+# EPATCH_SUFFIX="patch" \
+# EPATCH_SOURCE="${WORKDIR}/gentoo-patches" \
+# EPATCH_FORCE="yes" \
+# epatch
+
+ epatch_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export RANLIB;
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake DESTDIR="${D}" install
+}