summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-18 13:34:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-18 13:34:23 +0000
commit55a04cf8ddc55329152ae9a372cfaf6ed4846e6d (patch)
tree002838214964d685f821a9c1c487a32b752ca484 /sys-libs/libcxx
parentFix USE=examples install (bug #458038 by Branko Majic). (diff)
downloadgentoo-2-55a04cf8ddc55329152ae9a372cfaf6ed4846e6d.tar.gz
gentoo-2-55a04cf8ddc55329152ae9a372cfaf6ed4846e6d.tar.bz2
gentoo-2-55a04cf8ddc55329152ae9a372cfaf6ed4846e6d.zip
remove old
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/ChangeLog6
-rw-r--r--sys-libs/libcxx/libcxx-0.0_p20120911.ebuild68
2 files changed, 5 insertions, 69 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index 02ed38139149..11c625a15bf9 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.9 2013/01/31 17:56:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.10 2013/02/18 13:34:23 aballier Exp $
+
+ 18 Feb 2013; Alexis Ballier <aballier@gentoo.org>
+ -libcxx-0.0_p20120911.ebuild:
+ remove old
31 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org>
libcxx-0.0_p20121105.ebuild, libcxx-9999.ebuild:
diff --git a/sys-libs/libcxx/libcxx-0.0_p20120911.ebuild b/sys-libs/libcxx/libcxx-0.0_p20120911.ebuild
deleted file mode 100644
index d6b0b9ff2fdb..000000000000
--- a/sys-libs/libcxx/libcxx-0.0_p20120911.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-0.0_p20120911.ebuild,v 1.3 2012/11/01 17:37:04 aballier Exp $
-
-EAPI=4
-
-ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
-
-[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
-
-inherit cmake-utils ${SCM} base flag-o-matic
-
-DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
-if [ "${PV%9999}" = "${PV}" ] ; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else
- SRC_URI=""
-fi
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-if [ "${PV%9999}" = "${PV}" ] ; then
- KEYWORDS="~amd64 ~amd64-fbsd"
-else
- KEYWORDS=""
-fi
-IUSE=""
-
-RDEPEND="sys-libs/libcxxrt"
-DEPEND="${RDEPEND}
- sys-devel/clang
- app-arch/xz-utils"
-
-PATCHES=( "${FILESDIR}/multilib.patch"
- "${FILESDIR}/cxxrt.patch" )
-DOCS=( "CREDITS.TXT" )
-
-src_prepare() {
- base_src_prepare
-}
-
-src_configure() {
- append-cppflags "-I/usr/include/libcxxrt -DLIBCXXRT"
- # Needs to be built with clang. gcc-4.6.3 fails at least.
- # TODO: cross-compile ?
- export CC=clang
- export CXX=clang++
- cmake-utils_src_configure
-}
-
-# Tests fail for now, if anybody is able to fix them, help is very welcome.
-src_test() {
- cd "${S}/test"
- LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/lib:${LD_LIBRARY_PATH}" \
- CC="clang++" \
- HEADER_INCLUDE="-I${S}/include" \
- SOURCE_LIB="-L${CMAKE_BUILD_DIR}/lib" \
- ./testit || die
-}
-
-pkg_postinst() {
- elog "This package (${PN}) is mainly intended as a replacement for the C++"
- elog "standard library when using clang."
- elog "To use it, instead of libstdc++, use:"
- elog " clang++ -stdlib=libc++"
- elog "to compile your C++ programs."
-}