summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-18 22:05:07 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-18 22:05:07 +0000
commit4470b694c477f40b1adee75f1f934dcfc1039fc0 (patch)
treeb36e6d5942d64764e6d4fed7ade14d2089d721f6 /sys-libs/gpm
parentTagged stable. (diff)
downloadgentoo-2-4470b694c477f40b1adee75f1f934dcfc1039fc0.tar.gz
gentoo-2-4470b694c477f40b1adee75f1f934dcfc1039fc0.tar.bz2
gentoo-2-4470b694c477f40b1adee75f1f934dcfc1039fc0.zip
fix symlink issue
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/ChangeLog9
-rw-r--r--sys-libs/gpm/files/digest-gpm-1.20.0-r52
-rw-r--r--sys-libs/gpm/gpm-1.20.0-r5.ebuild65
3 files changed, 75 insertions, 1 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index adb5d252be46..f11a68a409aa 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/gpm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.9 2002/10/24 06:45:51 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.10 2002/11/18 22:05:07 azarah Exp $
+
+*gpm-1.20.0-r5 (18 Nov 2002)
+
+ 18 Nov 2002; Martin Schlemmer <azarah@gentoo.org> gpm-1.20.0-r5.ebuild :
+
+ Fix missing /usr/lib/libgpm.so.1, bug #10355. Convert to use epatch from
+ eutils.eclass. Add missing IUSE.
*gpm-1.20.0-r4 (23 Oct 2002)
diff --git a/sys-libs/gpm/files/digest-gpm-1.20.0-r5 b/sys-libs/gpm/files/digest-gpm-1.20.0-r5
new file mode 100644
index 000000000000..77ba65782919
--- /dev/null
+++ b/sys-libs/gpm/files/digest-gpm-1.20.0-r5
@@ -0,0 +1,2 @@
+MD5 ab33423219cfef97fce158af48d3ad8c gpm-1.20.0.tar.bz2 390987
+MD5 efed498fca612e0d08824f26fad1d2d3 gpm-1.20.1-patch.tar.bz2 5171
diff --git a/sys-libs/gpm/gpm-1.20.0-r5.ebuild b/sys-libs/gpm/gpm-1.20.0-r5.ebuild
new file mode 100644
index 000000000000..d5a2c33d364d
--- /dev/null
+++ b/sys-libs/gpm/gpm-1.20.0-r5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.0-r5.ebuild,v 1.1 2002/11/18 22:05:07 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Console-based mouse driver"
+SRC_URI="ftp://arcana.linux.it/pub/gpm/gpm-1.20.0.tar.bz2
+ http://www.ibiblio.org/gentoo/distfiles/gpm-1.20.1-patch.tar.bz2"
+HOMEPAGE="ftp://arcana.linux.it/pub/gpm/"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ sys-devel/autoconf"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+src_unpack() {
+ unpack ${A}
+
+ # This little hack turns off EMACS byte compilation. We really
+ # don't want this thing auto-detecting emacs.
+ cd ${S}; epatch ${WORKDIR}/gpm.patch
+
+ # Add missing 'mkinstalldirs' script
+ cp -f /usr/share/automake/mkinstalldirs ${S}
+}
+
+src_compile() {
+ econf --sysconfdir=/etc/gpm || die
+
+ # Do not create gpmdoc.ps, as it cause build to fail with our version
+ # of tetex (it is already there, so this will only create missing
+ # manpages)
+ cp doc/Makefile doc/Makefile.orig
+ sed -e 's:all\: $(srcdir)/gpmdoc.ps:all\::' \
+ doc/Makefile.orig > doc/Makefile
+
+ MAKEOPTS="-j1" emake || die
+}
+
+src_install() {
+ einstall
+
+ chmod 755 ${D}/usr/lib/*
+ # Fix missing /usr/lib/libgpm.so.1
+ preplib
+
+ dodoc BUGS COPYING ChangeLog Changes MANIFEST README TODO
+ dodoc doc/Announce doc/FAQ doc/README*
+ doinfo doc/gpm.info
+
+ insinto /etc/gpm
+ doins conf/gpm-*.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/gpm.rc6 gpm
+ insinto /etc/conf.d
+ newins ${FILESDIR}/gpm.conf.d gpm
+}
+