summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-10 23:56:24 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-10 23:56:24 +0000
commit20a586857d19c9cc8856062eddbc2ee8df1c013e (patch)
tree04f438cf011b896add65fe6d9cd08d630e0fd051 /sys-libs/glibc
parentStable on x86, bug #154684. (diff)
downloadgentoo-2-20a586857d19c9cc8856062eddbc2ee8df1c013e.tar.gz
gentoo-2-20a586857d19c9cc8856062eddbc2ee8df1c013e.tar.bz2
gentoo-2-20a586857d19c9cc8856062eddbc2ee8df1c013e.zip
tweak stupid xen warning so it only shows on x86 #154736 by Peter Abrahamsen
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r5.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.4-r4.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.5.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r5.ebuild b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
index 9b936268a51f..57198902138e 100644
--- a/sys-libs/glibc/glibc-2.3.6-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.12 2006/11/09 15:24:50 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.13 2006/11/10 23:56:24 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1043,7 +1043,7 @@ pkg_setup() {
die "nptlonly without nptl"
fi
- if [[ -e /proc/xen ]] && ! is-flag -mno-tls-direct-seg-refs ; then
+ if [[ -e /proc/xen ]] && [[ $(tc-arch) == "x86" ]] && ! is-flag -mno-tls-direct-seg-refs ; then
ewarn "You are using Xen but don't have -mno-tls-direct-seg-refs in your CFLAGS."
ewarn "This will result in a 50% performance penalty, which is probably not what you want."
fi
diff --git a/sys-libs/glibc/glibc-2.4-r4.ebuild b/sys-libs/glibc/glibc-2.4-r4.ebuild
index 1ab6131a253e..7762bbf18651 100644
--- a/sys-libs/glibc/glibc-2.4-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.8 2006/11/08 07:23:01 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.9 2006/11/10 23:56:24 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1074,7 +1074,7 @@ pkg_setup() {
die "nptlonly without nptl"
fi
- if [[ -e /proc/xen ]] && ! is-flag -mno-tls-direct-seg-refs ; then
+ if [[ -e /proc/xen ]] && [[ $(tc-arch) == "x86" ]] && ! is-flag -mno-tls-direct-seg-refs ; then
ewarn "You are using Xen but don't have -mno-tls-direct-seg-refs in your CFLAGS."
ewarn "This will result in a 50% performance penalty, which is probably not what you want."
fi
diff --git a/sys-libs/glibc/glibc-2.5.ebuild b/sys-libs/glibc/glibc-2.5.ebuild
index 381e063c098c..9f62bdf7d10a 100644
--- a/sys-libs/glibc/glibc-2.5.ebuild
+++ b/sys-libs/glibc/glibc-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.14 2006/11/02 01:45:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.15 2006/11/10 23:56:24 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1033,7 +1033,7 @@ pkg_setup() {
die "nptlonly without nptl"
fi
- if [[ -e /proc/xen ]] && ! is-flag -mno-tls-direct-seg-refs ; then
+ if [[ -e /proc/xen ]] && [[ $(tc-arch) == "x86" ]] && ! is-flag -mno-tls-direct-seg-refs ; then
ewarn "You are using Xen but don't have -mno-tls-direct-seg-refs in your CFLAGS."
ewarn "This will result in a 50% performance penalty, which is probably not what you want."
fi