summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-13 21:18:30 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-13 21:18:30 +0000
commit73a59679ee0a3ad909a396b1b68dded3d068e307 (patch)
tree0716adc78b11d456bbe1f519b2fb9db7d22ae7f3 /sys-libs/glibc/glibc-9999.ebuild
parentAdd ChangeLog entry for new cdrom.eclass. (diff)
downloadgentoo-2-73a59679ee0a3ad909a396b1b68dded3d068e307.tar.gz
gentoo-2-73a59679ee0a3ad909a396b1b68dded3d068e307.tar.bz2
gentoo-2-73a59679ee0a3ad909a396b1b68dded3d068e307.zip
Version bump. Add xz tarball support so we can upload our own release tarballs early without conflicting with official ones. Drop coreutils static checks since latest glibc versions no longer have that bug.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild18
1 files changed, 2 insertions, 16 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 66c41cc23439..e181933cb315 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-9999.ebuild,v 1.3 2011/11/16 16:07:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-9999.ebuild,v 1.4 2012/01/13 21:18:30 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -191,20 +191,6 @@ for x in setup {pre,post}inst ; do
fi
done
-pkg_setup() {
- eblit-run pkg_setup
-
- # Static binary sanity check #332927
- if [[ ${ROOT} == "/" ]] && \
- has_version "<${CATEGORY}/${P}" && \
- built_with_use sys-apps/coreutils static
- then
- eerror "Please rebuild coreutils with USE=-static, then install"
- eerror "glibc, then you may rebuild coreutils with USE=static."
- die "Avoiding system meltdown #332927"
- fi
-}
-
eblit-src_unpack-post() {
if use hardened ; then
cd "${S}"