summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-11-10 09:20:22 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-11-10 09:20:22 +0000
commitc99d6df6217df8dde19a040a61f1ab5ee9624a21 (patch)
tree819af7f94f86d5f3c762051208f9ae0f7da29e62 /sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
parentfix for remote denial-of-service in nfs3 xdr handling code. bug #62524 (Manif... (diff)
downloadgentoo-2-c99d6df6217df8dde19a040a61f1ab5ee9624a21.tar.gz
gentoo-2-c99d6df6217df8dde19a040a61f1ab5ee9624a21.tar.bz2
gentoo-2-c99d6df6217df8dde19a040a61f1ab5ee9624a21.zip
Renamed a few patches to better identify them for mips, masked 2.3.4.20041021, and added a series of patches to 2.3.4.20041102 from libc-alpha ML that allows it to build and usable. Also re-added use of the librt patchs to fix a run-time error.
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
index 06156e1999ec..41f8f7f0f1fb 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.1 2004/10/07 22:24:28 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.2 2004/11/10 09:20:22 kumba Exp $
inherit eutils flag-o-matic gcc
@@ -378,13 +378,13 @@ do_arch_mips_patches() {
epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-librt-mips.patch
epatch ${FILESDIR}/2.3.3/${PN}-2.3.3_pre20040420-mips-dl-machine-calls.diff
epatch ${FILESDIR}/2.3.3/${PN}-2.3.3_pre20040420-mips-incl-sgidefs.diff
- epatch ${FILESDIR}/2.3.3/mips-addabi.diff
- epatch ${FILESDIR}/2.3.3/mips-syscall.h.diff
- epatch ${FILESDIR}/2.3.3/semtimedop.diff
- epatch ${FILESDIR}/2.3.3/mips-sysify.diff
+ epatch ${FILESDIR}/2.3.3/${PN}-2.3.3-mips-addabi.diff
+ epatch ${FILESDIR}/2.3.3/${PN}-2.3.3-mips-syscall.h.diff
+ epatch ${FILESDIR}/2.3.3/${PN}-2.3.3-semtimedop.diff
+ epatch ${FILESDIR}/2.3.3/${PN}-2.3.3-mips-sysify.diff
if use n32 || use n64; then
- epatch ${FILESDIR}/2.3.4/mips-sysdep-cancel.diff
+ epatch ${FILESDIR}/2.3.4/${PN}-2.3.4-mips-sysdep-cancel.diff
fi
# Need to install into /lib for n32-only userland for now.