summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-05-08 05:59:25 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-05-08 05:59:25 +0000
commit8a818e2793e49c09a53228a2bf60666917c6ed3b (patch)
treeea01202b6db474757b181aa14af55efdde09ee51 /sys-kernel
parentuse check_KV and depend on portage >=> 1.9.10 (diff)
downloadgentoo-2-8a818e2793e49c09a53228a2bf60666917c6ed3b.tar.gz
gentoo-2-8a818e2793e49c09a53228a2bf60666917c6ed3b.tar.bz2
gentoo-2-8a818e2793e49c09a53228a2bf60666917c6ed3b.zip
/usr/src/linux "don't touch that symlink" fixups
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre32
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild80
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild20
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.19-r3.ebuild18
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild18
-rw-r--r--sys-kernel/redhat-sources/redhat-sources-2.4.18.0.13.ebuild20
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild20
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.18.ebuild20
8 files changed, 24 insertions, 174 deletions
diff --git a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre3 b/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre3
deleted file mode 100644
index eb4b863f0600..000000000000
--- a/sys-kernel/openmosix-sources/files/digest-openmosix-sources-2.4.17_pre3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 d3a363dc4f0731b57d1ed90a3eadf150 linux-2.4.16.tar.bz2 23746229
-MD5 3c9ef2f3054893fef93b7d9c59a356e8 linux-gentoo-2.4.17-pre3-openmosix.patch.bz2 239561
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild
deleted file mode 100644
index 3f7be72e58e2..000000000000
--- a/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild,v 1.5 2002/04/25 06:56:23 drobbins Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-OKV=2.4.16
-KV=2.4.17-pre3-openmosix
-DIRNAME=linux-${KV}
-S=${WORKDIR}/${DIRNAME}
-
-# What's in this kernel?
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-
-if [ $PN = "openmosix-sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
- mv linux ${DIRNAME} || die
- cd ${S}
- cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
- make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- cd ${S}
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-}
-
-src_install() {
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
-}
-
-pkg_postinst() {
- cd ${ROOT}usr/src/${DIRNAME}
- make mrproper
- if [ -e "${ROOT}usr/src/linux/.config" ]
- then
- cp "${ROOT}usr/src/linux/.config" .config
- else
- cp "${ROOT}usr/src/${DIRNAME}/arch/i386/defconfig" .config
- fi
- #The default setting will be selected.
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- #remove /usr/src/linux symlink
- rm -f ${ROOT}/usr/src/linux
- #set up a new one
- ln -sf ${DIRNAME} ${ROOT}/usr/src/linux
- #this will generate include/linux/modversions.h, among other things:
- cd ${ROOT}/usr/src/${DIRNAME}
- make dep
-}
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild
index fee3f35a583c..54833e4ab63b 100644
--- a/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild,v 1.3 2002/04/29 21:01:13 sandymac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre4.ebuild,v 1.4 2002/05/08 05:59:25 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -93,21 +93,9 @@ pkg_preinst() {
pkg_postinst() {
[ "$ETYPE" = "headers" ] && return
- cd ${ROOT}usr/src/linux-${KV}
- make mrproper
- if [ -e "${ROOT}usr/src/linux/.config" ]
+ if [ ! -e ${ROOT}usr/src/linux ]
then
- cp "${ROOT}usr/src/linux/.config" .config
- #we only make dep when upgrading to a new kernel (with existing config)
- #The default setting will be selected.
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- make dep
- else
- cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
fi
- #remove /usr/src/linux symlink
- rm -f ${ROOT}/usr/src/linux
- #set up a new one
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
}
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.19-r3.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r3.ebuild
index e828f3c61bcc..3c4518bd6b3a 100644
--- a/sys-kernel/ppc-sources/ppc-sources-2.4.19-r3.ebuild
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.19-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: Kain X <kain@gentoo.org>
-# $Id: ppc-sources-2.4.19-r3.ebuild,v 1.1 2002/05/05 06:47:41 kain Exp $
+# $Id: ppc-sources-2.4.19-r3.ebuild,v 1.2 2002/05/08 05:59:25 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
@@ -108,19 +108,9 @@ pkg_preinst() {
pkg_postinst() {
[ "$ETYPE" = "headers" ] && return
- cd ${ROOT}usr/src/linux-${KV}
- if [ -e "${ROOT}usr/src/linux/.config" ]
+ if [ ! -e ${ROOT}usr/src/linux ]
then
- cp "${ROOT}usr/src/linux/.config" .config
- #The default setting will be selected.
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- make dep
- else
- cp "${ROOT}usr/src/linux-${KV}/arch/ppc/defconfig" .config
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
fi
- #remove /usr/src/linux symlink
- rm -f ${ROOT}/usr/src/linux
- #set up a new one
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
}
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild
index 92f25b9684a3..3c109734e6ec 100644
--- a/sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild
+++ b/sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: Kain X <kain@gentoo.org>
-# $Id: ppc-sources-2.4.19.ebuild,v 1.2 2002/04/29 21:01:13 sandymac Exp $
+# $Id: ppc-sources-2.4.19.ebuild,v 1.3 2002/05/08 05:59:25 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
@@ -108,19 +108,9 @@ pkg_preinst() {
pkg_postinst() {
[ "$ETYPE" = "headers" ] && return
- cd ${ROOT}usr/src/linux-${KV}
- if [ -e "${ROOT}usr/src/linux/.config" ]
+ if [ ! -e ${ROOT}usr/src/linux ]
then
- cp "${ROOT}usr/src/linux/.config" .config
- #The default setting will be selected.
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- make dep
- else
- cp "${ROOT}usr/src/linux-${KV}/arch/ppc/defconfig" .config
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
fi
- #remove /usr/src/linux symlink
- rm -f ${ROOT}/usr/src/linux
- #set up a new one
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
}
diff --git a/sys-kernel/redhat-sources/redhat-sources-2.4.18.0.13.ebuild b/sys-kernel/redhat-sources/redhat-sources-2.4.18.0.13.ebuild
index 326352560d8e..3fe9d6a9569e 100644
--- a/sys-kernel/redhat-sources/redhat-sources-2.4.18.0.13.ebuild
+++ b/sys-kernel/redhat-sources/redhat-sources-2.4.18.0.13.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Maintainer: Bruce A. Locke <blocke@shivan.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/redhat-sources/redhat-sources-2.4.18.0.13.ebuild,v 1.4 2002/04/29 21:01:13 sandymac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/redhat-sources/redhat-sources-2.4.18.0.13.ebuild,v 1.5 2002/05/08 05:59:25 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -90,21 +90,9 @@ pkg_preinst() {
pkg_postinst() {
[ "$ETYPE" = "headers" ] && return
- cd ${ROOT}usr/src/linux-${KV}
- make mrproper
- if [ -e "${ROOT}usr/src/linux/.config" ]
+ if [ ! -e ${ROOT}usr/src/linux ]
then
- cp "${ROOT}usr/src/linux/.config" .config
- #we only make dep when upgrading to a new kernel (with existing config)
- #The default setting will be selected.
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- make dep
- else
- cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
fi
- #remove /usr/src/linux symlink
- rm -f ${ROOT}/usr/src/linux
- #set up a new one
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
}
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild
index 86e9a15a16f3..2a45c7467602 100644
--- a/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild
+++ b/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild,v 1.3 2002/04/29 21:01:13 sandymac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild,v 1.4 2002/05/08 05:59:25 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -91,21 +91,9 @@ pkg_preinst() {
pkg_postinst() {
[ "$ETYPE" = "headers" ] && return
- cd ${ROOT}usr/src/linux-${KV}
- make mrproper
- if [ -e "${ROOT}usr/src/linux/.config" ]
+ if [ ! -e ${ROOT}usr/src/linux ]
then
- cp "${ROOT}usr/src/linux/.config" .config
- #we only make dep when upgrading to a new kernel (with existing config)
- #The default setting will be selected.
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- make dep
- else
- cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
fi
- #remove /usr/src/linux symlink
- rm -f ${ROOT}/usr/src/linux
- #set up a new one
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
}
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.18.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.18.ebuild
index 458976e3e05f..23639d701bfc 100644
--- a/sys-kernel/xfs-sources/xfs-sources-2.4.18.ebuild
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.18.ebuild,v 1.4 2002/04/29 21:01:13 sandymac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.18.ebuild,v 1.5 2002/05/08 05:59:25 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -92,21 +92,9 @@ pkg_preinst() {
pkg_postinst() {
[ "$ETYPE" = "headers" ] && return
- cd ${ROOT}usr/src/linux-${KV}
- make mrproper
- if [ -e "${ROOT}usr/src/linux/.config" ]
+ if [ ! -e ${ROOT}usr/src/linux ]
then
- cp "${ROOT}usr/src/linux/.config" .config
- #we only make dep when upgrading to a new kernel (with existing config)
- #The default setting will be selected.
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- make dep
- else
- cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
fi
- #remove /usr/src/linux symlink
- rm -f ${ROOT}/usr/src/linux
- #set up a new one
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
}