summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2004-06-03 12:19:58 +0000
committerChristian Birchinger <joker@gentoo.org>2004-06-03 12:19:58 +0000
commit87676ec080660a669d66d6f8b698b8e7e371d0f5 (patch)
treef19b663713d7e07982d023d6cfb4ed3ea939f63a /sys-kernel
parentCleanup; removing an unneeded variable and fixing a die() message. (Manifest ... (diff)
downloadgentoo-2-87676ec080660a669d66d6f8b698b8e7e371d0f5.tar.gz
gentoo-2-87676ec080660a669d66d6f8b698b8e7e371d0f5.tar.bz2
gentoo-2-87676ec080660a669d66d6f8b698b8e7e371d0f5.zip
Added -r1 with a CAN-2004-0394 fix
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/files/2.4.26-CAN-2004-0394.patch11
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.26-r12
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.26-r1.ebuild66
4 files changed, 86 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 77d31076d82e..b7ef2c5357cc 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.56 2004/04/27 22:08:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.57 2004/06/03 12:19:58 joker Exp $
+
+*sparc-sources-2.4.26-r1 (03 Jun 2004)
+
+ 03 Jun 2004; Christian Birchinger <joker@gentoo.org>
+ sparc-sources-2.4.26-r1.ebuild, files/2.4.26-CAN-2004-0394.patch:
+ Added CAN-2004-0394 fix
27 Apr 2004; Aron Griffis <agriffis@gentoo.org>
sparc-sources-2.4.25-r1.ebuild, sparc-sources-2.4.26.ebuild:
diff --git a/sys-kernel/sparc-sources/files/2.4.26-CAN-2004-0394.patch b/sys-kernel/sparc-sources/files/2.4.26-CAN-2004-0394.patch
new file mode 100644
index 000000000000..7b12ecbccce1
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/2.4.26-CAN-2004-0394.patch
@@ -0,0 +1,11 @@
+--- linux/kernel/panic.c Tue Mar 30 15:37:18 2004
++++ linux/kernel/panic.c Mon May 17 18:44:01 2004
+@@ -51,7 +51,7 @@
+
+ bust_spinlocks(1);
+ va_start(args, fmt);
+- vsprintf(buf, fmt, args);
++ vsnprintf(buf, sizeof(buf), fmt, args);
+ va_end(args);
+ printk(KERN_EMERG "Kernel panic: %s\n",buf);
+ if (in_interrupt())
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.26-r1 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.26-r1
new file mode 100644
index 000000000000..ce6ae7ed6f79
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.26-r1
@@ -0,0 +1,2 @@
+MD5 88d7aefa03c92739cb70298a0b486e2c linux-2.4.26.tar.bz2 30772389
+MD5 ec4db0cbb81c30dea24ee27287eb2ae2 patches-2.4.26-sparc.tar.bz2 145065
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.26-r1.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.26-r1.ebuild
new file mode 100644
index 000000000000..d2e0d5a6ce85
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.26-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.26-r1.ebuild,v 1.1 2004/06/03 12:19:58 joker Exp $
+
+IUSE="ultra1"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel eutils
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+[ "$OKV" == "" ] && OKV="${PV}"
+
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+PATCH_VERSION="2.4.26-sparc"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${PATCH_VERSION}.tar.bz2"
+
+S=${WORKDIR}/linux-${KV}
+KEYWORDS="~x86 -ppc sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${PATCH_VERSION} || die "Unable to cd into ${PATCH_VERSION}"
+
+ kernel_src_unpack
+
+ # fix format string problem in panic()
+ epatch ${FILESDIR}/2.4.26-CAN-2004-0394.patch
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}