summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-10-18 17:39:06 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-10-18 17:39:06 +0000
commit2f374fd57776eedf61a3bb58abbdc37c86f0374a (patch)
treed76bf0bd1e9beb7d7660e2e300e75fc9a8e1c345 /sys-kernel
parentvanilla-3.2.51 + genpatches-3.2-16 + grsecurity-2.9.1-3.2.51-201310162039 (diff)
downloadgentoo-2-2f374fd57776eedf61a3bb58abbdc37c86f0374a.tar.gz
gentoo-2-2f374fd57776eedf61a3bb58abbdc37c86f0374a.tar.bz2
gentoo-2-2f374fd57776eedf61a3bb58abbdc37c86f0374a.zip
vanilla-3.11.5 + genpatches-3.11-7 + grsecurity-2.9.1-3.11.5-201310162041
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.11.5.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 4bb9ad44d41b..948df35da383 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.924 2013/10/18 17:37:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.925 2013/10/18 17:39:06 blueness Exp $
+
+*hardened-sources-3.11.5 (18 Oct 2013)
+
+ 18 Oct 2013; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.11.5.ebuild:
+ vanilla-3.11.5 + genpatches-3.11-7 + grsecurity-2.9.1-3.11.5-201310162041
*hardened-sources-3.2.51-r3 (18 Oct 2013)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.11.5.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.11.5.ebuild
new file mode 100644
index 000000000000..b352499ce29c
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.11.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.11.5.ebuild,v 1.1 2013/10/18 17:39:06 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="7"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-1"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="
+ 1500_XATTR_USER_PREFIX.patch
+ 2900_dev-root-proc-mount-fix.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.9.1*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}