summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-01-12 19:20:36 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-01-12 19:20:36 +0000
commit851bd2fd2c0069056ed480a2acc0c5d2bf615af0 (patch)
tree1ac0004bf869e84c4410bd5066624f6a9f2d13d2 /sys-kernel/gentoo-sources
parentCode fix for GCC 3.2.1. No oustanding bug out on this (but prerequisite fix f... (diff)
downloadgentoo-2-851bd2fd2c0069056ed480a2acc0c5d2bf615af0.tar.gz
gentoo-2-851bd2fd2c0069056ed480a2acc0c5d2bf615af0.tar.bz2
gentoo-2-851bd2fd2c0069056ed480a2acc0c5d2bf615af0.zip
new kernel marked ~ for now
Diffstat (limited to 'sys-kernel/gentoo-sources')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog53
-rw-r--r--sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.20-r12
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r1.ebuild91
3 files changed, 145 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index fc06358152a3..0031e7d16bab 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,57 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.12 2002/12/18 00:12:48 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.13 2003/01/12 19:20:36 lostlogic Exp $
+
+*gentoo-sources-2.4.20-r1 (12 Jan 2003)
+
+ Ebuild Changes
+ * Drop gcc-3.1 patch if not on gcc3
+ * Also make prettier output for the USE var controlled
+ patches
+
+ Features of this kernel:
+ * Based heavily on ck-sources-2.4.20-r2 (linux-2.4.20-ck2)
+
+ From CK:
+ * O(1) Scheduler
+ * Low-latency scheduling
+ * Preempt
+ * Read-latency 2
+ * Reverse mapping VM
+ * Supermount
+ * ACPI update
+ * Variable HZ (automatically tuned afaik)
+
+ From elsewhere:
+ * 3.5G Address space
+ * xattr+acl support
+ * TIOCGDEV support
+ * Grsecurity-1.9.8-rc2
+ * ACLs for JFS
+ * Optimizations for GCC3 compilation
+ * EVMS 1.2.1
+ * Additional Tekram SCSI Support
+ * KT400 pci.ids thanks to viz
+ * NTFS-tng 2.10a
+ * Support for the ECC driver
+ * Video 4 Linux v2 API
+ * MPPE support
+ * i2c-2.7.0
+ * Inode Monitor support
+ * Support for kernel config on /proc/config
+ * Updated support for aic7xxx SCSI cards
+ * Ext3 data=journal fix.
+ * Fix for 3c509
+ * Synced with almost all of the iptables patch-o-matic base
+ * XFS optional useflag with a warning about JFS
+ xfs+quota-v2+kdb support many thanks to dragon
+ * Encrypted loopback support (loop-jari)
+ * CryptoAPI support from www.kerneli.org
+ * Super Free S/WAN
+ * Quick bugfixes
+ * Defconfig with some reasonable stuff for this kernel
+ on gentoo
+ * Gentoo fb-logos
17 Dec 2002; Brandon Low <lostlogic@gentoo.org>:
Make all kernel-sources SLOT="${KV}"
diff --git a/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.20-r1 b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.20-r1
new file mode 100644
index 000000000000..18af8051baba
--- /dev/null
+++ b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.20-r1
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 1c4283aa5c293c0c1119e8147c50f92e patches-2.4.20-gentoo-r1.tar.bz2 3078465
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r1.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r1.ebuild
new file mode 100644
index 000000000000..f0306603eaab
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r1.ebuild,v 1.1 2003/01/12 19:20:36 lostlogic Exp $
+
+IUSE="build crypt xfs"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+OKV="2.4.20"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gentoo-sources-${PV}/patches.txt.gz with summary in
+# the package ChangeLog
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches... (USE='-crypt')"
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled... (USE='crypt')"
+ fi
+
+ # This is the non-ratified xfs USE flag, enables XFS which is not
+ # patched by default because it can cause problems with JFS's
+ # journals.
+ if [ -z "`use xfs`" ]; then
+ einfo "No XFS support, is this on purpose? (USE='-xfs')"
+ for file in 79*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ ewarn "Enabling XFS patch, are you sure you want this? (USE='xfs')"
+ fi
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "You have just installed a specialized, "
+ einfo "high performance patchset of the linux kernel."
+ einfo "If there are problems with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "lostlogic@gentoo.org"
+ [ `use xfs` ] && ewarn "XFS patches enabled, this may cause JFS problems" || \
+ einfo "XFS not enabled, is that on purpose? JFS users beware of XFS."
+
+}