summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-08-09 22:56:41 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-08-09 22:56:41 +0000
commit9fcc6c9933aa9b380eab99b4a866e9954d303ffc (patch)
tree604fbdb2e8b654d40515bf43f823075d751e4a53 /sys-kernel/alpha-sources
parentadded missing net-p2p/bittorrent (diff)
downloadgentoo-2-9fcc6c9933aa9b380eab99b4a866e9954d303ffc.tar.gz
gentoo-2-9fcc6c9933aa9b380eab99b4a866e9954d303ffc.tar.bz2
gentoo-2-9fcc6c9933aa9b380eab99b4a866e9954d303ffc.zip
Version bump for the /proc/cmdline leak vulnerability; bug #59905.
Diffstat (limited to 'sys-kernel/alpha-sources')
-rw-r--r--sys-kernel/alpha-sources/ChangeLog8
-rw-r--r--sys-kernel/alpha-sources/alpha-sources-2.4.21-r12.ebuild (renamed from sys-kernel/alpha-sources/alpha-sources-2.4.21-r11.ebuild)7
-rw-r--r--sys-kernel/alpha-sources/files/alpha-sources.cmdlineLeak.patch11
-rw-r--r--sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.21-r12 (renamed from sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.21-r11)0
4 files changed, 22 insertions, 4 deletions
diff --git a/sys-kernel/alpha-sources/ChangeLog b/sys-kernel/alpha-sources/ChangeLog
index e74da5bb7526..58bd6002c5dc 100644
--- a/sys-kernel/alpha-sources/ChangeLog
+++ b/sys-kernel/alpha-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/alpha-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/alpha-sources/ChangeLog,v 1.33 2004/08/08 15:46:46 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/alpha-sources/ChangeLog,v 1.34 2004/08/09 22:56:41 plasmaroo Exp $
+
+*alpha-sources-2.4.21-r12 (09 Aug 2004)
+
+ 09 Aug 2004; <plasmaroo@gentoo.org> -alpha-sources-2.4.21-r11.ebuild,
+ +alpha-sources-2.4.21-r12.ebuild, +files/alpha-sources.cmdlineLeak.patch:
+ Version bump for the /proc/cmdline leak vulnerability; bug #59905.
*alpha-sources-2.4.21-r11 (08 Aug 2004)
diff --git a/sys-kernel/alpha-sources/alpha-sources-2.4.21-r11.ebuild b/sys-kernel/alpha-sources/alpha-sources-2.4.21-r12.ebuild
index 7c3700d00157..acbaac22cc47 100644
--- a/sys-kernel/alpha-sources/alpha-sources-2.4.21-r11.ebuild
+++ b/sys-kernel/alpha-sources/alpha-sources-2.4.21-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/alpha-sources/alpha-sources-2.4.21-r11.ebuild,v 1.1 2004/08/08 15:32:20 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/alpha-sources/alpha-sources-2.4.21-r12.ebuild,v 1.1 2004/08/09 22:56:41 plasmaroo Exp $
# OKV=original kernel version, KV=patched kernel version. They can be the same.
@@ -16,7 +16,7 @@ S=${WORKDIR}/linux-${KV}
DESCRIPTION="Full sources for the Gentoo Linux Alpha kernel"
SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- mirror://gentoo/patches-${KV/11/3}.tar.bz2
+ mirror://gentoo/patches-${KV/12/3}.tar.bz2
http://dev.gentoo.org/~plasmaroo/patches/kernel/misc/security/linux-${OKV}-CAN-2004-0415.patch"
SLOT="${KV}"
KEYWORDS="alpha -sparc -x86 -ppc -hppa -mips"
@@ -24,7 +24,7 @@ KEYWORDS="alpha -sparc -x86 -ppc -hppa -mips"
src_unpack() {
unpack ${A}
mv linux-${OKV} linux-${KV} || die
- cd ${WORKDIR}/${KV/11/1}
+ cd ${WORKDIR}/${KV/12/1}
# This is the crypt USE flag, keeps {USAGI/superfreeswan/patch-int/loop-jari}
if ! use crypt; then
@@ -76,6 +76,7 @@ src_unpack() {
epatch ${FILESDIR}/${PN}.CAN-2004-0685.patch || die "Failed to add the CAN-2004-0685 patch!"
epatch ${FILESDIR}/${PN}.rtc_fix.patch || die "Failed to patch RTC vulnerabilities!"
epatch ${FILESDIR}/${PN}.munmap.patch || die "Failed to apply munmap patch!"
+ epatch ${FILESDIR}/${PN}.cmdlineLeak.patch || die "Failed to apply the /proc/cmdline patch!"
# Fix multi-line literal in include/asm-alpha/xor.h -- see bug 38354
# If this script "dies" then that means it's no longer applicable.
diff --git a/sys-kernel/alpha-sources/files/alpha-sources.cmdlineLeak.patch b/sys-kernel/alpha-sources/files/alpha-sources.cmdlineLeak.patch
new file mode 100644
index 000000000000..5f26f7f388f6
--- /dev/null
+++ b/sys-kernel/alpha-sources/files/alpha-sources.cmdlineLeak.patch
@@ -0,0 +1,11 @@
+--- linux-2.4/fs/proc/base.c 2004-04-15 07:09:32.000000000 +0100
++++ linux-2.4/fs/proc/base.c.plasmaroo 2004-08-09 23:30:43.869195800 +0100
+@@ -187,7 +187,7 @@ static int proc_pid_cmdline(struct task_
+ if (mm)
+ atomic_inc(&mm->mm_users);
+ task_unlock(task);
+- if (mm) {
++ if (mm && mm->arg_end) {
+ int len = mm->arg_end - mm->arg_start;
+ if (len > PAGE_SIZE)
+ len = PAGE_SIZE;
diff --git a/sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.21-r11 b/sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.21-r12
index 363cacc1766b..363cacc1766b 100644
--- a/sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.21-r11
+++ b/sys-kernel/alpha-sources/files/digest-alpha-sources-2.4.21-r12