summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-04-12 18:13:44 +0000
committerMike Frysinger <vapier@gentoo.org>2015-04-12 18:13:44 +0000
commit990301cb12e4649dab1272adada3ab5697336f95 (patch)
tree6eed408ff7ccf37ae2375c7b4d8bc1952231f2ea /sys-fs
parentMark alpha/arm64/ia64/s390/sh/sparc stable and add mips #527672. (diff)
downloadgentoo-2-990301cb12e4649dab1272adada3ab5697336f95.tar.gz
gentoo-2-990301cb12e4649dab1272adada3ab5697336f95.tar.bz2
gentoo-2-990301cb12e4649dab1272adada3ab5697336f95.zip
Add USE=pwquality to control libpwquality dep #492624 by Nikoli.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup/ChangeLog6
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.6.5.ebuild8
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.6.6.ebuild8
-rw-r--r--sys-fs/cryptsetup/metadata.xml1
4 files changed, 16 insertions, 7 deletions
diff --git a/sys-fs/cryptsetup/ChangeLog b/sys-fs/cryptsetup/ChangeLog
index 2af8de4755ed..d59b72cc8637 100644
--- a/sys-fs/cryptsetup/ChangeLog
+++ b/sys-fs/cryptsetup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/cryptsetup
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.197 2015/04/08 18:27:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.198 2015/04/12 18:13:44 vapier Exp $
+
+ 12 Apr 2015; Mike Frysinger <vapier@gentoo.org> cryptsetup-1.6.5.ebuild,
+ cryptsetup-1.6.6.ebuild, metadata.xml:
+ Add USE=pwquality to control libpwquality dep #492624 by Nikoli.
08 Apr 2015; Michał Górny <mgorny@gentoo.org> cryptsetup-1.6.2.ebuild:
Drop old Python implementations
diff --git a/sys-fs/cryptsetup/cryptsetup-1.6.5.ebuild b/sys-fs/cryptsetup/cryptsetup-1.6.5.ebuild
index db6e3a9a83d9..9dc31567e4c4 100644
--- a/sys-fs/cryptsetup/cryptsetup-1.6.5.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-1.6.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.6.5.ebuild,v 1.16 2014/11/01 01:08:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.6.5.ebuild,v 1.17 2015/04/12 18:13:44 vapier Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -18,7 +18,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
CRYPTO_BACKENDS="+gcrypt kernel nettle openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
-IUSE="${CRYPTO_BACKENDS} nls python reencrypt static static-libs udev urandom"
+IUSE="${CRYPTO_BACKENDS} nls pwquality python reencrypt static static-libs udev urandom"
REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
python? ( ${PYTHON_REQUIRED_USE} )
static? ( !gcrypt )" #496612
@@ -29,6 +29,7 @@ LIB_DEPEND="dev-libs/libgpg-error[static-libs(+)]
gcrypt? ( dev-libs/libgcrypt:0=[static-libs(+)] )
nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
openssl? ( dev-libs/openssl[static-libs(+)] )
+ pwquality? ( dev-libs/libpwquality[static-libs(+)] )
sys-fs/lvm2[static-libs(+)]
udev? ( virtual/libudev[static-libs(+)] )"
# We have to always depend on ${LIB_DEPEND} rather than put behind
@@ -69,6 +70,7 @@ src_configure() {
$(use_enable static static-cryptsetup) \
$(use_enable static-libs static) \
$(use_enable nls) \
+ $(use_enable pwquality) \
$(use_enable python) \
$(use_enable reencrypt cryptsetup-reencrypt) \
$(use_enable udev) \
diff --git a/sys-fs/cryptsetup/cryptsetup-1.6.6.ebuild b/sys-fs/cryptsetup/cryptsetup-1.6.6.ebuild
index a0c525f7c7fe..21abcacfe588 100644
--- a/sys-fs/cryptsetup/cryptsetup-1.6.6.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-1.6.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.6.6.ebuild,v 1.11 2014/11/09 05:48:12 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.6.6.ebuild,v 1.12 2015/04/12 18:13:44 vapier Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -18,7 +18,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
CRYPTO_BACKENDS="+gcrypt kernel nettle openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
-IUSE="${CRYPTO_BACKENDS} nls python reencrypt static static-libs udev urandom"
+IUSE="${CRYPTO_BACKENDS} nls pwquality python reencrypt static static-libs udev urandom"
REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
python? ( ${PYTHON_REQUIRED_USE} )
static? ( !gcrypt )" #496612
@@ -29,6 +29,7 @@ LIB_DEPEND="dev-libs/libgpg-error[static-libs(+)]
gcrypt? ( dev-libs/libgcrypt:0=[static-libs(+)] )
nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
openssl? ( dev-libs/openssl[static-libs(+)] )
+ pwquality? ( dev-libs/libpwquality[static-libs(+)] )
sys-fs/lvm2[static-libs(+)]
udev? ( virtual/libudev[static-libs(+)] )"
# We have to always depend on ${LIB_DEPEND} rather than put behind
@@ -69,6 +70,7 @@ src_configure() {
$(use_enable static static-cryptsetup) \
$(use_enable static-libs static) \
$(use_enable nls) \
+ $(use_enable pwquality) \
$(use_enable python) \
$(use_enable reencrypt cryptsetup-reencrypt) \
$(use_enable udev) \
diff --git a/sys-fs/cryptsetup/metadata.xml b/sys-fs/cryptsetup/metadata.xml
index eb7aa91555e0..17bad91dcee8 100644
--- a/sys-fs/cryptsetup/metadata.xml
+++ b/sys-fs/cryptsetup/metadata.xml
@@ -7,6 +7,7 @@
<flag name="kernel">Use kernel crypto backend (mainly for embedded systems)</flag>
<flag name="nettle">Use <pkg>dev-libs/nettle</pkg> crypto backend</flag>
<flag name="openssl">Use <pkg>dev-libs/openssl</pkg> crypto backend</flag>
+ <flag name="pwquality">Use <pkg>dev-libs/libpwquality</pkg> for password quality checking</flag>
<flag name="urandom">Use /dev/urandom instead of /dev/random</flag>
<flag name="reencrypt">Build cryptsetup-reencrypt</flag>
</use>