summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-04-05 12:37:30 +0000
committerThomas Sachau <tommy@gentoo.org>2010-04-05 12:37:30 +0000
commit4d6f911be96cd3de6b1c2b02d996380205b2077e (patch)
tree63b6aa6e8d4da24341b0b2a2e9b7cc9fe90c8d5b /sys-fs
parentVersion bump (diff)
downloadgentoo-2-4d6f911be96cd3de6b1c2b02d996380205b2077e.tar.gz
gentoo-2-4d6f911be96cd3de6b1c2b02d996380205b2077e.tar.bz2
gentoo-2-4d6f911be96cd3de6b1c2b02d996380205b2077e.zip
Version bump
(Portage version: 2.2_rc67-r3/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs2/ChangeLog10
-rw-r--r--sys-fs/aufs2/aufs2-0_p20100405.ebuild (renamed from sys-fs/aufs2/aufs2-0_p20091214.ebuild)10
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-31.patch69
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-32.patch88
-rw-r--r--sys-fs/aufs2/files/aufs2-standalone-33.patch69
5 files changed, 238 insertions, 8 deletions
diff --git a/sys-fs/aufs2/ChangeLog b/sys-fs/aufs2/ChangeLog
index bd6627cb41b7..32d2d6301645 100644
--- a/sys-fs/aufs2/ChangeLog
+++ b/sys-fs/aufs2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/aufs2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.17 2010/03/17 15:42:57 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/ChangeLog,v 1.18 2010/04/05 12:37:30 tommy Exp $
+
+*aufs2-0_p20100405 (05 Apr 2010)
+
+ 05 Apr 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ -aufs2-0_p20091214.ebuild, +aufs2-0_p20100405.ebuild,
+ files/aufs2-standalone-31.patch, files/aufs2-standalone-32.patch,
+ files/aufs2-standalone-33.patch:
+ Version bump
17 Mar 2010; Sebastian Pipping <sping@gentoo.org>
aufs2-0_p20091214.ebuild, aufs2-0_p20100308.ebuild:
diff --git a/sys-fs/aufs2/aufs2-0_p20091214.ebuild b/sys-fs/aufs2/aufs2-0_p20100405.ebuild
index 0e94165ba69a..23442a49ef1b 100644
--- a/sys-fs/aufs2/aufs2-0_p20091214.ebuild
+++ b/sys-fs/aufs2/aufs2-0_p20100405.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20091214.ebuild,v 1.2 2010/03/17 15:42:57 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs2/aufs2-0_p20100405.ebuild,v 1.1 2010/04/05 12:37:30 tommy Exp $
EAPI="2"
-inherit linux-mod toolchain-funcs
+inherit linux-mod multilib toolchain-funcs
DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
HOMEPAGE="http://aufs.sourceforge.net"
@@ -25,7 +25,7 @@ MODULE_NAMES="aufs(misc:${S})"
pkg_setup() {
get_version
kernel_is lt 2 6 27 && die "kernel too old"
- kernel_is gt 2 6 32 && die "kernel too new"
+ kernel_is gt 2 6 33 && die "kernel too new"
if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-standalone-${KV_PATCH}.patch >/dev/null && \
patch -p1 --dry-run --force -R -d ${KV_DIR} < "${FILESDIR}"/aufs2-base-${KV_PATCH}.patch >/dev/null ); then
@@ -50,9 +50,6 @@ pkg_setup() {
src_prepare() {
local branch=origin/aufs2-${KV_PATCH}
- if [[ $KV_PATCH == 33 ]] ; then
- branch=origin/aufs2
- fi
git checkout -q $branch || die
if ! use debug; then
sed -i "s:DEBUG = y:DEBUG =:g" config.mk || die
@@ -66,6 +63,7 @@ src_prepare() {
cd "${WORKDIR}"/${PN}-util
sed -i "/LDFLAGS += -static -s/d" Makefile || die
+ sed -i -e "s:m 644 -s:m 644:g" -e "s:/usr/lib:/usr/$(get_libdir):g" libau/Makefile || die
}
src_compile() {
diff --git a/sys-fs/aufs2/files/aufs2-standalone-31.patch b/sys-fs/aufs2/files/aufs2-standalone-31.patch
index d9b492284011..44f8e59ebf91 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-31.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-31.patch
@@ -40,6 +40,75 @@ index 7230787..8269b66 100644
static int event;
static DEFINE_IDA(mnt_id_ida);
+diff --git a/fs/notify/group.c b/fs/notify/group.c
+index 0e16771..3fab10a 100644
+--- a/fs/notify/group.c
++++ b/fs/notify/group.c
+@@ -22,6 +22,7 @@
+ #include <linux/srcu.h>
+ #include <linux/rculist.h>
+ #include <linux/wait.h>
++#include <linux/module.h>
+
+ #include <linux/fsnotify_backend.h>
+ #include "fsnotify.h"
+@@ -169,6 +170,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
+ fsnotify_recalc_global_mask();
+ fsnotify_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_put_group);
+
+ /*
+ * Simply run the fsnotify_groups list and find a group which matches
+@@ -252,3 +254,4 @@ struct fsnotify_group *fsnotify_obtain_group(unsigned int group_num, __u32 mask,
+
+ return group;
+ }
++EXPORT_SYMBOL(fsnotify_obtain_group);
+diff --git a/fs/notify/inode_mark.c b/fs/notify/inode_mark.c
+index c8a07c6..c5a229b 100644
+--- a/fs/notify/inode_mark.c
++++ b/fs/notify/inode_mark.c
+@@ -106,6 +106,7 @@ void fsnotify_put_mark(struct fsnotify_mark_entry *entry)
+ if (atomic_dec_and_test(&entry->refcnt))
+ entry->free_mark(entry);
+ }
++EXPORT_SYMBOL(fsnotify_put_mark);
+
+ /*
+ * Recalculate the mask of events relevant to a given inode locked.
+@@ -216,6 +217,7 @@ void fsnotify_destroy_mark_by_entry(struct fsnotify_mark_entry *entry)
+ if (unlikely(atomic_dec_and_test(&group->num_marks)))
+ fsnotify_final_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_destroy_mark_by_entry);
+
+ /*
+ * Given a group, destroy all of the marks associated with that group.
+@@ -282,6 +284,7 @@ struct fsnotify_mark_entry *fsnotify_find_mark_entry(struct fsnotify_group *grou
+ }
+ return NULL;
+ }
++EXPORT_SYMBOL(fsnotify_find_mark_entry);
+
+ /*
+ * Nothing fancy, just initialize lists and locks and counters.
+@@ -298,6 +301,7 @@ void fsnotify_init_mark(struct fsnotify_mark_entry *entry,
+ entry->inode = NULL;
+ entry->free_mark = free_mark;
+ }
++EXPORT_SYMBOL(fsnotify_init_mark);
+
+ /*
+ * Attach an initialized mark entry to a given group and inode.
+@@ -353,6 +357,7 @@ int fsnotify_add_mark(struct fsnotify_mark_entry *entry,
+
+ return ret;
+ }
++EXPORT_SYMBOL(fsnotify_add_mark);
+
+ /**
+ * fsnotify_unmount_inodes - an sb is unmounting. handle any watched inodes.
diff --git a/fs/open.c b/fs/open.c
index dd98e80..04b9aad 100644
--- a/fs/open.c
diff --git a/sys-fs/aufs2/files/aufs2-standalone-32.patch b/sys-fs/aufs2/files/aufs2-standalone-32.patch
index 1780b91e0616..5409830688ec 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-32.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-32.patch
@@ -40,6 +40,75 @@ index bdc3cb4..a2cadcf 100644
static int event;
static DEFINE_IDA(mnt_id_ida);
+diff --git a/fs/notify/group.c b/fs/notify/group.c
+index 0e16771..3fab10a 100644
+--- a/fs/notify/group.c
++++ b/fs/notify/group.c
+@@ -22,6 +22,7 @@
+ #include <linux/srcu.h>
+ #include <linux/rculist.h>
+ #include <linux/wait.h>
++#include <linux/module.h>
+
+ #include <linux/fsnotify_backend.h>
+ #include "fsnotify.h"
+@@ -169,6 +170,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
+ fsnotify_recalc_global_mask();
+ fsnotify_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_put_group);
+
+ /*
+ * Simply run the fsnotify_groups list and find a group which matches
+@@ -252,3 +254,4 @@ struct fsnotify_group *fsnotify_obtain_group(unsigned int group_num, __u32 mask,
+
+ return group;
+ }
++EXPORT_SYMBOL(fsnotify_obtain_group);
+diff --git a/fs/notify/inode_mark.c b/fs/notify/inode_mark.c
+index 3165d85..4586162 100644
+--- a/fs/notify/inode_mark.c
++++ b/fs/notify/inode_mark.c
+@@ -106,6 +106,7 @@ void fsnotify_put_mark(struct fsnotify_mark_entry *entry)
+ if (atomic_dec_and_test(&entry->refcnt))
+ entry->free_mark(entry);
+ }
++EXPORT_SYMBOL(fsnotify_put_mark);
+
+ /*
+ * Recalculate the mask of events relevant to a given inode locked.
+@@ -216,6 +217,7 @@ void fsnotify_destroy_mark_by_entry(struct fsnotify_mark_entry *entry)
+ if (unlikely(atomic_dec_and_test(&group->num_marks)))
+ fsnotify_final_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_destroy_mark_by_entry);
+
+ /*
+ * Given a group, destroy all of the marks associated with that group.
+@@ -282,6 +284,7 @@ struct fsnotify_mark_entry *fsnotify_find_mark_entry(struct fsnotify_group *grou
+ }
+ return NULL;
+ }
++EXPORT_SYMBOL(fsnotify_find_mark_entry);
+
+ /*
+ * Nothing fancy, just initialize lists and locks and counters.
+@@ -298,6 +301,7 @@ void fsnotify_init_mark(struct fsnotify_mark_entry *entry,
+ entry->inode = NULL;
+ entry->free_mark = free_mark;
+ }
++EXPORT_SYMBOL(fsnotify_init_mark);
+
+ /*
+ * Attach an initialized mark entry to a given group and inode.
+@@ -353,6 +357,7 @@ int fsnotify_add_mark(struct fsnotify_mark_entry *entry,
+
+ return ret;
+ }
++EXPORT_SYMBOL(fsnotify_add_mark);
+
+ /**
+ * fsnotify_unmount_inodes - an sb is unmounting. handle any watched inodes.
diff --git a/fs/open.c b/fs/open.c
index 4f01e06..ef09031 100644
--- a/fs/open.c
@@ -72,6 +141,15 @@ index 77184f0..8479d95 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
+diff --git a/security/commoncap.c b/security/commoncap.c
+index fe30751..813108d 100644
+--- a/security/commoncap.c
++++ b/security/commoncap.c
+@@ -1014,3 +1014,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
+ }
+ return ret;
+ }
++EXPORT_SYMBOL(cap_file_mmap);
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 6cf8fd2..008e0d8 100644
--- a/security/device_cgroup.c
@@ -97,7 +175,7 @@ index b85e61b..a23fad4 100644
/**
* ima_bprm_check - based on policy, collect/store measurement.
diff --git a/security/security.c b/security/security.c
-index c4c6732..854d15c 100644
+index c4c6732..092cd90 100644
--- a/security/security.c
+++ b/security/security.c
@@ -386,6 +386,7 @@ int security_path_mkdir(struct path *path, struct dentry *dentry, int mode)
@@ -180,3 +258,11 @@ index c4c6732..854d15c 100644
int security_file_alloc(struct file *file)
{
+@@ -641,6 +651,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
+ {
+ return security_ops->file_mmap(file, reqprot, prot, flags, addr, addr_only);
+ }
++EXPORT_SYMBOL(security_file_mmap);
+
+ int security_file_mprotect(struct vm_area_struct *vma, unsigned long reqprot,
+ unsigned long prot)
diff --git a/sys-fs/aufs2/files/aufs2-standalone-33.patch b/sys-fs/aufs2/files/aufs2-standalone-33.patch
index 8ea735b788f2..c945ba15edcd 100644
--- a/sys-fs/aufs2/files/aufs2-standalone-33.patch
+++ b/sys-fs/aufs2/files/aufs2-standalone-33.patch
@@ -40,6 +40,75 @@ index c768f73..0fd78c3 100644
static int event;
static DEFINE_IDA(mnt_id_ida);
+diff --git a/fs/notify/group.c b/fs/notify/group.c
+index 0e16771..3fab10a 100644
+--- a/fs/notify/group.c
++++ b/fs/notify/group.c
+@@ -22,6 +22,7 @@
+ #include <linux/srcu.h>
+ #include <linux/rculist.h>
+ #include <linux/wait.h>
++#include <linux/module.h>
+
+ #include <linux/fsnotify_backend.h>
+ #include "fsnotify.h"
+@@ -169,6 +170,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
+ fsnotify_recalc_global_mask();
+ fsnotify_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_put_group);
+
+ /*
+ * Simply run the fsnotify_groups list and find a group which matches
+@@ -252,3 +254,4 @@ struct fsnotify_group *fsnotify_obtain_group(unsigned int group_num, __u32 mask,
+
+ return group;
+ }
++EXPORT_SYMBOL(fsnotify_obtain_group);
+diff --git a/fs/notify/inode_mark.c b/fs/notify/inode_mark.c
+index 3165d85..4586162 100644
+--- a/fs/notify/inode_mark.c
++++ b/fs/notify/inode_mark.c
+@@ -106,6 +106,7 @@ void fsnotify_put_mark(struct fsnotify_mark_entry *entry)
+ if (atomic_dec_and_test(&entry->refcnt))
+ entry->free_mark(entry);
+ }
++EXPORT_SYMBOL(fsnotify_put_mark);
+
+ /*
+ * Recalculate the mask of events relevant to a given inode locked.
+@@ -216,6 +217,7 @@ void fsnotify_destroy_mark_by_entry(struct fsnotify_mark_entry *entry)
+ if (unlikely(atomic_dec_and_test(&group->num_marks)))
+ fsnotify_final_destroy_group(group);
+ }
++EXPORT_SYMBOL(fsnotify_destroy_mark_by_entry);
+
+ /*
+ * Given a group, destroy all of the marks associated with that group.
+@@ -282,6 +284,7 @@ struct fsnotify_mark_entry *fsnotify_find_mark_entry(struct fsnotify_group *grou
+ }
+ return NULL;
+ }
++EXPORT_SYMBOL(fsnotify_find_mark_entry);
+
+ /*
+ * Nothing fancy, just initialize lists and locks and counters.
+@@ -298,6 +301,7 @@ void fsnotify_init_mark(struct fsnotify_mark_entry *entry,
+ entry->inode = NULL;
+ entry->free_mark = free_mark;
+ }
++EXPORT_SYMBOL(fsnotify_init_mark);
+
+ /*
+ * Attach an initialized mark entry to a given group and inode.
+@@ -353,6 +357,7 @@ int fsnotify_add_mark(struct fsnotify_mark_entry *entry,
+
+ return ret;
+ }
++EXPORT_SYMBOL(fsnotify_add_mark);
+
+ /**
+ * fsnotify_unmount_inodes - an sb is unmounting. handle any watched inodes.
diff --git a/fs/open.c b/fs/open.c
index 040cef7..453b782 100644
--- a/fs/open.c