summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-04 18:58:59 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-04 18:58:59 +0000
commit0735b72ca0f241feb4dfb7cd1fb5402bf15ef59b (patch)
tree00fdbf46ecc28e6cc47b440df96271c496b6b511 /sys-fs
parentSwitch to EAPI5 and respect RANLIB (bug #468188) (diff)
downloadgentoo-2-0735b72ca0f241feb4dfb7cd1fb5402bf15ef59b.tar.gz
gentoo-2-0735b72ca0f241feb4dfb7cd1fb5402bf15ef59b.tar.bz2
gentoo-2-0735b72ca0f241feb4dfb7cd1fb5402bf15ef59b.zip
Version bump (bug #464610 by Manuel Rüger), convert to python-single-r1, add support for choosing a crypto backend (gcrypt, kernel, nettle, or openssl), remove old postinst warning, and only show postinst logs on new installs.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cryptsetup/ChangeLog10
-rw-r--r--sys-fs/cryptsetup/cryptsetup-1.6.1.ebuild123
-rw-r--r--sys-fs/cryptsetup/metadata.xml4
3 files changed, 136 insertions, 1 deletions
diff --git a/sys-fs/cryptsetup/ChangeLog b/sys-fs/cryptsetup/ChangeLog
index f5487de650bc..42c099915246 100644
--- a/sys-fs/cryptsetup/ChangeLog
+++ b/sys-fs/cryptsetup/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/cryptsetup
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.149 2013/04/09 10:06:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/ChangeLog,v 1.150 2013/06/04 18:58:59 radhermit Exp $
+
+*cryptsetup-1.6.1 (04 Jun 2013)
+
+ 04 Jun 2013; Tim Harder <radhermit@gentoo.org> +cryptsetup-1.6.1.ebuild,
+ metadata.xml:
+ Version bump (bug #464610 by Manuel Rüger), convert to python-single-r1, add
+ support for choosing a crypto backend (gcrypt, kernel, nettle, or openssl),
+ remove old postinst warning, and only show postinst logs on new installs.
09 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
cryptsetup-1.0.6-r2.ebuild:
diff --git a/sys-fs/cryptsetup/cryptsetup-1.6.1.ebuild b/sys-fs/cryptsetup/cryptsetup-1.6.1.ebuild
new file mode 100644
index 000000000000..81cfcf90194b
--- /dev/null
+++ b/sys-fs/cryptsetup/cryptsetup-1.6.1.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-1.6.1.ebuild,v 1.1 2013/06/04 18:58:59 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit python-single-r1 linux-info libtool eutils
+
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://code.google.com/p/cryptsetup/"
+SRC_URI="http://cryptsetup.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+CRYPTO_BACKENDS="+gcrypt kernel nettle openssl"
+# we don't support nss since it doesn't allow cryptsetup to be built statically
+# and it's missing ripemd160 support so it can't provide full backward compatibility
+IUSE="${CRYPTO_BACKENDS} nls python reencrypt selinux static static-libs udev urandom"
+REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+LIB_DEPEND="dev-libs/libgpg-error[static-libs(+)]
+ dev-libs/popt[static-libs(+)]
+ sys-apps/util-linux[static-libs(+)]
+ gcrypt? ( dev-libs/libgcrypt[-caps,static-libs(+)] )
+ nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
+ openssl? ( dev-libs/openssl[static-libs(+)] )
+ sys-fs/lvm2[static-libs(+)]
+ sys-libs/e2fsprogs-libs[static-libs(+)]
+ udev? ( virtual/udev[static-libs(+)] )"
+# We have to always depend on ${LIB_DEPEND} rather than put behind
+# static? () because we provide a shared library which links against
+# these other packages. #414665
+RDEPEND="static-libs? ( ${LIB_DEPEND} )
+ ${LIB_DEPEND//\[static-libs(+)]}
+ selinux? ( sys-libs/libselinux )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ static? ( ${LIB_DEPEND} )"
+
+pkg_setup() {
+ local CONFIG_CHECK="~DM_CRYPT ~CRYPTO ~CRYPTO_CBC"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup)\n"
+ local WARNING_CRYPTO_CBC="CONFIG_CRYPTO_CBC:\tis not set (required for kernel 2.6.19)\n"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup)\n"
+ check_extra_config
+
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i '/^LOOPDEV=/s:$: || exit 0:' tests/{compat,mode}-test || die
+ elibtoolize
+}
+
+src_configure() {
+ if use kernel ; then
+ ewarn "Note that kernel backend is very slow for this type of operation"
+ ewarn "and is provided mainly for embedded systems wanting to avoid"
+ ewarn "userspace crypto libraries."
+ fi
+
+ econf \
+ --sbindir=/sbin \
+ --enable-shared \
+ $(use_enable static static-cryptsetup) \
+ $(use_enable static-libs static) \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable reencrypt cryptsetup-reencrypt) \
+ $(use_enable selinux) \
+ $(use_enable udev) \
+ $(use_enable !urandom dev-random) \
+ --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/}; do use ${x} && echo ${x} ; done)
+}
+
+src_test() {
+ if [[ ! -e /dev/mapper/control ]] ; then
+ ewarn "No /dev/mapper/control found -- skipping tests"
+ return 0
+ fi
+ local p
+ for p in /dev/mapper /dev/loop* ; do
+ addwrite ${p}
+ done
+ default
+}
+
+src_install() {
+ default
+ if use static ; then
+ mv "${ED}"/sbin/cryptsetup{.static,} || die
+ mv "${ED}"/sbin/veritysetup{.static,} || die
+ use reencrypt && { mv "${ED}"/sbin/cryptsetup-reencrypt{.static,} || die ; }
+ fi
+ prune_libtool_files --modules
+
+ newconfd "${FILESDIR}"/1.0.6-dmcrypt.confd dmcrypt
+ newinitd "${FILESDIR}"/1.5.1-dmcrypt.rc dmcrypt
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Please see the example for configuring a LUKS mountpoint"
+ elog "in /etc/conf.d/dmcrypt"
+ elog
+ elog "If you are using baselayout-2 then please do:"
+ elog "rc-update add dmcrypt boot"
+ elog "This version introduces a command line arguement 'key_timeout'."
+ elog "If you want the search for the removable key device to timeout"
+ elog "after 10 seconds add the following to your bootloader config:"
+ elog "key_timeout=10"
+ elog "A timeout of 0 will mean it will wait indefinitely."
+ elog
+ elog "Users using cryptsetup-1.0.x (dm-crypt plain) volumes must use"
+ elog "a compatibility mode when using cryptsetup-1.1.x. This can be"
+ elog "done by specifying the cipher (-c), key size (-s) and hash (-h)."
+ elog "For more info, see http://code.google.com/p/cryptsetup/wiki/FrequentlyAskedQuestions#6._Issues_with_Specific_Versions_of_cryptsetup"
+ fi
+}
diff --git a/sys-fs/cryptsetup/metadata.xml b/sys-fs/cryptsetup/metadata.xml
index c8836af873d7..94de4f606bc4 100644
--- a/sys-fs/cryptsetup/metadata.xml
+++ b/sys-fs/cryptsetup/metadata.xml
@@ -4,6 +4,10 @@
<herd>base-system</herd>
<use>
<flag name="dynamic">Build cryptsetup dynamically</flag>
+ <flag name="gcrypt">Enable the <pkg>dev-libs/libgcrypt</pkg> crypto backend</flag>
+ <flag name="kernel">Enable the kernel crypto backend</flag>
+ <flag name="nettle">Enable the <pkg>dev-libs/nettle</pkg> crypto backend</flag>
+ <flag name="openssl">Enable the <pkg>dev-libs/openssl</pkg> crypto backend</flag>
<flag name="urandom">Use /dev/urandom instead of /dev/random</flag>
<flag name="reencrypt">Build cryptsetup-reencrypt</flag>
</use>