summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-03-23 23:50:17 +0000
committerRichard Yao <ryao@gentoo.org>2013-03-23 23:50:17 +0000
commitcf7f05eac793dda55a2750471a2bf4569043d727 (patch)
tree065d2850b4df0a6ad4c77174df86de89d3868e13 /sys-fs/zfs-kmod
parentFree memory more quickly under memory pressure; do not dodoc INSTALL (depreca... (diff)
downloadgentoo-2-cf7f05eac793dda55a2750471a2bf4569043d727.tar.gz
gentoo-2-cf7f05eac793dda55a2750471a2bf4569043d727.tar.bz2
gentoo-2-cf7f05eac793dda55a2750471a2bf4569043d727.zip
Enable zfs_arc_memory_throttle_disable by default
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'sys-fs/zfs-kmod')
-rw-r--r--sys-fs/zfs-kmod/ChangeLog9
-rw-r--r--sys-fs/zfs-kmod/files/zfs-kmod-0.6.0_rc14-zfs_arc_memory_throttle_disable.patch41
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14-r5.ebuild (renamed from sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14-r4.ebuild)5
3 files changed, 53 insertions, 2 deletions
diff --git a/sys-fs/zfs-kmod/ChangeLog b/sys-fs/zfs-kmod/ChangeLog
index c60cbd89db75..2dd1d1570c05 100644
--- a/sys-fs/zfs-kmod/ChangeLog
+++ b/sys-fs/zfs-kmod/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/zfs-kmod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.23 2013/03/16 18:06:07 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.24 2013/03/23 23:50:17 ryao Exp $
+
+*zfs-kmod-0.6.0_rc14-r5 (23 Mar 2013)
+
+ 23 Mar 2013; Richard Yao <ryao@gentoo.org>
+ +files/zfs-kmod-0.6.0_rc14-zfs_arc_memory_throttle_disable.patch,
+ +zfs-kmod-0.6.0_rc14-r5.ebuild, -zfs-kmod-0.6.0_rc14-r4.ebuild:
+ Enable zfs_arc_memory_throttle_disable by default
16 Mar 2013; Richard Yao <ryao@gentoo.org> zfs-kmod-0.6.0_rc10-r2.ebuild,
zfs-kmod-0.6.0_rc11-r3.ebuild, zfs-kmod-0.6.0_rc12-r3.ebuild,
diff --git a/sys-fs/zfs-kmod/files/zfs-kmod-0.6.0_rc14-zfs_arc_memory_throttle_disable.patch b/sys-fs/zfs-kmod/files/zfs-kmod-0.6.0_rc14-zfs_arc_memory_throttle_disable.patch
new file mode 100644
index 000000000000..81ec15f3e6c7
--- /dev/null
+++ b/sys-fs/zfs-kmod/files/zfs-kmod-0.6.0_rc14-zfs_arc_memory_throttle_disable.patch
@@ -0,0 +1,41 @@
+From 546c978bbd3f132a88609cab15ec0e954eaa62b8 Mon Sep 17 00:00:00 2001
+From: Brian Behlendorf <behlendorf1@llnl.gov>
+Date: Thu, 21 Feb 2013 12:14:44 -0800
+Subject: [PATCH] Enable zfs_arc_memory_throttle_disable by default
+
+The zfs_arc_memory_throttle_disable module option was introduced
+by commit 0c5493d47059f25ce9dbf20c9fe87655f55102a1 to resolve a
+memory miscalculation which could result in the txg_sync thread
+spinning.
+
+When this was first introduced the default behavior was left
+unchanged until enough real world usage confirmed there were no
+unexpected issues. We've now reached that point. Linux's
+direct reclaim is working as expected so we're enabling this
+behavior by default.
+
+This helps pave the way to retire the spl_kmem_availrmem()
+functionality in the SPL layer. This was the only caller.
+
+Signed-off-by: Brian Behlendorf <behlendorf1@llnl.gov>
+Issue #938
+---
+ module/zfs/arc.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/module/zfs/arc.c b/module/zfs/arc.c
+index 09924db..b7499ee 100644
+--- a/module/zfs/arc.c
++++ b/module/zfs/arc.c
+@@ -189,7 +189,7 @@
+ int zfs_arc_grow_retry = 0;
+ int zfs_arc_shrink_shift = 0;
+ int zfs_arc_p_min_shift = 0;
+-int zfs_arc_memory_throttle_disable = 0;
++int zfs_arc_memory_throttle_disable = 1;
+ int zfs_disable_dup_eviction = 0;
+ int zfs_arc_meta_prune = 0;
+
+--
+1.8.1.5
+
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14-r4.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14-r5.ebuild
index 7ab70f913235..5b0e51c9e09a 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14-r4.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14-r4.ebuild,v 1.3 2013/03/16 18:06:07 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-0.6.0_rc14-r5.ebuild,v 1.1 2013/03/23 23:50:17 ryao Exp $
EAPI="4"
@@ -83,6 +83,9 @@ src_prepare() {
# Linux 3.9 Support
epatch "${FILESDIR}/${P}-linux-3.9-compat.patch"
+
+ # Do not second guess Linux's memory management
+ epatch "${FILESDIR}/${P}-zfs_arc_memory_throttle_disable.patch"
fi
# Remove GPLv2-licensed ZPIOS unless we are debugging