summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2014-03-09 03:13:00 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2014-03-09 03:13:00 +0000
commit9da339ce96bebc42f4d98d13587bdf58cff6a149 (patch)
treee44a3a7272200d5d023935ee64da83779c564d87 /sys-fs/multipath-tools
parentVersion bump. (diff)
downloadgentoo-2-9da339ce96bebc42f4d98d13587bdf58cff6a149.tar.gz
gentoo-2-9da339ce96bebc42f4d98d13587bdf58cff6a149.tar.bz2
gentoo-2-9da339ce96bebc42f4d98d13587bdf58cff6a149.zip
Use pkg-config to find correct systemd libraries. Fixes #502446.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/ChangeLog7
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.5.0-systemd-pkgconfig.patch24
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.5.0-r1.ebuild3
3 files changed, 32 insertions, 2 deletions
diff --git a/sys-fs/multipath-tools/ChangeLog b/sys-fs/multipath-tools/ChangeLog
index 1181b4b3220d..8f153a47a2dc 100644
--- a/sys-fs/multipath-tools/ChangeLog
+++ b/sys-fs/multipath-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/multipath-tools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.64 2014/03/02 22:35:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.65 2014/03/09 03:13:00 zx2c4 Exp $
+
+ 09 Mar 2014; Jason A. Donenfeld <zx2c4@gentoo.org>
+ +files/multipath-tools-0.5.0-systemd-pkgconfig.patch,
+ multipath-tools-0.5.0-r1.ebuild:
+ Use pkg-config to find correct systemd libraries. Fixes #502446.
02 Mar 2014; Pacho Ramos <pacho@gentoo.org> multipath-tools-0.5.0-r1.ebuild:
amd64 stable, bug #499320
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.5.0-systemd-pkgconfig.patch b/sys-fs/multipath-tools/files/multipath-tools-0.5.0-systemd-pkgconfig.patch
new file mode 100644
index 000000000000..d75f841361a6
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.5.0-systemd-pkgconfig.patch
@@ -0,0 +1,24 @@
+diff -ru multipath-tools-0.5.0/libmultipath/Makefile multipath-tools-0.5.0-modified/libmultipath/Makefile
+--- multipath-tools-0.5.0/libmultipath/Makefile 2013-12-17 22:40:41.000000000 +0100
++++ multipath-tools-0.5.0-modified/libmultipath/Makefile 2014-03-07 04:03:45.963309627 +0100
+@@ -9,7 +9,7 @@
+ LIBS = $(DEVLIB).$(SONAME)
+ LIBDEPS = -lpthread -ldl -ldevmapper -ludev
+ ifdef SYSTEMD
+- LIBDEPS += -lsystemd-daemon
++ LIBDEPS += $(shell pkg-config --libs libsystemd 2>/dev/null || pkg-config --libs libsystemd-daemon 2>/dev/null)
+ endif
+
+ OBJS = memory.o parser.o vector.o devmapper.o callout.o \
+diff -ru multipath-tools-0.5.0/multipathd/Makefile multipath-tools-0.5.0-modified/multipathd/Makefile
+--- multipath-tools-0.5.0/multipathd/Makefile 2014-03-07 04:05:09.340307633 +0100
++++ multipath-tools-0.5.0-modified/multipathd/Makefile 2014-03-07 04:04:03.555309206 +0100
+@@ -11,7 +11,7 @@
+ endif
+ LIBS += -lpthread -ldevmapper -lreadline
+ ifdef SYSTEMD
+- LIBS += -lsystemd-daemon
++ LIBS += $(shell pkg-config --libs libsystemd 2>/dev/null || pkg-config --libs libsystemd-daemon 2>/dev/null)
+ endif
+ LIBS += -ludev -ldl \
+ -L$(multipathdir) -lmultipath -L$(mpathpersistdir) -lmpathpersist
diff --git a/sys-fs/multipath-tools/multipath-tools-0.5.0-r1.ebuild b/sys-fs/multipath-tools/multipath-tools-0.5.0-r1.ebuild
index 68573a9e3dd5..861d402d743f 100644
--- a/sys-fs/multipath-tools/multipath-tools-0.5.0-r1.ebuild
+++ b/sys-fs/multipath-tools/multipath-tools-0.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/multipath-tools-0.5.0-r1.ebuild,v 1.5 2014/03/02 22:35:22 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/multipath-tools-0.5.0-r1.ebuild,v 1.6 2014/03/09 03:13:00 zx2c4 Exp $
EAPI=4
inherit eutils toolchain-funcs udev
@@ -24,6 +24,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-systemd-pkgconfig.patch
epatch_user
}