summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-07 10:45:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-07 10:45:25 +0000
commit2f86e372a508e651f9608dc0b239a7661a142f99 (patch)
treefaee4187013aca41d4e290c63ea91fa7764f5cb0 /sys-fs/encfs
parentFix building with GLIBC 2.10+ wrt #277672. (diff)
downloadgentoo-2-2f86e372a508e651f9608dc0b239a7661a142f99.tar.gz
gentoo-2-2f86e372a508e651f9608dc0b239a7661a142f99.tar.bz2
gentoo-2-2f86e372a508e651f9608dc0b239a7661a142f99.zip
Fix building with GLIBC 2.10+ wrt #277237, thanks to Martin Väth for patch.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/encfs')
-rw-r--r--sys-fs/encfs/ChangeLog7
-rw-r--r--sys-fs/encfs/encfs-1.5.ebuild5
-rw-r--r--sys-fs/encfs/files/encfs-1.5-glibc-2.10.patch11
3 files changed, 20 insertions, 3 deletions
diff --git a/sys-fs/encfs/ChangeLog b/sys-fs/encfs/ChangeLog
index 1f09934a2a95..bd3fe6242a98 100644
--- a/sys-fs/encfs/ChangeLog
+++ b/sys-fs/encfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/encfs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.40 2009/03/16 08:20:17 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.41 2009/08/07 10:45:25 ssuominen Exp $
+
+ 07 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> encfs-1.5.ebuild,
+ +files/encfs-1.5-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #277237, thanks to Martin Väth for
+ patch.
16 Mar 2009; Tiziano Müller <dev-zero@gentoo.org>
files/encfs-1.5-boost-system-and-as-needed.patch:
diff --git a/sys-fs/encfs/encfs-1.5.ebuild b/sys-fs/encfs/encfs-1.5.ebuild
index 18cc8834a036..4052a547d889 100644
--- a/sys-fs/encfs/encfs-1.5.ebuild
+++ b/sys-fs/encfs/encfs-1.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.5.ebuild,v 1.5 2008/12/13 16:50:32 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.5.ebuild,v 1.6 2009/08/07 10:45:25 ssuominen Exp $
WANT_AUTOMAKE="1.10"
@@ -27,6 +27,7 @@ src_unpack() {
cd "${S}"
# bug 245782 - sys-fs/encfs-1.5 fails to build with --as-needed
epatch "${FILESDIR}"/${P}-boost-system-and-as-needed.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
eautomake
}
diff --git a/sys-fs/encfs/files/encfs-1.5-glibc-2.10.patch b/sys-fs/encfs/files/encfs-1.5-glibc-2.10.patch
new file mode 100644
index 000000000000..f42cbe6ed27d
--- /dev/null
+++ b/sys-fs/encfs/files/encfs-1.5-glibc-2.10.patch
@@ -0,0 +1,11 @@
+--- encfs/NameIO.cpp
++++ encfs/NameIO.cpp
+@@ -190,7 +190,7 @@
+ } else
+ {
+ bool isDotFile = (*path == '.');
+- char *next = strchr( path, '/' );
++ const char *next = strchr( path, '/' );
+ int len = next ? next - path : strlen( path );
+
+ // at this point we know that len > 0