summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2007-01-26 15:06:12 +0000
committerBenjamin Smee <strerror@gentoo.org>2007-01-26 15:06:12 +0000
commit6b5e11d63d205326c93d5b2cf286e27560788330 (patch)
tree7b93633a57aac8d37cc066382465091aee2b1774 /sys-fs/cryptsetup-luks
parentAdded ~ppc. (diff)
downloadgentoo-2-6b5e11d63d205326c93d5b2cf286e27560788330.tar.gz
gentoo-2-6b5e11d63d205326c93d5b2cf286e27560788330.tar.bz2
gentoo-2-6b5e11d63d205326c93d5b2cf286e27560788330.zip
Change to fix bug #162851
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-fs/cryptsetup-luks')
-rw-r--r--sys-fs/cryptsetup-luks/ChangeLog8
-rw-r--r--sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r1.ebuild93
-rw-r--r--sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4-r13
3 files changed, 103 insertions, 1 deletions
diff --git a/sys-fs/cryptsetup-luks/ChangeLog b/sys-fs/cryptsetup-luks/ChangeLog
index 3769d2ae43d5..d7e861d19384 100644
--- a/sys-fs/cryptsetup-luks/ChangeLog
+++ b/sys-fs/cryptsetup-luks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/cryptsetup-luks
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.46 2007/01/21 12:45:31 strerror Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/ChangeLog,v 1.47 2007/01/26 15:06:12 strerror Exp $
+
+*cryptsetup-luks-1.0.4-r1 (26 Jan 2007)
+
+ 26 Jan 2007; Benjamin Smee <strerror@gentoo.org>
+ +cryptsetup-luks-1.0.4-r1.ebuild:
+ Change to fix bug #162851
21 Jan 2007; Benjamin Smee <strerror@gentoo.org>
cryptsetup-luks-1.0.4.ebuild:
diff --git a/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r1.ebuild b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..0493f6a5dacb
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup-luks/cryptsetup-luks-1.0.4-r1.ebuild,v 1.1 2007/01/26 15:06:12 strerror Exp $
+
+inherit linux-info eutils flag-o-matic multilib
+
+DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
+HOMEPAGE="http://luks.endorphin.org/"
+SRC_URI="http://luks.endorphin.org/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build dynamic nls selinux"
+RESTRICT="confcache"
+
+DEPEND=">=sys-fs/device-mapper-1.00.07-r1
+ >=dev-libs/libgcrypt-1.1.42
+ >=dev-libs/libgpg-error-1.0-r1
+ >=dev-libs/popt-1.7
+ selinux? ( sys-libs/libselinux )
+ !sys-fs/cryptsetup"
+
+dm-crypt_check() {
+ local CONFIG_CHECK="~DM_CRYPT"
+ local WARNING_DM_CRYPT="CONFIG_DM_CRYPT:\tis not set (required for cryptsetup-luks)"
+ check_extra_config
+ echo
+}
+
+crypto_check() {
+ local CONFIG_CHECK="~CRYPTO"
+ local WARNING_CRYPTO="CONFIG_CRYPTO:\tis not set (required for cryptsetup-luks)"
+ check_extra_config
+ echo
+}
+
+cbc_check() {
+ local CONFIG_CHECK="~CRYPTO_CBC"
+ local WARNING_CRYPTO="CONFIG_CRYPTO_CBC:\tis not set (required for Kernel 2.6.19)"
+ check_extra_config
+ echo
+}
+
+pkg_setup() {
+ # Bug 148390
+ if ! use build ; then
+ linux-info_pkg_setup
+ dm-crypt_check
+ crypto_check
+ cbc_check
+ fi
+}
+
+src_compile() {
+ if use dynamic ; then
+ ewarn "If you need cryptsetup for an initrd or initramfs then you"
+ ewarn "should NOT use the dynamic USE flag"
+ epause 5
+ fi
+
+ econf \
+ --sbindir=/sbin \
+ $(use_enable !dynamic static) \
+ --libdir=/usr/$(get_libdir) \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ rmdir "${D}"/usr/$(get_libdir)/cryptsetup
+ insinto /lib/rcscripts/addons
+ dosym /sbin/cryptsetup /bin/cryptsetup
+ newins "${FILESDIR}"/1.0.3-dm-crypt-start.sh dm-crypt-start.sh || die
+ newins "${FILESDIR}"/1.0.3-dm-crypt-stop.sh dm-crypt-stop.sh || die
+ newconfd "${FILESDIR}"/1.0.3-cryptfs.confd cryptfs || die
+}
+
+pkg_postinst() {
+ ewarn "This ebuild introduces a new set of scripts and configuration"
+ ewarn "then the previous system. If you are currently using /etc/conf.d/crypfs"
+ ewarn "then you *MUST* read the new /etc/conf.d/cryptfs for instructions"
+ ewarn "on how to convert your previous cryptfs to the new syntax or your"
+ ewarn "encrypted partitions will *NOT* work."
+ einfo
+ einfo "Please see the example for configuring a LUKS mountpoint"
+ einfo "in /etc/conf.d/cryptfs"
+ einfo
+}
diff --git a/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4-r1 b/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4-r1
new file mode 100644
index 000000000000..5941fa96ba5e
--- /dev/null
+++ b/sys-fs/cryptsetup-luks/files/digest-cryptsetup-luks-1.0.4-r1
@@ -0,0 +1,3 @@
+MD5 156ae6b618438ee9feeddc6c2bdc4e94 cryptsetup-luks-1.0.4.tar.bz2 306907
+RMD160 47737ab9302152a64f0e13b405c219d0166d8217 cryptsetup-luks-1.0.4.tar.bz2 306907
+SHA256 5ba6066d79443fce157b8b6081be466b4c04759cf5cd020b51a8f6cfc996e2a6 cryptsetup-luks-1.0.4.tar.bz2 306907