summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-09-18 10:06:42 +0000
committerJustin Lecher <jlec@gentoo.org>2013-09-18 10:06:42 +0000
commit60fcb48e2d1927b1b5fc7512f15c5c6c6103cd41 (patch)
treecbafe45b6e57d57d56e76bf27a9afd4bb72dfcec /sys-fs/cachefilesd
parentsci-chemistry/coot: Drop old (diff)
downloadgentoo-2-60fcb48e2d1927b1b5fc7512f15c5c6c6103cd41.tar.gz
gentoo-2-60fcb48e2d1927b1b5fc7512f15c5c6c6103cd41.tar.bz2
gentoo-2-60fcb48e2d1927b1b5fc7512f15c5c6c6103cd41.zip
sys-fs/cachefilesd: Install systemd unit
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-fs/cachefilesd')
-rw-r--r--sys-fs/cachefilesd/ChangeLog9
-rw-r--r--sys-fs/cachefilesd/cachefilesd-0.10.5-r2.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sys-fs/cachefilesd/ChangeLog b/sys-fs/cachefilesd/ChangeLog
index 1b0eca6b0c19..0eb833f5d347 100644
--- a/sys-fs/cachefilesd/ChangeLog
+++ b/sys-fs/cachefilesd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/cachefilesd
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/ChangeLog,v 1.6 2012/12/13 16:41:05 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/ChangeLog,v 1.7 2013/09/18 10:06:42 jlec Exp $
+
+*cachefilesd-0.10.5-r2 (18 Sep 2013)
+
+ 18 Sep 2013; Justin Lecher <jlec@gentoo.org> +cachefilesd-0.10.5-r2.ebuild:
+ Install systemd unit
*cachefilesd-0.10.5-r1 (13 Dec 2012)
diff --git a/sys-fs/cachefilesd/cachefilesd-0.10.5-r2.ebuild b/sys-fs/cachefilesd/cachefilesd-0.10.5-r2.ebuild
new file mode 100644
index 000000000000..f5892935eb9b
--- /dev/null
+++ b/sys-fs/cachefilesd/cachefilesd-0.10.5-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cachefilesd/cachefilesd-0.10.5-r2.ebuild,v 1.1 2013/09/18 10:06:42 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Provides a caching directory on an already mounted filesystem"
+HOMEPAGE="http://people.redhat.com/~dhowells/fscache/"
+SRC_URI="http://people.redhat.com/~dhowells/fscache/${P}.tar.bz2 -> ${P}.tar"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc selinux"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0.10.4-makefile.patch
+ tc-export CC
+ if ! use selinux; then
+ sed -e '/^secctx/s:^:#:g' -i cachefilesd.conf || die
+ fi
+
+ append-flags -fpie
+}
+
+src_install() {
+ default
+
+ if use selinux; then
+ insinto /usr/share/doc/${P}
+ doins -r selinux
+ fi
+
+ dodoc howto.txt
+
+ newconfd "${FILESDIR}"/cachefilesd.conf ${PN}
+ newinitd "${FILESDIR}"/cachefilesd.init ${PN}
+
+ systemd_dounit ${PN}.service
+
+ keepdir /var/cache/fscache
+}
+
+pkg_postinst() {
+ [[ -d /var/cache/fscache ]] && return
+ elog "Before CacheFiles can be used, a directory for local storage"
+ elog "must be created. The default configuration of /etc/cachefilesd.conf"
+ elog "uses /var/cache/fscache. The filesystem mounted there must support"
+ elog "extended attributes (mount -o user_xattr)."
+ echo ""
+ elog "Once that is taken care of, start the daemon, add -o ...,fsc"
+ elog "to the mount options of your network mounts, and let it fly!"
+}