summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-16 21:25:47 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-16 21:25:47 +0000
commitf25fc147a7f1dcbcc10158f65e2e64af2b096326 (patch)
treeb76a9c0fc304399dd5cffd860bf7125a8b8bc8ba /sys-firmware
parentUse new toolchain helpers for selecting the bfd linker #438058 by Alexandre R... (diff)
downloadgentoo-2-f25fc147a7f1dcbcc10158f65e2e64af2b096326.tar.gz
gentoo-2-f25fc147a7f1dcbcc10158f65e2e64af2b096326.tar.bz2
gentoo-2-f25fc147a7f1dcbcc10158f65e2e64af2b096326.zip
Use new toolchain helpers for selecting the bfd linker #438058 by Alexandre Rostovtsev.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/ipxe/ChangeLog7
-rw-r--r--sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild10
2 files changed, 9 insertions, 8 deletions
diff --git a/sys-firmware/ipxe/ChangeLog b/sys-firmware/ipxe/ChangeLog
index cada7e102167..7b7730ea6cde 100644
--- a/sys-firmware/ipxe/ChangeLog
+++ b/sys-firmware/ipxe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-firmware/ipxe
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.20 2015/03/16 21:23:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.21 2015/03/16 21:25:47 vapier Exp $
+
+ 16 Mar 2015; Mike Frysinger <vapier@gentoo.org> ipxe-1.0.0_p20130624.ebuild,
+ ipxe-1.0.0_p20130925.ebuild:
+ Use new toolchain helpers for selecting the bfd linker #438058 by Alexandre
+ Rostovtsev.
16 Mar 2015; Mike Frysinger <vapier@gentoo.org> ipxe-1.0.0_p20130624.ebuild,
ipxe-1.0.0_p20130925.ebuild:
diff --git a/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild b/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild
index 9ef8437a49a0..d08f764aa239 100644
--- a/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild
+++ b/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild,v 1.8 2015/03/16 21:23:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130624.ebuild,v 1.9 2015/03/16 21:25:47 vapier Exp $
EAPI=5
@@ -29,11 +29,6 @@ RDEPEND=""
S="${WORKDIR}/ipxe-${GIT_SHORT}/src"
-pkg_setup() {
- tc-ld-is-gold && \
- ewarn "gold linker unable to handle 16-bit code using ld.bfd. bug #438058"
-}
-
src_prepare() {
cat <<-EOF > "${S}"/config/local/general.h
#undef BANNER_TIMEOUT
@@ -49,11 +44,12 @@ EOF
}
src_compile() {
+ tc-ld-disable-gold
ipxemake() {
# Q='' makes the build verbose since that's what everyone loves now
emake Q='' \
CC=$(tc-getCC) \
- LD="$(tc-getLD).bfd" \
+ LD="$(tc-getLD)" \
AR=$(tc-getAR) \
OBJCOPY=$(tc-getOBJCOPY) \
RANLIB=$(tc-getRANLIB) \