summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-12 04:31:01 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-12 04:31:01 +0000
commitaffc5a78608a8a71a25504d966b1001beb4811b3 (patch)
tree557ec97c81712ddd3b9c419db0165abc78b4eced /sys-devel
parentadd a func to automatically process patches in rpm specs (diff)
downloadgentoo-2-affc5a78608a8a71a25504d966b1001beb4811b3.tar.gz
gentoo-2-affc5a78608a8a71a25504d966b1001beb4811b3.tar.bz2
gentoo-2-affc5a78608a8a71a25504d966b1001beb4811b3.zip
Add an ebuild for Fedora rpms (since they apply a ton of custom patches).
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb/ChangeLog8
-rw-r--r--sys-devel/gdb/gdb-6.8.50.20090302.8.11.ebuild111
2 files changed, 118 insertions, 1 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index 01717c197223..5dbda288c6a1 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gdb
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.152 2009/03/12 03:16:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.153 2009/03/12 04:31:01 vapier Exp $
+
+*gdb-6.8.50.20090302.8.11 (12 Mar 2009)
+
+ 12 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+ +gdb-6.8.50.20090302.8.11.ebuild:
+ Add an ebuild for Fedora rpms (since they apply a ton of custom patches).
*gdb-6.8-r2 (12 Mar 2009)
diff --git a/sys-devel/gdb/gdb-6.8.50.20090302.8.11.ebuild b/sys-devel/gdb/gdb-6.8.50.20090302.8.11.ebuild
new file mode 100644
index 000000000000..b104e6e1c1ad
--- /dev/null
+++ b/sys-devel/gdb/gdb-6.8.50.20090302.8.11.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.8.50.20090302.8.11.ebuild,v 1.1 2009/03/12 04:31:01 vapier Exp $
+
+inherit flag-o-matic eutils
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+if [[ ${PV} == *.*.*.*.*.* ]] ; then
+ inherit versionator rpm
+ # fedora version: gdb-6.8.50.20090302-8.fc11.src.rpm
+ gvcr() { get_version_component_range "$@"; }
+ MY_PV=$(gvcr 1-4)
+ RPM="${PN}-${MY_PV}-$(gvcr 5).fc$(gvcr 6).src.rpm"
+else
+ MY_PV=${PV}
+ RPM=
+fi
+
+PATCH_VER=""
+DESCRIPTION="GNU debugger"
+HOMEPAGE="http://sources.redhat.com/gdb/"
+if [[ -n ${RPM} ]] ; then
+ SRC_URI="http://mirrors.kernel.org/fedora/development/source/SRPMS/${RPM}"
+else
+ SRC_URI="http://ftp.gnu.org/gnu/gdb/${P}.tar.bz2
+ ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2"
+fi
+SRC_URI="${SRC_URI} ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.lzma}"
+
+LICENSE="GPL-2 LGPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS=""
+IUSE="multitarget nls test vanilla"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ app-arch/lzma-utils
+ test? ( dev-util/dejagnu )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ if [[ -n ${RPM} ]] ; then
+ rpm_src_unpack
+ cd "${S}"
+ rpm_spec_epatch "${WORKDIR}"/gdb.spec
+ else
+ unpack ${A}
+ fi
+ cd "${S}"
+ if [[ -n ${PATCH_VER} ]] ; then
+ use vanilla || EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
+ fi
+ strip-linguas -u bfd/po opcodes/po
+}
+
+src_compile() {
+ strip-unsupported-flags
+ econf \
+ --disable-werror \
+ $(has_version '=sys-libs/readline-5*' && echo --with-system-readline) \
+ $(use_enable nls) \
+ $(use multitarget && echo --enable-targets=all) \
+ || die
+ emake || die
+}
+
+src_test() {
+ emake check || ewarn "tests failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
+ install || die
+ rm -r "${D}"/nukeme || die
+
+ # Don't install docs when building a cross-gdb
+ if [[ ${CTARGET} != ${CHOST} ]] ; then
+ rm -r "${D}"/usr/share
+ return 0
+ fi
+
+ dodoc README
+ docinto gdb
+ dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
+ gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
+ docinto sim
+ dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
+
+ dodoc "${WORKDIR}"/extra/gdbinit.sample
+
+ # Remove shared info pages
+ rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
+}
+
+pkg_postinst() {
+ # portage sucks and doesnt unmerge files in /etc
+ rm -vf "${ROOT}"/etc/skel/.gdbinit
+}