summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-07-25 13:54:01 +0000
committerMichał Górny <mgorny@gentoo.org>2015-07-25 13:54:01 +0000
commit7600ecc27e21cc89b5e68b3e4c64306027c405d2 (patch)
treee40a36ead0194fe55722ee16f7a3413a06ba4e63 /sys-devel
parentVersion bump with bug fixes. Bug #555536. (diff)
downloadgentoo-2-7600ecc27e21cc89b5e68b3e4c64306027c405d2.tar.gz
gentoo-2-7600ecc27e21cc89b5e68b3e4c64306027c405d2.tar.bz2
gentoo-2-7600ecc27e21cc89b5e68b3e4c64306027c405d2.zip
Version bump to match sys-devel/llvm. Bug #555536.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog7
-rw-r--r--sys-devel/clang/clang-3.6.2-r100.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index fff5ede13187..45dd5de1674f 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.124 2015/05/27 12:02:40 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.125 2015/07/25 13:54:01 mgorny Exp $
+
+*clang-3.6.2-r100 (25 Jul 2015)
+
+ 25 Jul 2015; Michał Górny <mgorny@gentoo.org> +clang-3.6.2-r100.ebuild:
+ Version bump to match sys-devel/llvm. Bug #555536.
*clang-3.6.1-r100 (27 May 2015)
diff --git a/sys-devel/clang/clang-3.6.2-r100.ebuild b/sys-devel/clang/clang-3.6.2-r100.ebuild
new file mode 100644
index 000000000000..7c8f110aae98
--- /dev/null
+++ b/sys-devel/clang/clang-3.6.2-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.6.2-r100.ebuild,v 1.1 2015/07/25 13:54:01 mgorny Exp $
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.6"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}