summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-11 22:46:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-11 22:46:01 +0000
commit73d278eb9e30383d380c86a49faa7703ae1678b3 (patch)
treefa662a2d5742ae026ac280b333735440bb68ee09 /sys-devel
parentppc stable as per bug #74117. Ancient version removed as well. (Manifest reco... (diff)
downloadgentoo-2-73d278eb9e30383d380c86a49faa7703ae1678b3.tar.gz
gentoo-2-73d278eb9e30383d380c86a49faa7703ae1678b3.tar.bz2
gentoo-2-73d278eb9e30383d380c86a49faa7703ae1678b3.zip
Rather than guess at variable name changes, perform version sanity checks to make sure that the libtool version being used by configure (via aclocal.m4/libtool.m4) matches that of the local ltmain.sh/libtool files.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libtool/ChangeLog12
-rw-r--r--sys-devel/libtool/files/1.5.10/libtool-1.5.10-version-checking.patch59
-rw-r--r--sys-devel/libtool/files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch35
-rw-r--r--sys-devel/libtool/files/digest-libtool-1.5.10-r1 (renamed from sys-devel/libtool/files/digest-libtool-1.5.10)0
-rw-r--r--sys-devel/libtool/libtool-1.5.10-r1.ebuild (renamed from sys-devel/libtool/libtool-1.5.10.ebuild)13
5 files changed, 77 insertions, 42 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index c4c67b9b4ba8..692d4216100e 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-devel/libtool
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.60 2004/11/30 04:01:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.61 2004/12/11 22:46:01 vapier Exp $
+
+*libtool-1.5.10-r1 (11 Dec 2004)
+
+ 11 Dec 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.5.10/libtool-1.5.10-version-checking.patch,
+ -files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch,
+ +libtool-1.5.10-r1.ebuild:
+ Rather than guess at variable name changes, perform version sanity checks to
+ make sure that the libtool version being used by configure (via
+ aclocal.m4/libtool.m4) matches that of the local ltmain.sh/libtool files.
29 Nov 2004; Mike Frysinger <vapier@gentoo.org>
+files/1.5.10/libtool-1.5.10-locking.patch, libtool-1.5.10.ebuild:
diff --git a/sys-devel/libtool/files/1.5.10/libtool-1.5.10-version-checking.patch b/sys-devel/libtool/files/1.5.10/libtool-1.5.10-version-checking.patch
new file mode 100644
index 000000000000..392d81ceabec
--- /dev/null
+++ b/sys-devel/libtool/files/1.5.10/libtool-1.5.10-version-checking.patch
@@ -0,0 +1,59 @@
+--- libtool-1.5.10/libtool.m4.orig 2004-12-11 13:28:30.494718288 -0500
++++ libtool-1.5.10/libtool.m4 2004-12-11 13:31:51.452168112 -0500
+@@ -227,6 +227,14 @@
+ [pic_mode=default])
+ test -z "$pic_mode" && pic_mode=default
+
++# Check if we have a version mismatch between libtool.m4 and ltmain.sh.
++#
++# Note: This should be in AC_LIBTOOL_SETUP, _after_ $ltmain have been defined.
++# We also should do it _before_ AC_LIBTOOL_LANG_C_CONFIG that actually
++# calls AC_LIBTOOL_CONFIG and creates libtool.
++#
++_LT_VERSION_CHECK
++
+ # Use C for the default configuration in the libtool script
+ tagname=
+ AC_LIBTOOL_LANG_C_CONFIG
+@@ -234,6 +242,41 @@
+ ])# AC_LIBTOOL_SETUP
+
+
++# _LT_VERSION_CHECK
++# -----------------
++AC_DEFUN([_LT_VERSION_CHECK],
++[AC_MSG_CHECKING([for correct ltmain.sh version])
++if test -z "$ltmain"; then
++ AC_MSG_RESULT(no)
++ echo
++ echo "*** [Gentoo] sanity check failed! ***"
++ echo "*** \$ltmain is not defined, please check the patch for consistency! ***"
++ echo
++ exit 1
++fi
++gentoo_lt_version="@_LT_VERSION@"
++gentoo_ltmain_version=`grep '^[[:space:]]*VERSION=' $ltmain | sed -e 's|^[[:space:]]*VERSION=||'`
++if test "$gentoo_lt_version" != "$gentoo_ltmain_version"; then
++ AC_MSG_RESULT(no)
++ echo
++ echo "*** [Gentoo] sanity check failed! ***"
++ echo "*** libtool.m4 and ltmain.sh have a version mismatch! ***"
++ echo "*** (libtool.m4 = $gentoo_lt_version, ltmain.sh = $gentoo_ltmain_version) ***"
++ echo
++ echo "Please run:"
++ echo
++ echo " libtoolize --copy --force"
++ echo
++ echo "if appropriate, please contact the maintainer of this"
++ echo "package (or your distribution) for help."
++ echo
++ exit 1
++else
++ AC_MSG_RESULT(yes)
++fi
++])# _LT_VERSION_CHECK
++
++
+ # _LT_AC_SYS_COMPILER
+ # -------------------
+ AC_DEFUN([_LT_AC_SYS_COMPILER],
diff --git a/sys-devel/libtool/files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch b/sys-devel/libtool/files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch
deleted file mode 100644
index ba46f009af18..000000000000
--- a/sys-devel/libtool/files/1.5.6/libtool-1.5.6-libtool_m4-shared_ext.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- libtool-1.5.2/libtool.m4 2004-02-10 00:23:58.000000000 +0200
-+++ libtool-1.5.2.shared_ext/libtool.m4 2004-02-10 23:32:08.364266152 +0200
-@@ -229,6 +229,7 @@
- tagname=
- AC_LIBTOOL_LANG_C_CONFIG
- _LT_AC_TAGCONFIG
-+_LT_AC_SHARED_EXT
- ])# AC_LIBTOOL_SETUP
-
-
-@@ -1788,6 +1789,24 @@
- fi
- ])# _LT_AC_TAGCONFIG
-
-+# _LT_AC_SHARED_EXT
-+# ----------------
-+AC_DEFUN([_LT_AC_SHARED_EXT],[
-+ if test ! -f "${ofile}"; then
-+ AC_MSG_WARN([output file `$ofile' does not exist])
-+ fi
-+ if test -z "`grep -e 'shared_ext.*shrext_cmds' $ofile`"; then
-+ # Make sure $shared_ext gets set to $shrext_cmds
-+ if sed -e 's/shared_ext/shrext_cmds/g' "$ofile" > "${ofile}T"; then
-+ mv "${ofile}T" "$ofile"
-+ chmod +x "$ofile"
-+ else
-+ rm -f "${ofile}T"
-+ AC_MSG_ERROR([unable to update shared_ext.])
-+ fi
-+ fi
-+])# _LT_AC_SHARED_EXT
-+
-
- # AC_LIBTOOL_DLOPEN
- # -----------------
diff --git a/sys-devel/libtool/files/digest-libtool-1.5.10 b/sys-devel/libtool/files/digest-libtool-1.5.10-r1
index cab20e0c9462..cab20e0c9462 100644
--- a/sys-devel/libtool/files/digest-libtool-1.5.10
+++ b/sys-devel/libtool/files/digest-libtool-1.5.10-r1
diff --git a/sys-devel/libtool/libtool-1.5.10.ebuild b/sys-devel/libtool/libtool-1.5.10-r1.ebuild
index 00d3d62e21db..6ec49f1e3a87 100644
--- a/sys-devel/libtool/libtool-1.5.10.ebuild
+++ b/sys-devel/libtool/libtool-1.5.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10.ebuild,v 1.5 2004/11/30 04:01:32 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10-r1.ebuild,v 1.1 2004/12/11 22:46:01 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils gnuconfig libtool
@@ -90,11 +90,11 @@ src_unpack() {
# <azarah@gentoo.org> - (07 April 2002)
epatch ${FILESDIR}/1.4.3/${PN}-1.4.2-portage.patch
# If a package use an older libtool, and libtool.m4 for that
- # package is updated, but not libtool, then we run into an
- # issue where $shared_ext is not set. This results in libraries
- # being built without '.so' extension, bug #40901
- # <azarah@gentoo.org> - (11 Feb 2004)
- epatch ${FILESDIR}/1.5.6/${PN}-1.5.6-libtool_m4-shared_ext.patch
+ # package is updated, but not libtool, then we may run into an
+ # issue where internal variables are named differently. Often
+ # this shows up as libs being built without '.so' extension #73140
+ epatch ${FILESDIR}/1.5.10/${PN}-1.5.10-version-checking.patch
+ sed -i "s:@_LT_VERSION@:${PV}:" libtool.m4 || die "sed libtool.m4"
# For older autoconf setups's that do not support libtool.m4,
# $max_cmd_len are never set, causing all tests against it to
# fail, resulting in 'integer expression expected' errors and
@@ -118,6 +118,7 @@ src_unpack() {
uclibctoolize
gnuconfig_update ${WORKDIR}
+ epunt_cxx
}
src_compile() {