summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-06-17 00:30:03 +0000
committerZack Welch <zwelch@gentoo.org>2003-06-17 00:30:03 +0000
commit714780b9cb34f4c42d378ccc39fbb8350aa99669 (patch)
tree9c19d5736f42d30e202002cf0c48949524033bca /sys-devel
parentbump version; add improvements by Lisa Marie from bug 22914 (diff)
downloadgentoo-2-714780b9cb34f4c42d378ccc39fbb8350aa99669.tar.gz
gentoo-2-714780b9cb34f4c42d378ccc39fbb8350aa99669.tar.bz2
gentoo-2-714780b9cb34f4c42d378ccc39fbb8350aa99669.zip
bump version; add improvements by Lisa Marie from bug 22914
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog7
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/distcc-2.7.ebuild114
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.71
4 files changed, 123 insertions, 3 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 03323d177f4b..b993c9a858c8 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.46 2003/06/07 19:04:53 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.47 2003/06/17 00:30:00 zwelch Exp $
+
+*distcc-2.7 (16 Jun 2003)
+
+ 16 Jun 2003; Zach Welch <zwelch@gentoo.org> distcc-2.7.ebuild:
+ bump version; add support provided by Lisa Marie in bug 22914
04 Jun 2003; Zach Welch <zwelch@gentoo.org> distcc-2.5-r1.ebuild:
mark 2.5-r1 stable on all arches; update web page address to use new wiki
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 5c16f1083a6a..05e069a82a5f 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,4 +1,4 @@
-MD5 7b547825bca695804c266077321eaae1 ChangeLog 8224
+MD5 8eee56873139ed3cd39d56ca7f939d40 ChangeLog 8381
MD5 960b9f9b17b8f9dd99094d162362dd1b distcc-2.0.1-r1.ebuild 2892
MD5 da890f4d3d7a6c3cb65ad47f80feff6a distcc-2.0.1.ebuild 2895
MD5 8df905f30d3f4bce8c31534396b66ec8 distcc-2.3.ebuild 2691
@@ -6,7 +6,7 @@ MD5 c242a8c0ff4035a2c6a3ee0545691aed distcc-2.4.ebuild 2702
MD5 3bc5a82158ff39298b4b80134999ddde distcc-2.4.2.ebuild 2703
MD5 c958bfeb956960d4b15ebab2df7a6d86 distcc-2.5.ebuild 2702
MD5 7b08a44d08561a7ff5ddb161bc661419 distcc-2.5-r1.ebuild 3176
-MD5 168e4fbbba9481b4e863b76de98aa9a7 distcc-2.7.ebuild 3251
+MD5 678280847fd36babab91ee94307a736e distcc-2.7.ebuild 3348
MD5 372827ac4fc6b9dae1d585934369ce8e distcc-1.2.3-r3.ebuild 2882
MD5 9a3a39b4f229559e6a855d777c6fe807 files/digest-distcc-2.0.1-r1 65
MD5 8aa55227d128b8ff22a8caf5d47db89c files/digest-distcc-2.3 63
diff --git a/sys-devel/distcc/distcc-2.7.ebuild b/sys-devel/distcc/distcc-2.7.ebuild
new file mode 100644
index 000000000000..a5a3021733e6
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.7.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.7.ebuild,v 1.1 2003/06/17 00:30:00 zwelch Exp $
+
+inherit eutils
+
+IUSE="gnome"
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+
+OPV="1.2"
+LPV="2.3"
+
+DEPEND=">=sys-apps/portage-2.0.46-r11
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ dev-libs/popt"
+
+RDEPEND="gnome? ( >=gnome-base/libgnomeui-2.2.0.1 )"
+
+src_compile() {
+ local myconf
+ use gnome && myconf="--enable-gnome"
+ echo "Running econf with ${myconf}"
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${LPV}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${OPV}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${OPV}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}" ${ROOT}usr/bin/distcc-config --set-hosts \
+ $(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install-user
+ /usr/bin/distcc-config --install-links
+ /usr/bin/distcc-config --install-links "${CHOST}"
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "To use distcc with **non-Portage** C compiling, add"
+ einfo "/usr/lib/distcc/bin to your path before /usr/bin. If you're"
+ einfo "combining this with ccache, put the ccache path BEFORE distcc."
+ einfo "Portage 2.0.46-r11+ will take advantage of distcc if you put"
+ einfo "distcc into the FEATURES setting in make.conf and use"
+ einfo "distcc-config --set-hosts. Do NOT set CC=distcc or similar."
+ ewarn "See \"http://wiki.dev.gentoo.org/gentoo/moin.cgi/UsingDistcc\" for information."
+}
+
+#pkg_prerm() {
+# # ztw - not sure if this is the right place
+# distcc-config --remove-links "${CHOST}"
+# distcc-config --remove-links
+#}
+
diff --git a/sys-devel/distcc/files/digest-distcc-2.7 b/sys-devel/distcc/files/digest-distcc-2.7
new file mode 100644
index 000000000000..5e952f0656b2
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.7
@@ -0,0 +1 @@
+MD5 7f367102fb645b769368b901ec57e159 distcc-2.7.tar.bz2 232371