summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-20 04:35:02 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-20 04:35:02 +0000
commit5aec45680c08977a6af34355696f41573635c5d5 (patch)
tree0129d490107c3610e08e0cf74231ca2fcc8af6f8 /sys-devel
parentupdate SRC_URI (diff)
downloadgentoo-2-5aec45680c08977a6af34355696f41573635c5d5.tar.gz
gentoo-2-5aec45680c08977a6af34355696f41573635c5d5.tar.bz2
gentoo-2-5aec45680c08977a6af34355696f41573635c5d5.zip
Add tempfile patch to resolve #85766.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gettext/ChangeLog9
-rw-r--r--sys-devel/gettext/files/digest-gettext-0.14.1-r1 (renamed from sys-devel/gettext/files/digest-gettext-0.14.1)0
-rw-r--r--sys-devel/gettext/files/gettext-0.14.1-tempfile.patch75
-rw-r--r--sys-devel/gettext/gettext-0.14.1-r1.ebuild (renamed from sys-devel/gettext/gettext-0.14.1.ebuild)3
4 files changed, 85 insertions, 2 deletions
diff --git a/sys-devel/gettext/ChangeLog b/sys-devel/gettext/ChangeLog
index e14c110730d8..54b6b5167b03 100644
--- a/sys-devel/gettext/ChangeLog
+++ b/sys-devel/gettext/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gettext
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.86 2005/04/19 22:19:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/ChangeLog,v 1.87 2005/04/20 04:35:02 vapier Exp $
+
+*gettext-0.14.1-r1 (20 Apr 2005)
+
+ 20 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/gettext-0.14.1-tempfile.patch, -gettext-0.14.1.ebuild,
+ +gettext-0.14.1-r1.ebuild:
+ Add tempfile patch to resolve #85766.
*gettext-0.14.4 (19 Apr 2005)
diff --git a/sys-devel/gettext/files/digest-gettext-0.14.1 b/sys-devel/gettext/files/digest-gettext-0.14.1-r1
index 4eae2cc7c785..4eae2cc7c785 100644
--- a/sys-devel/gettext/files/digest-gettext-0.14.1
+++ b/sys-devel/gettext/files/digest-gettext-0.14.1-r1
diff --git a/sys-devel/gettext/files/gettext-0.14.1-tempfile.patch b/sys-devel/gettext/files/gettext-0.14.1-tempfile.patch
new file mode 100644
index 000000000000..78de04610918
--- /dev/null
+++ b/sys-devel/gettext/files/gettext-0.14.1-tempfile.patch
@@ -0,0 +1,75 @@
+diff -ur gettext-0.14.1.orig/gettext-tools/misc/autopoint.in gettext-0.14.1/gettext-tools/misc/autopoint.in
+--- gettext-0.14.1.orig/gettext-tools/misc/autopoint.in 2004-01-29 20:17:27.000000000 +0100
++++ gettext-0.14.1/gettext-tools/misc/autopoint.in 2004-09-20 10:26:14.000000000 +0200
+@@ -39,14 +39,7 @@
+ */* | *\\*) ;;
+ *) # Need to look in the PATH.
+ if test "${PATH_SEPARATOR+set}" != set; then
+- { echo "#! /bin/sh"; echo "exit 0"; } > /tmp/conf$$.sh
+- chmod +x /tmp/conf$$.sh
+- if (PATH="/nonexistent;/tmp"; conf$$.sh) >/dev/null 2>&1; then
+- PATH_SEPARATOR=';'
+- else
+- PATH_SEPARATOR=:
+- fi
+- rm -f /tmp/conf$$.sh
++ PATH_SEPARATOR=:
+ fi
+ save_IFS="$IFS"; IFS="$PATH_SEPARATOR"
+ for dir in $PATH; do
+@@ -318,7 +311,15 @@
+ cvs_dir=tmpcvs$$
+ work_dir=tmpwrk$$
+ mkdir "$cvs_dir"
++if [ $? -ne 0 ]; then
++ echo "ERROR making $cvs_dir"
++ exit 1
++fi
+ mkdir "$work_dir"
++if [ $? -ne 0 ]; then
++ echo "ERROR making $work_dir"
++ exit 1
++fi
+ CVSROOT="$srcdir/$cvs_dir"
+ export CVSROOT
+ unset CVS_CLIENT_LOG
+@@ -384,8 +385,7 @@
+ # original - too great risk of version mismatch.
+ if test -z "$force"; then
+ mismatch=
+- mismatchfile="${TMPDIR-/tmp}"/autopoint$$.diff
+- rm -f "$mismatchfile"
++ mismatchfile="`mktemp -t autopoint.diff.XXXXXX`"
+ for file in `find "$work_dir/archive" -type f -print | sed -e "s,^$work_dir/archive/,," | LC_ALL=C sort`; do
+ func_destfile "$file"
+ if test -n "$destfile"; then
+@@ -417,6 +417,10 @@
+ # Recompute base. It was clobbered by the recursive call.
+ base=`echo "$1" | sed -e 's,/[^/]*$,,'`
+ test -d "$base" || { echo "Creating directory $base"; mkdir "$base"; }
++ if [ $? -ne 0 ]; then
++ echo "ERROR making directory $base"
++ exit 1
++ fi
+ fi
+ }
+
+diff -ur gettext-0.14.1.orig/gettext-tools/misc/gettextize.in gettext-0.14.1/gettext-tools/misc/gettextize.in
+--- gettext-0.14.1.orig/gettext-tools/misc/gettextize.in 2004-01-20 12:30:06.000000000 +0100
++++ gettext-0.14.1/gettext-tools/misc/gettextize.in 2004-09-20 10:22:39.000000000 +0200
+@@ -39,14 +39,7 @@
+ */* | *\\*) ;;
+ *) # Need to look in the PATH.
+ if test "${PATH_SEPARATOR+set}" != set; then
+- { echo "#! /bin/sh"; echo "exit 0"; } > /tmp/conf$$.sh
+- chmod +x /tmp/conf$$.sh
+- if (PATH="/nonexistent;/tmp"; conf$$.sh) >/dev/null 2>&1; then
+- PATH_SEPARATOR=';'
+- else
+- PATH_SEPARATOR=:
+- fi
+- rm -f /tmp/conf$$.sh
++ PATH_SEPARATOR=:
+ fi
+ save_IFS="$IFS"; IFS="$PATH_SEPARATOR"
+ for dir in $PATH; do
diff --git a/sys-devel/gettext/gettext-0.14.1.ebuild b/sys-devel/gettext/gettext-0.14.1-r1.ebuild
index ed7700667eb3..bc5b643b35c4 100644
--- a/sys-devel/gettext/gettext-0.14.1.ebuild
+++ b/sys-devel/gettext/gettext-0.14.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.1.ebuild,v 1.32 2005/04/09 13:13:09 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.14.1-r1.ebuild,v 1.1 2005/04/20 04:35:02 vapier Exp $
inherit eutils gnuconfig toolchain-funcs mono libtool
@@ -22,6 +22,7 @@ src_unpack() {
epunt_cxx
epatch "${FILESDIR}"/${P}-lib-path-tests.patch #81628
+ epatch "${FILESDIR}"/${P}-tempfile.patch #66355
# java sucks
epatch "${FILESDIR}"/${P}-without_java.patch
epatch "${FILESDIR}"/${P}-no-java-tests.patch