summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-06-27 16:34:28 +0000
committerJeroen Roovers <jer@gentoo.org>2012-06-27 16:34:28 +0000
commit080904bf6995fdd456d058b9bf64b1fbedb9797f (patch)
tree4436d0362e7e9e7187abacf6e915b0c2a9cf3e5e /sys-devel
parentRevert the -r1 to use the internal version. It was commited accidentaly, the ... (diff)
downloadgentoo-2-080904bf6995fdd456d058b9bf64b1fbedb9797f.tar.gz
gentoo-2-080904bf6995fdd456d058b9bf64b1fbedb9797f.tar.bz2
gentoo-2-080904bf6995fdd456d058b9bf64b1fbedb9797f.zip
Bump.
(Portage version: 2.2.0_alpha113/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/kgcc64/ChangeLog7
-rw-r--r--sys-devel/kgcc64/kgcc64-4.6.3.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
index e71ae78d5535..94e00cc04903 100644
--- a/sys-devel/kgcc64/ChangeLog
+++ b/sys-devel/kgcc64/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/kgcc64
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.42 2012/05/15 19:25:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.43 2012/06/27 16:34:28 jer Exp $
+
+*kgcc64-4.6.3 (27 Jun 2012)
+
+ 27 Jun 2012; Jeroen Roovers <jer@gentoo.org> +kgcc64-4.6.3.ebuild:
+ Bump.
15 May 2012; Jeroen Roovers <jer@gentoo.org> kgcc64-4.5.3.ebuild:
Stable for HPPA too.
diff --git a/sys-devel/kgcc64/kgcc64-4.6.3.ebuild b/sys-devel/kgcc64/kgcc64-4.6.3.ebuild
new file mode 100644
index 000000000000..da67d8c9ecbe
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.6.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.6.3.ebuild,v 1.1 2012/06/27 16:34:28 jer Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.3"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="~hppa ~sparc"
+
+RDEPEND=">=dev-libs/gmp-4.3.2
+ >=dev-libs/mpfr-2.4.2
+ >=dev-libs/mpc-0.8.1
+ >=sys-devel/gcc-config-1.4"
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="${RDEPEND}
+ hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64
+ >=sys-apps/texinfo-4.8
+ >=sys-devel/bison-1.875"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}