summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-03 20:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-03 20:28:07 +0000
commit6f34509f38cdbb83e595431b2d48a6c45fe5028b (patch)
tree023497c68b23bb66907c7afa93e3f9a008c26028 /sys-devel/gcc/gcc-4.6.2.ebuild
parentDisable ssse3 on Darwin to fix compilation, thanks Paul, bug #367045 (diff)
downloadgentoo-2-6f34509f38cdbb83e595431b2d48a6c45fe5028b.tar.gz
gentoo-2-6f34509f38cdbb83e595431b2d48a6c45fe5028b.tar.bz2
gentoo-2-6f34509f38cdbb83e595431b2d48a6c45fe5028b.zip
Disable fortify patches with older glibcs #362315 by Leonid Volnitsky.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gcc/gcc-4.6.2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.6.2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-4.6.2.ebuild b/sys-devel/gcc/gcc-4.6.2.ebuild
index 980ed5cbdcc3..678b67a952a0 100644
--- a/sys-devel/gcc/gcc-4.6.2.ebuild
+++ b/sys-devel/gcc/gcc-4.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.2.ebuild,v 1.2 2011/11/09 19:22:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.2.ebuild,v 1.3 2011/12/03 20:28:07 vapier Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -36,6 +36,12 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_unpack() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
toolchain_src_unpack
use vanilla && return 0