summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-12-07 15:49:29 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-12-07 15:49:29 +0000
commitfc0d152ec61b505655a84e52df34581690dfc681 (patch)
treeedb6d5bd1c888b5e38208e5d64249aa2f937a65a /sys-devel/dragonegg
parentRC bump, install FileCheck test tool as it is needed for dragonegg tests (diff)
downloadgentoo-2-fc0d152ec61b505655a84e52df34581690dfc681.tar.gz
gentoo-2-fc0d152ec61b505655a84e52df34581690dfc681.tar.bz2
gentoo-2-fc0d152ec61b505655a84e52df34581690dfc681.zip
RC bump, set C locale for tests to correctly get 'gcc -v' output
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'sys-devel/dragonegg')
-rw-r--r--sys-devel/dragonegg/ChangeLog8
-rw-r--r--sys-devel/dragonegg/dragonegg-3.2_rc3.ebuild (renamed from sys-devel/dragonegg/dragonegg-3.2_rc2.ebuild)9
2 files changed, 13 insertions, 4 deletions
diff --git a/sys-devel/dragonegg/ChangeLog b/sys-devel/dragonegg/ChangeLog
index 41b7dc460156..8c6bcd98809f 100644
--- a/sys-devel/dragonegg/ChangeLog
+++ b/sys-devel/dragonegg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/dragonegg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.10 2012/12/03 20:38:33 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.11 2012/12/07 15:49:29 voyageur Exp $
+
+*dragonegg-3.2_rc3 (07 Dec 2012)
+
+ 07 Dec 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ -dragonegg-3.2_rc2.ebuild, +dragonegg-3.2_rc3.ebuild:
+ RC bump, set C locale for tests to correctly get 'gcc -v' output
*dragonegg-3.2_rc2 (03 Dec 2012)
diff --git a/sys-devel/dragonegg/dragonegg-3.2_rc2.ebuild b/sys-devel/dragonegg/dragonegg-3.2_rc3.ebuild
index 779651dd93c7..21f1ce45feeb 100644
--- a/sys-devel/dragonegg/dragonegg-3.2_rc2.ebuild
+++ b/sys-devel/dragonegg/dragonegg-3.2_rc3.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-3.2_rc2.ebuild,v 1.1 2012/12/03 20:38:33 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-3.2_rc3.ebuild,v 1.1 2012/12/07 15:49:29 voyageur Exp $
EAPI=5
inherit multilib toolchain-funcs
DESCRIPTION="GCC plugin that uses LLVM for optimization and code generation"
HOMEPAGE="http://dragonegg.llvm.org/"
-SRC_URI="http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.2_}/${P/_}.src.tar.gz
- test? ( http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.2_}/llvm-${PV/_}.src.tar.gz )"
+SRC_URI="http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.2_}/${P/_}.src.tar.bz2
+ test? ( http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.2_}/llvm-${PV/_}.src.tar.bz2 )"
LICENSE="GPL-2"
SLOT="0"
@@ -28,6 +28,9 @@ src_compile() {
}
src_test() {
+ # GCC languages are determined via locale-dependant gcc -v output
+ export LC_ALL=C
+
emake LIT_DIR="${WORKDIR}"/llvm.src/utils/lit check
}