summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2013-06-10 21:56:58 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2013-06-10 21:56:58 +0000
commit7a7d3def3610efd008dd6d440381c3ec19e12339 (patch)
treef03f514c891b8104286fb96d6234b7929e40de5c /sys-devel/dragonegg
parent3.3_rc bump, fix live ebuild test call (diff)
downloadgentoo-2-7a7d3def3610efd008dd6d440381c3ec19e12339.tar.gz
gentoo-2-7a7d3def3610efd008dd6d440381c3ec19e12339.tar.bz2
gentoo-2-7a7d3def3610efd008dd6d440381c3ec19e12339.zip
3.3_rc bump, fix live ebuild test call
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'sys-devel/dragonegg')
-rw-r--r--sys-devel/dragonegg/ChangeLog8
-rw-r--r--sys-devel/dragonegg/dragonegg-3.3_rc3.ebuild50
-rw-r--r--sys-devel/dragonegg/dragonegg-9999.ebuild5
3 files changed, 61 insertions, 2 deletions
diff --git a/sys-devel/dragonegg/ChangeLog b/sys-devel/dragonegg/ChangeLog
index 671ee12c94fe..7adbe639347a 100644
--- a/sys-devel/dragonegg/ChangeLog
+++ b/sys-devel/dragonegg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/dragonegg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.13 2013/04/03 21:40:52 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/ChangeLog,v 1.14 2013/06/10 21:56:58 voyageur Exp $
+
+*dragonegg-3.3_rc3 (10 Jun 2013)
+
+ 10 Jun 2013; Bernard Cafarelli <voyageur@gentoo.org>
+ +dragonegg-3.3_rc3.ebuild, dragonegg-9999.ebuild:
+ 3.3_rc bump, fix live ebuild test call
03 Apr 2013; Bernard Cafarelli <voyageur@gentoo.org> dragonegg-9999.ebuild:
Fix test check in src_unpack, spotted in bug #464350
diff --git a/sys-devel/dragonegg/dragonegg-3.3_rc3.ebuild b/sys-devel/dragonegg/dragonegg-3.3_rc3.ebuild
new file mode 100644
index 000000000000..1fb37cfb5a4a
--- /dev/null
+++ b/sys-devel/dragonegg/dragonegg-3.3_rc3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-3.3_rc3.ebuild,v 1.1 2013/06/10 21:56:58 voyageur Exp $
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+DESCRIPTION="GCC plugin that uses LLVM for optimization and code generation"
+HOMEPAGE="http://dragonegg.llvm.org/"
+SRC_URI="http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.3_}/${PN}-source-${PV/_}.tar.gz
+ test? ( http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.3_}/llvm-source-${PV/_}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="test"
+
+DEPEND="|| ( sys-devel/gcc:4.5[lto]
+ >=sys-devel/gcc-4.6 )
+ ~sys-devel/llvm-${PV}"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}.src
+
+src_compile() {
+ # GCC: compiler to use plugin with
+ emake CC="$(tc-getCC)" GCC="$(tc-getCC)" CXX="$(tc-getCXX)" VERBOSE=1
+}
+
+src_test() {
+ # GCC languages are determined via locale-dependant gcc -v output
+ export LC_ALL=C
+
+ emake LIT_DIR="${WORKDIR}"/llvm.src/utils/lit check
+}
+
+src_install() {
+ # Install plugin in llvm lib directory
+ exeinto /usr/$(get_libdir)/llvm
+ doexe dragonegg.so
+
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "To use dragonegg, run gcc as usual, with an extra command line argument:"
+ elog " -fplugin=/usr/$(get_libdir)/llvm/dragonegg.so"
+ elog "If you change the active gcc profile, or update gcc to a new version,"
+ elog "you will have to remerge this package to update the plugin"
+}
diff --git a/sys-devel/dragonegg/dragonegg-9999.ebuild b/sys-devel/dragonegg/dragonegg-9999.ebuild
index a6db95cbb7e1..51c3af3e9e73 100644
--- a/sys-devel/dragonegg/dragonegg-9999.ebuild
+++ b/sys-devel/dragonegg/dragonegg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-9999.ebuild,v 1.4 2013/04/03 21:40:52 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dragonegg/dragonegg-9999.ebuild,v 1.5 2013/06/10 21:56:58 voyageur Exp $
EAPI=5
inherit subversion multilib toolchain-funcs
@@ -34,6 +34,9 @@ src_compile() {
}
src_test() {
+ # GCC languages are determined via locale-dependant gcc -v output
+ export LC_ALL=C
+
emake LIT_DIR="${WORKDIR}"/llvm/utils/lit check
}