summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-10-29 18:52:28 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-10-29 18:52:28 +0000
commit56cb848d0e02c8f1b082ce58869ddb37d23cc31e (patch)
treee75be92959f4552cae20b9f91a6cb52cd8ed501e /sys-devel/distcc
parentDrop jruby target. (diff)
downloadgentoo-2-56cb848d0e02c8f1b082ce58869ddb37d23cc31e.tar.gz
gentoo-2-56cb848d0e02c8f1b082ce58869ddb37d23cc31e.tar.bz2
gentoo-2-56cb848d0e02c8f1b082ce58869ddb37d23cc31e.zip
Added missing python dependencies, cleaned up old v3.1 ebuilds as per discussion with untrabug on irc
(Portage version: 2.2.8-r2/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/ChangeLog11
-rw-r--r--sys-devel/distcc/distcc-3.1-r10.ebuild (renamed from sys-devel/distcc/distcc-3.1-r9.ebuild)6
-rw-r--r--sys-devel/distcc/distcc-3.1-r5.ebuild174
-rw-r--r--sys-devel/distcc/distcc-3.1-r6.ebuild176
-rw-r--r--sys-devel/distcc/distcc-3.1-r7.ebuild167
-rw-r--r--sys-devel/distcc/distcc-3.2_rc1-r1.ebuild (renamed from sys-devel/distcc/distcc-3.2_rc1.ebuild)6
6 files changed, 18 insertions, 522 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index e431727ca39f..603352d0df83 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/distcc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.236 2014/05/21 06:38:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.237 2014/10/29 18:52:28 axs Exp $
+
+*distcc-3.2_rc1-r1 (29 Oct 2014)
+*distcc-3.1-r10 (29 Oct 2014)
+
+ 29 Oct 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org> +distcc-3.1-r10.ebuild,
+ +distcc-3.2_rc1-r1.ebuild, -distcc-3.1-r5.ebuild, -distcc-3.1-r6.ebuild,
+ -distcc-3.1-r7.ebuild, -distcc-3.1-r9.ebuild, -distcc-3.2_rc1.ebuild:
+ Added missing python dependencies, cleaned up old v3.1 ebuilds as per
+ discussion with untrabug on irc
21 May 2014; Justin Lecher <jlec@gentoo.org> distcc-3.1-r9.ebuild,
distcc-3.2_rc1.ebuild:
diff --git a/sys-devel/distcc/distcc-3.1-r9.ebuild b/sys-devel/distcc/distcc-3.1-r10.ebuild
index 00c6912e2fac..3b8386d5b83f 100644
--- a/sys-devel/distcc/distcc-3.1-r9.ebuild
+++ b/sys-devel/distcc/distcc-3.1-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-3.1-r9.ebuild,v 1.10 2014/05/21 06:38:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-3.1-r10.ebuild,v 1.1 2014/10/29 18:52:28 axs Exp $
EAPI=5
@@ -19,7 +19,7 @@ IUSE="avahi gtk hardened ipv6 selinux xinetd"
RESTRICT="test"
-RDEPEND="
+RDEPEND="${PYTHON_DEPS}
dev-libs/popt
avahi? ( >=net-dns/avahi-0.6[dbus] )
gtk? ( x11-libs/gtk+:2 )"
@@ -31,6 +31,8 @@ RDEPEND="${RDEPEND}
selinux? ( sec-policy/selinux-distcc )
xinetd? ( sys-apps/xinetd )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
DISTCC_LOG=""
DCCC_PATH="/usr/$(get_libdir)/distcc/bin"
DISTCC_VERBOSE="0"
diff --git a/sys-devel/distcc/distcc-3.1-r5.ebuild b/sys-devel/distcc/distcc-3.1-r5.ebuild
deleted file mode 100644
index 6d4e880860e7..000000000000
--- a/sys-devel/distcc/distcc-3.1-r5.ebuild
+++ /dev/null
@@ -1,174 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-3.1-r5.ebuild,v 1.5 2014/05/16 19:53:04 jer Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-
-inherit eutils fdo-mime flag-o-matic multilib python toolchain-funcs user
-
-DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
-HOMEPAGE="http://distcc.org/"
-SRC_URI="http://distcc.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="avahi gnome gtk hardened ipv6 selinux xinetd"
-
-RESTRICT="test"
-
-RDEPEND="dev-libs/popt
- avahi? ( >=net-dns/avahi-0.6[dbus] )
- gnome? (
- >=gnome-base/libgnome-2
- >=gnome-base/libgnomeui-2
- x11-libs/gtk+:2
- x11-libs/pango
- )
- gtk? (
- x11-libs/gtk+:2
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- !net-misc/pump
- >=sys-devel/gcc-config-1.4.1
- selinux? ( sec-policy/selinux-distcc )
- xinetd? ( sys-apps/xinetd )"
-
-DISTCC_LOG=""
-DCCC_PATH="/usr/$(get_libdir)/distcc/bin"
-DISTCC_VERBOSE="0"
-
-pkg_setup() {
- enewuser distcc 240 -1 -1 daemon
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-3.0-xinetd.patch"
- # bug #253786
- epatch "${FILESDIR}/${PN}-3.0-fix-fortify.patch"
- # bug #255188
- epatch "${FILESDIR}/${P}-freedesktop.patch"
- # bug #258364
- epatch "${FILESDIR}/${P}-python.patch"
-
- sed -i -e "/PATH/s:\$distcc_location:${DCCC_PATH}:" pump.in || die
-
- # Bugs #120001, #167844 and probably more. See patch for description.
- use hardened && epatch "${FILESDIR}/distcc-hardened.patch"
-}
-
-src_configure() {
- local myconf="--disable-Werror --with-docdir=/usr/share/doc/${PF}"
- # More legacy stuff?
- [ "$(gcc-major-version)" = "2" ] && filter-lfs-flags
-
- # --disable-rfc2553 b0rked, bug #254176
- use ipv6 && myconf="${myconf} --enable-rfc2553"
-
- econf \
- $(use_with avahi) \
- $(use_with gtk) \
- $(use_with gnome) \
- ${myconf} || die "econf failed"
-}
-
-src_install() {
- # In rare cases, parallel make install failed
- emake -j1 DESTDIR="${D}" install || die
-
- dobin "${FILESDIR}/3.0/distcc-config"
-
- newinitd "${FILESDIR}/${PV}/init" distccd
-
- cp "${FILESDIR}/3.0/conf" "${T}/distccd"
- if use avahi; then
- cat >> "${T}/distccd" <<-EOF
-
- # Enable zeroconf support in distccd
- DISTCCD_OPTS="\${DISTCCD_OPTS} --zeroconf"
- EOF
- fi
- doconfd "${T}/distccd"
-
- cat > "${T}/02distcc" <<-EOF
- # This file is managed by distcc-config; use it to change these settings.
- DISTCC_LOG="${DISTCC_LOG}"
- DCCC_PATH="${DCCC_PATH}"
- DISTCC_VERBOSE="${DISTCC_VERBOSE}"
- EOF
- doenvd "${T}/02distcc"
-
- # create the masquerade directory
- dodir "${DCCC_PATH}"
- for f in cc c++ gcc g++; do
- dosym /usr/bin/distcc "${DCCC_PATH}/${f}"
- if [ "${f}" != "cc" ]; then
- dosym /usr/bin/distcc "${DCCC_PATH}/${CTARGET:-${CHOST}}-${f}"
- fi
- done
-
- # create the distccd pid directory
- keepdir /var/run/distccd
- fowners distcc:daemon /var/run/distccd
-
- if use gnome || use gtk; then
- einfo "Renaming /usr/bin/distccmon-gnome to /usr/bin/distccmon-gui"
- einfo "This is to have a little sensability in naming schemes between distccmon programs"
- mv "${D}/usr/bin/distccmon-gnome" "${D}/usr/bin/distccmon-gui" || die
- dosym distccmon-gui /usr/bin/distccmon-gnome
- fi
-
- if use xinetd; then
- insinto /etc/xinetd.d
- newins "doc/example/xinetd" distcc
- fi
-
- rm -rf "${D}/etc/default"
- rm -f "${D}/etc/distcc/clients.allow"
- rm -f "${D}/etc/distcc/commands.allow.sh"
-
- python_convert_shebangs -r $(python_get_version) "${ED}"
- sed -e "s:${EPREFIX}/usr/bin/python:$(PYTHON -a):" -i "${ED}usr/bin/pump" || die "sed failed"
-}
-
-pkg_postinst() {
- python_mod_optimize include_server
- use gnome && fdo-mime_desktop_database_update
-
- if use ipv6; then
- elog
- elog "IPv6 is not supported yet by ${P}."
- fi
- elog
- elog "Tips on using distcc with Gentoo can be found at"
- elog "http://www.gentoo.org/doc/en/distcc.xml"
- elog
- elog "How to use pump mode with Gentoo:"
- elog "# distcc-config --set-hosts \"foo,cpp,lzo bar,cpp,lzo baz,cpp,lzo\""
- elog "# pump emerge -u world"
- elog
- elog "To use the distccmon programs with Gentoo you should use this command:"
- elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-text 5"
-
- if use gnome || use gtk; then
- elog "Or:"
- elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-gnome"
- fi
-
- elog
- elog "***SECURITY NOTICE***"
- elog "If you are upgrading distcc please make sure to run etc-update to"
- elog "update your /etc/conf.d/distccd and /etc/init.d/distccd files with"
- elog "added security precautions (the --listen and --allow directives)"
- elog
-}
-
-pkg_postrm() {
- python_mod_cleanup include_server
- use gnome && fdo-mime_desktop_database_update
-}
diff --git a/sys-devel/distcc/distcc-3.1-r6.ebuild b/sys-devel/distcc/distcc-3.1-r6.ebuild
deleted file mode 100644
index 7ce96d9f57ae..000000000000
--- a/sys-devel/distcc/distcc-3.1-r6.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-3.1-r6.ebuild,v 1.4 2014/05/16 19:53:04 jer Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-
-inherit eutils fdo-mime flag-o-matic multilib python toolchain-funcs user
-
-DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
-HOMEPAGE="http://distcc.org/"
-SRC_URI="http://distcc.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="avahi gnome gtk hardened ipv6 selinux xinetd"
-
-RESTRICT="test"
-
-RDEPEND="dev-libs/popt
- avahi? ( >=net-dns/avahi-0.6[dbus] )
- gnome? (
- >=gnome-base/libgnome-2
- >=gnome-base/libgnomeui-2
- x11-libs/gtk+:2
- x11-libs/pango
- )
- gtk? (
- x11-libs/gtk+:2
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- !net-misc/pump
- >=sys-devel/gcc-config-1.4.1
- selinux? ( sec-policy/selinux-distcc )
- xinetd? ( sys-apps/xinetd )"
-
-DISTCC_LOG=""
-DCCC_PATH="/usr/$(get_libdir)/distcc/bin"
-DISTCC_VERBOSE="0"
-
-pkg_setup() {
- enewuser distcc 240 -1 -1 daemon
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-3.0-xinetd.patch"
- # bug #253786
- epatch "${FILESDIR}/${PN}-3.0-fix-fortify.patch"
- # bug #255188
- epatch "${FILESDIR}/${P}-freedesktop.patch"
- # bug #258364
- epatch "${FILESDIR}/${P}-python.patch"
- # bug #351979
- epatch "${FILESDIR}/${P}-argc-fix.patch"
-
- sed -i -e "/PATH/s:\$distcc_location:${DCCC_PATH}:" pump.in || die
-
- # Bugs #120001, #167844 and probably more. See patch for description.
- use hardened && epatch "${FILESDIR}/distcc-hardened.patch"
-}
-
-src_configure() {
- local myconf="--disable-Werror --with-docdir=/usr/share/doc/${PF}"
- # More legacy stuff?
- [ "$(gcc-major-version)" = "2" ] && filter-lfs-flags
-
- # --disable-rfc2553 b0rked, bug #254176
- use ipv6 && myconf="${myconf} --enable-rfc2553"
-
- econf \
- $(use_with avahi) \
- $(use_with gtk) \
- $(use_with gnome) \
- ${myconf} || die "econf failed"
-}
-
-src_install() {
- # In rare cases, parallel make install failed
- emake -j1 DESTDIR="${D}" install || die
-
- dobin "${FILESDIR}/3.0/distcc-config"
-
- newinitd "${FILESDIR}/${PV}/init" distccd
-
- cp "${FILESDIR}/3.0/conf" "${T}/distccd"
- if use avahi; then
- cat >> "${T}/distccd" <<-EOF
-
- # Enable zeroconf support in distccd
- DISTCCD_OPTS="\${DISTCCD_OPTS} --zeroconf"
- EOF
- fi
- doconfd "${T}/distccd"
-
- cat > "${T}/02distcc" <<-EOF
- # This file is managed by distcc-config; use it to change these settings.
- DISTCC_LOG="${DISTCC_LOG}"
- DCCC_PATH="${DCCC_PATH}"
- DISTCC_VERBOSE="${DISTCC_VERBOSE}"
- EOF
- doenvd "${T}/02distcc"
-
- # create the masquerade directory
- dodir "${DCCC_PATH}"
- for f in cc c++ gcc g++; do
- dosym /usr/bin/distcc "${DCCC_PATH}/${f}"
- if [ "${f}" != "cc" ]; then
- dosym /usr/bin/distcc "${DCCC_PATH}/${CTARGET:-${CHOST}}-${f}"
- fi
- done
-
- # create the distccd pid directory
- keepdir /var/run/distccd
- fowners distcc:daemon /var/run/distccd
-
- if use gnome || use gtk; then
- einfo "Renaming /usr/bin/distccmon-gnome to /usr/bin/distccmon-gui"
- einfo "This is to have a little sensability in naming schemes between distccmon programs"
- mv "${D}/usr/bin/distccmon-gnome" "${D}/usr/bin/distccmon-gui" || die
- dosym distccmon-gui /usr/bin/distccmon-gnome
- fi
-
- if use xinetd; then
- insinto /etc/xinetd.d
- newins "doc/example/xinetd" distcc
- fi
-
- rm -rf "${D}/etc/default"
- rm -f "${D}/etc/distcc/clients.allow"
- rm -f "${D}/etc/distcc/commands.allow.sh"
-
- python_convert_shebangs -r $(python_get_version) "${ED}"
- sed -e "s:${EPREFIX}/usr/bin/python:$(PYTHON -a):" -i "${ED}usr/bin/pump" || die "sed failed"
-}
-
-pkg_postinst() {
- python_mod_optimize include_server
- use gnome && fdo-mime_desktop_database_update
-
- if use ipv6; then
- elog
- elog "IPv6 is not supported yet by ${P}."
- fi
- elog
- elog "Tips on using distcc with Gentoo can be found at"
- elog "http://www.gentoo.org/doc/en/distcc.xml"
- elog
- elog "How to use pump mode with Gentoo:"
- elog "# distcc-config --set-hosts \"foo,cpp,lzo bar,cpp,lzo baz,cpp,lzo\""
- elog "# pump emerge -u world"
- elog
- elog "To use the distccmon programs with Gentoo you should use this command:"
- elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-text 5"
-
- if use gnome || use gtk; then
- elog "Or:"
- elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-gnome"
- fi
-
- elog
- elog "***SECURITY NOTICE***"
- elog "If you are upgrading distcc please make sure to run etc-update to"
- elog "update your /etc/conf.d/distccd and /etc/init.d/distccd files with"
- elog "added security precautions (the --listen and --allow directives)"
- elog
-}
-
-pkg_postrm() {
- python_mod_cleanup include_server
- use gnome && fdo-mime_desktop_database_update
-}
diff --git a/sys-devel/distcc/distcc-3.1-r7.ebuild b/sys-devel/distcc/distcc-3.1-r7.ebuild
deleted file mode 100644
index 84de38258749..000000000000
--- a/sys-devel/distcc/distcc-3.1-r7.ebuild
+++ /dev/null
@@ -1,167 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-3.1-r7.ebuild,v 1.7 2014/05/16 19:53:04 jer Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit eutils fdo-mime flag-o-matic multilib python-single-r1 toolchain-funcs user
-
-DESCRIPTION="Distribute compilation of C code across several machines on a network"
-HOMEPAGE="http://distcc.org/"
-SRC_URI="http://distcc.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="avahi gtk hardened ipv6 selinux xinetd"
-
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/popt
- avahi? ( >=net-dns/avahi-0.6[dbus] )
- gtk? ( x11-libs/gtk+:2 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-RDEPEND="${RDEPEND}
- !net-misc/pump
- >=sys-devel/gcc-config-1.4.1
- selinux? ( sec-policy/selinux-distcc )
- xinetd? ( sys-apps/xinetd )"
-
-DISTCC_LOG=""
-DCCC_PATH="/usr/$(get_libdir)/distcc/bin"
-DISTCC_VERBOSE="0"
-
-pkg_setup() {
- enewuser distcc 240 -1 -1 daemon
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-3.0-xinetd.patch"
- # bug #253786
- epatch "${FILESDIR}/${PN}-3.0-fix-fortify.patch"
- # bug #255188
- epatch "${FILESDIR}/${P}-freedesktop.patch"
- # bug #258364
- epatch "${FILESDIR}/${P}-python.patch"
- # bug #351979
- epatch "${FILESDIR}/${P}-argc-fix.patch"
-
- sed -i -e "/PATH/s:\$distcc_location:${DCCC_PATH}:" pump.in || die
-
- # Bugs #120001, #167844 and probably more. See patch for description.
- use hardened && epatch "${FILESDIR}/distcc-hardened.patch"
-}
-
-src_configure() {
- local myconf="--disable-Werror --with-docdir=/usr/share/doc/${PF}"
- # More legacy stuff?
- [ "$(gcc-major-version)" = "2" ] && filter-lfs-flags
-
- # --disable-rfc2553 b0rked, bug #254176
- use ipv6 && myconf="${myconf} --enable-rfc2553"
-
- econf \
- $(use_with avahi) \
- $(use_with gtk) \
- ${myconf}
-}
-
-src_install() {
- # In rare cases, parallel make install failed
- MAKEOPTS+=" -j1"
- default
-
- dobin "${FILESDIR}/3.0/distcc-config"
-
- newinitd "${FILESDIR}/${PV}/init" distccd
-
- cp "${FILESDIR}/3.0/conf" "${T}/distccd"
- if use avahi; then
- cat >> "${T}/distccd" <<-EOF
-
- # Enable zeroconf support in distccd
- DISTCCD_OPTS="\${DISTCCD_OPTS} --zeroconf"
- EOF
- fi
- doconfd "${T}/distccd"
-
- cat > "${T}/02distcc" <<-EOF
- # This file is managed by distcc-config; use it to change these settings.
- DISTCC_LOG="${DISTCC_LOG}"
- DCCC_PATH="${DCCC_PATH}"
- DISTCC_VERBOSE="${DISTCC_VERBOSE}"
- EOF
- doenvd "${T}/02distcc"
-
- # create the masquerade directory
- dodir "${DCCC_PATH}"
- for f in cc c++ gcc g++; do
- dosym /usr/bin/distcc "${DCCC_PATH}/${f}"
- if [ "${f}" != "cc" ]; then
- dosym /usr/bin/distcc "${DCCC_PATH}/${CTARGET:-${CHOST}}-${f}"
- fi
- done
-
- # create the distccd pid directory
- keepdir /var/run/distccd
- fowners distcc:daemon /var/run/distccd
-
- if use gtk; then
- einfo "Renaming /usr/bin/distccmon-gnome to /usr/bin/distccmon-gui"
- einfo "This is to have a little sensability in naming schemes between distccmon programs"
- mv "${D}/usr/bin/distccmon-gnome" "${D}/usr/bin/distccmon-gui" || die
- dosym distccmon-gui /usr/bin/distccmon-gnome
- fi
-
- if use xinetd; then
- insinto /etc/xinetd.d
- newins "doc/example/xinetd" distcc
- fi
-
- rm -rf "${D}/etc/default" || die
- rm -f "${D}/etc/distcc/clients.allow" || die
- rm -f "${D}/etc/distcc/commands.allow.sh" || die
-
- python_fix_shebang "${ED}"
- python_optimize "${ED}"/$(python_get_sitedir)
-}
-
-pkg_postinst() {
- use gtk && fdo-mime_desktop_database_update
-
- if use ipv6; then
- elog
- elog "IPv6 is not supported yet by ${P}."
- fi
- elog
- elog "Tips on using distcc with Gentoo can be found at"
- elog "http://www.gentoo.org/doc/en/distcc.xml"
- elog
- elog "How to use pump mode with Gentoo:"
- elog "# distcc-config --set-hosts \"foo,cpp,lzo bar,cpp,lzo baz,cpp,lzo\""
- elog "# pump emerge -u world"
- elog
- elog "To use the distccmon programs with Gentoo you should use this command:"
- elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-text 5"
-
- if use gtk; then
- elog "Or:"
- elog "# DISTCC_DIR=\"${DISTCC_DIR}\" distccmon-gnome"
- fi
-
- elog
- elog "***SECURITY NOTICE***"
- elog "If you are upgrading distcc please make sure to run etc-update to"
- elog "update your /etc/conf.d/distccd and /etc/init.d/distccd files with"
- elog "added security precautions (the --listen and --allow directives)"
- elog
-}
-
-pkg_postrm() {
- use gtk && fdo-mime_desktop_database_update
-}
diff --git a/sys-devel/distcc/distcc-3.2_rc1.ebuild b/sys-devel/distcc/distcc-3.2_rc1-r1.ebuild
index 8c115f58a474..639bf4fe9ed9 100644
--- a/sys-devel/distcc/distcc-3.2_rc1.ebuild
+++ b/sys-devel/distcc/distcc-3.2_rc1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-3.2_rc1.ebuild,v 1.8 2014/05/21 06:38:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-3.2_rc1-r1.ebuild,v 1.1 2014/10/29 18:52:28 axs Exp $
EAPI=5
@@ -20,7 +20,7 @@ IUSE="avahi crossdev gnome gssapi gtk hardened ipv6 selinux xinetd"
RESTRICT="test"
-RDEPEND="
+RDEPEND="${PYTHON_DEPS}
dev-libs/popt
avahi? ( >=net-dns/avahi-0.6[dbus] )
gnome? (
@@ -39,6 +39,8 @@ RDEPEND="${RDEPEND}
selinux? ( sec-policy/selinux-distcc )
xinetd? ( sys-apps/xinetd )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
S="${WORKDIR}/${MY_P}"
DCCC_PATH="/usr/$(get_libdir)/distcc/bin"