summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-21 01:46:09 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-21 01:46:09 +0000
commitdecd694a855611be58c55764f56b55930ec7a7d5 (patch)
tree4d0eedd7885b48554df26f8b9c1017ff263202fd /sys-devel/crossdev
parentVersion bump (diff)
downloadgentoo-2-decd694a855611be58c55764f56b55930ec7a7d5.tar.gz
gentoo-2-decd694a855611be58c55764f56b55930ec7a7d5.tar.bz2
gentoo-2-decd694a855611be58c55764f56b55930ec7a7d5.zip
Add support for cell from lu_zero and push out accumulated fixes.
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog8
-rw-r--r--sys-devel/crossdev/crossdev-0.9.16.ebuild20
-rwxr-xr-xsys-devel/crossdev/files/crossdev16
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9.161
4 files changed, 42 insertions, 3 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 734a7de5ae33..6192a96310f3 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.36 2006/08/10 03:52:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.37 2006/08/21 01:46:09 vapier Exp $
+
+*crossdev-0.9.16 (21 Aug 2006)
+
+ 21 Aug 2006; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ -crossdev-0.9.15-r2.ebuild, +crossdev-0.9.16.ebuild:
+ Add support for cell from lu_zero and push out accumulated fixes.
*crossdev-0.9.15-r2 (10 Aug 2006)
diff --git a/sys-devel/crossdev/crossdev-0.9.16.ebuild b/sys-devel/crossdev/crossdev-0.9.16.ebuild
new file mode 100644
index 000000000000..b713cccff30e
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9.16.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.16.ebuild,v 1.1 2006/08/21 01:46:09 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash"
+
+src_install() {
+ dosbin "${FILESDIR}"/crossdev || die
+ dosed "s:GENTOO_PV:${PV}:" /usr/sbin/crossdev
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index 7eb0ab634214..46972f8444b0 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.69 2006/08/10 03:52:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.70 2006/08/21 01:46:09 vapier Exp $
cd /
@@ -69,7 +69,7 @@ parse_target() {
cris*) CPOST="axis-linux-gnu";;
x86|i?86*|amd64|x86_64*) CPOST="pc-linux-gnu";;
s390*) CPOST="ibm-linux-gnu";;
- bfin*|nios2*) CPOST="elf";;
+ bfin*|nios2*|spu*) CPOST="elf";;
*) CPOST="unknown-linux-gnu";;
esac
fi
@@ -130,6 +130,18 @@ parse_target() {
vax*) TARCH=${HARCH};
LPKG="uclibc";;
+ cell*)einfo "The cell target is really an alias for the spu/ppu targets"
+ ${CROSSDEV} -t ppu || exit 1
+ ${CROSSDEV} -t spu-elf || exit 1
+ exit 0;;
+ spu*) TARCH=ppc64;
+ GPKG="gcc-cell";
+ KPKG="[none]";
+ LPKG="newlib";;
+ ppu*) TARCH=ppc64;
+ CPRE=powerpc64;
+ GPKG="gcc-cell";;
+
ps2*) einfo "The ps2 target is really an alias for the ee/iop/dvp targets"
${CROSSDEV} -t ee || exit 1
${CROSSDEV} -t iop || exit 1
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9.16 b/sys-devel/crossdev/files/digest-crossdev-0.9.16
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9.16
@@ -0,0 +1 @@
+