summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-09 00:10:25 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-09 00:10:25 +0000
commit8c92dc24388c68792203eb244dddb13c504e52d1 (patch)
tree7cf26a640b18d5c6b0b2eba84c18fa8b38648a2f /sys-devel/crossdev
parentversion bump (diff)
downloadgentoo-2-8c92dc24388c68792203eb244dddb13c504e52d1.tar.gz
gentoo-2-8c92dc24388c68792203eb244dddb13c504e52d1.tar.bz2
gentoo-2-8c92dc24388c68792203eb244dddb13c504e52d1.zip
Have targets set default stage which user can override via --stage.
(Portage version: 2.1.2.9)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog8
-rw-r--r--sys-devel/crossdev/crossdev-0.9.18-r2.ebuild21
-rwxr-xr-xsys-devel/crossdev/files/crossdev21
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9.18-r20
4 files changed, 39 insertions, 11 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 6f5cef223731..c00211045b03 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.51 2007/05/23 16:21:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.52 2007/06/09 00:10:25 vapier Exp $
+
+*crossdev-0.9.18-r2 (09 Jun 2007)
+
+ 09 Jun 2007; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ +crossdev-0.9.18-r2.ebuild:
+ Have targets set default stage which user can override via --stage.
23 May 2007; Diego Pettenò <flameeyes@gentoo.org>
crossdev-0.9.17-r3.ebuild, crossdev-0.9.18-r1.ebuild:
diff --git a/sys-devel/crossdev/crossdev-0.9.18-r2.ebuild b/sys-devel/crossdev/crossdev-0.9.18-r2.ebuild
new file mode 100644
index 000000000000..ee4d120b3c44
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9.18-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.18-r2.ebuild,v 1.1 2007/06/09 00:10:25 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ || ( dev-util/unifdef sys-freebsd/freebsd-ubin )"
+
+src_install() {
+ dosbin "${FILESDIR}"/crossdev || die
+ dosed "s:GENTOO_PV:${PV}:" /usr/sbin/crossdev
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index 4b845a188ccd..34885c97545d 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.94 2007/05/14 14:56:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.95 2007/06/09 00:10:25 vapier Exp $
cd /
umask 0022 #159111
@@ -57,6 +57,7 @@ STAGE_C_ONLY=1
STAGE_C_KERNEL=2
STAGE_LIBC=3
STAGE_C_CPP=4
+STAGE_DEFAULT=${STAGE_C_CPP}
STAGE_DISP=( "binutils" "C compiler only" "kernel headers" "C compiler & libc" "C/C++ compiler" )
parse_target() {
@@ -142,7 +143,7 @@ parse_target() {
# Now account for all the "special" architectures out there
case ${CTARGET} in
- avr*) KPKG="[none]"; STAGE=${STAGE_LIBC};
+ avr*) KPKG="[none]"; STAGE_DEFAULT=${STAGE_LIBC};
LCAT="dev-embedded"; LPKG="avr-libc";
GVER="3.4.6"; BVER="2.16.1-r3";
GUSE=${GUSE_DISABLE};;
@@ -153,7 +154,7 @@ parse_target() {
LCAT="dev-util"; LPKG="mingw-runtime";;
msp430)
- STAGE=${STAGE_BINUTILS};;
+ STAGE_DEFAULT=${STAGE_BINUTILS};;
nios2*)
BPKG="binutils-nios2";
@@ -176,15 +177,15 @@ parse_target() {
ee*) TARCH=mips;
KPKG="[none]"
GVER="3.2.2"; BVER="2.14";
- STAGE=${STAGE_C_ONLY};
+ STAGE_DEFAULT=${STAGE_C_ONLY};
GUSE=${GUSE_DISABLE};;
iop*) TARCH=mips;
GVER="3.2.2"; BVER="2.14";
- STAGE=${STAGE_C_ONLY};
+ STAGE_DEFAULT=${STAGE_C_ONLY};
GUSE=${GUSE_DISABLE};;
dvp*) TARCH=mips;
GVER="3.2.2"; BVER="2.14";
- STAGE=${STAGE_BINUTILS};;
+ STAGE_DEFAULT=${STAGE_BINUTILS};;
esac
# Tweak packages based upon CTARGET
@@ -200,7 +201,7 @@ parse_target() {
*-newlib|*-elf)
LPKG="newlib"
KPKG="[none]"
- STAGE=${STAGE_LIBC}
+ STAGE_DEFAULT=${STAGE_LIBC}
;;
# Now for the BSDs ...
@@ -321,7 +322,7 @@ UOPTS=
TARCH=
HARCH=$(unset ARCH ; portageq envvar ARCH)
CTARGET=
-STAGE="COW"
+STAGE=""
BCAT="sys-devel" ; BPKG="binutils" ; BVER="[latest]" ; BUSE=""
GCAT="sys-devel" ; GPKG="gcc" ; GVER="[latest]" ; GUSE=""
KCAT="sys-kernel" ; KPKG="linux-headers" ; KVER="[latest]" ; KUSE=""
@@ -343,7 +344,7 @@ while [[ $# -gt 0 ]] ; do
--k|--kernel) shift; KVER=$1;;
--l|--libc) shift; LVER=$1;;
-C|--clean) shift; parse_target $1; uninstall;;
- -s?|--stage?) [[ ${STAGE} == "COW" ]] && STAGE=${1:0-1};;
+ -s?|--stage?) STAGE=${1:0-1};;
--ex-only) EX_FAST="yes";;
--ex-gcc) EX_GCC="yes";;
--ex-gdb) EX_GDB="yes";;
@@ -360,8 +361,8 @@ while [[ $# -gt 0 ]] ; do
done
[[ ${SET_X} == "yes" ]] && set -x
+STAGE=${STAGE:-${STAGE_DEFAULT}}
[[ -z ${CTARGET} ]] && usage 1
-[[ ${STAGE} == "COW" ]] && STAGE=${STAGE_C_CPP}
for with in HEADERS ; do
var=WITH_${with} defvar=WITH_DEF_${with}
[[ ${!var} == "COW" ]] && eval ${var}=${!defvar}
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9.18-r2 b/sys-devel/crossdev/files/digest-crossdev-0.9.18-r2
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9.18-r2