summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2004-11-18 18:42:01 +0000
committerKito Danya Dietrich <kito@gentoo.org>2004-11-18 18:42:01 +0000
commit0b65a0d76d45f5c782d11003ab2f6fdc56f74208 (patch)
tree303e02c0d314066a9508b8ab619dcad70000bb42 /sys-devel/cctools-extras
parentVersion bump. Change ftdetect rules slightly, bug #71197 (Manifest recommit) (diff)
downloadgentoo-2-0b65a0d76d45f5c782d11003ab2f6fdc56f74208.tar.gz
gentoo-2-0b65a0d76d45f5c782d11003ab2f6fdc56f74208.tar.bz2
gentoo-2-0b65a0d76d45f5c782d11003ab2f6fdc56f74208.zip
fixed static libkld.a build
Diffstat (limited to 'sys-devel/cctools-extras')
-rw-r--r--sys-devel/cctools-extras/ChangeLog5
-rw-r--r--sys-devel/cctools-extras/cctools-extras-525.ebuild15
2 files changed, 15 insertions, 5 deletions
diff --git a/sys-devel/cctools-extras/ChangeLog b/sys-devel/cctools-extras/ChangeLog
index e733bed87123..2a5473f081ff 100644
--- a/sys-devel/cctools-extras/ChangeLog
+++ b/sys-devel/cctools-extras/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/cctools-extras
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/ChangeLog,v 1.1 2004/11/07 22:56:00 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/ChangeLog,v 1.2 2004/11/18 18:42:01 kito Exp $
+
+ 18 Nov 2004; Kito <kito@gentoo.org> cctools-extras-525.ebuild:
+ fix libkld.a static build
*cctools-extras-525 (07 Nov 2004)
diff --git a/sys-devel/cctools-extras/cctools-extras-525.ebuild b/sys-devel/cctools-extras/cctools-extras-525.ebuild
index a40cf1699761..e7f300111442 100644
--- a/sys-devel/cctools-extras/cctools-extras-525.ebuild
+++ b/sys-devel/cctools-extras/cctools-extras-525.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/cctools-extras-525.ebuild,v 1.2 2004/11/07 23:13:37 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/cctools-extras-525.ebuild,v 1.3 2004/11/18 18:42:01 kito Exp $
DESCRIPTION="Extra cctools utils"
HOMEPAGE="http://darwinsource.opendarwin.org/"
@@ -12,12 +12,16 @@ SLOT="0"
KEYWORDS="~ppc-macos"
IUSE=""
-DEPEND=""
+DEPEND="sys-apps/bootstrap_cmds
+ virtual/libc"
src_compile() {
cd ${WORKDIR}/cctools-${PV}
- rm -rf ar as cbtlibs dyld file gprof ld libdyld libmacho mkshlib otool
- make SUBDIRS="libstuff misc" || die "make failed"
+ rm -rf ar as cbtlibs dyld file gprof libdyld mkshlib otool
+ make SUBDIRS="libmacho libstuff misc" RC_OS=macos || die "make failed"
+
+ cd ${WORKDIR}/cctools-${PV}/ld
+ make RC_OS=macos kld_build || die "static kld build failed"
}
src_install() {
@@ -29,6 +33,9 @@ src_install() {
newbin seg_addr_table.NEW seg_addr_table || die "seg_addr_table failed"
newbin seg_hack.NEW seg_hack || die "seg_hack failed"
+ cd ${WORKDIR}/cctools-${PV}/ld/static_kld
+ dolib.a *.a
+
cd ${WORKDIR}/cctools-${PV}/man
doman {check_dylib.1,checksyms.1,indr.1,seg_addr_table.1}
} \ No newline at end of file