summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 16:05:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 16:05:19 +0000
commit8c2f9b5d58d2c8ba17ecd94571dc41b82919228f (patch)
treee3f2ab2acadd83ad2269d388593e02ee4a4107e3 /sys-devel/bison
parentMaintainence and FHS 2.1 fixes for RC4 (diff)
downloadgentoo-2-8c2f9b5d58d2c8ba17ecd94571dc41b82919228f.tar.gz
gentoo-2-8c2f9b5d58d2c8ba17ecd94571dc41b82919228f.tar.bz2
gentoo-2-8c2f9b5d58d2c8ba17ecd94571dc41b82919228f.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/bison-1.28-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-devel/bison/bison-1.28-r2.ebuild b/sys-devel/bison/bison-1.28-r2.ebuild
new file mode 100644
index 000000000000..e0389a19773d
--- /dev/null
+++ b/sys-devel/bison/bison-1.28-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.28-r2.ebuild,v 1.1 2001/02/07 16:05:19 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A yacc-compatible parser generator"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bison/${A}
+ ftp://prep.ai.mit.edu/gnu/bison/${A}"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+
+
+DEPEND="virtual/glibc
+ sys-devel/gettext"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ try ./configure --prefix=/usr --datadir=/usr/share/bison \
+ --mandir=/usr/share/man --infodir=/usr/share/info --host=${CHOST}
+ try make ${MAKEOPTS}
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr datadir=${D}/usr/share/bison \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+
+ dodoc COPYING AUTHORS NEWS ChangeLog README REFERENCES OChangeLog
+ docinto txt
+ dodoc doc/FAQ
+}
+
+