summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-22 05:48:26 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-22 05:48:26 +0000
commit594773d1c783f63a4ebd6d50892e8168d0fc3a07 (patch)
tree1b64b090bf423f26e2abdbbcf8d76977d4b45463 /sys-devel/bison
parentVersion bump #250812 by Peter Volkov. (diff)
downloadgentoo-2-594773d1c783f63a4ebd6d50892e8168d0fc3a07.tar.gz
gentoo-2-594773d1c783f63a4ebd6d50892e8168d0fc3a07.tar.bz2
gentoo-2-594773d1c783f63a4ebd6d50892e8168d0fc3a07.zip
Version bump #250848 by Arfrever Frehtes Taifersar Arahesis.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog7
-rw-r--r--sys-devel/bison/bison-2.4.1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index e28567f97251..5b9548df84b6 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.76 2008/11/14 08:50:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.77 2008/12/22 05:48:26 vapier Exp $
+
+*bison-2.4.1 (22 Dec 2008)
+
+ 22 Dec 2008; Mike Frysinger <vapier@gentoo.org> +bison-2.4.1.ebuild:
+ Version bump #250848 by Arfrever Frehtes Taifersar Arahesis.
14 Nov 2008; Mike Frysinger <vapier@gentoo.org>
files/bison-2.4-compat.patch, bison-2.4-r1.ebuild:
diff --git a/sys-devel/bison/bison-2.4.1.ebuild b/sys-devel/bison/bison-2.4.1.ebuild
new file mode 100644
index 000000000000..dcf1d0f2ae53
--- /dev/null
+++ b/sys-devel/bison/bison-2.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.1.ebuild,v 1.1 2008/12/22 05:48:26 vapier Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A yacc-compatible parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls static"
+
+# need flex since we patch scan-code.l in ${P}-compat.patch
+DEPEND="nls? ( sys-devel/gettext )
+ sys-devel/flex"
+RDEPEND="sys-devel/m4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # since we patch sources, update mtimes on docs so we dont regen
+ touch doc/bison.1 doc/bison.info doc/cross-options.texi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # This one is installed by dev-util/yacc
+ mv "${D}"/usr/bin/yacc{,.bison} || die
+ mv "${D}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need this.
+ rm -r "${D}"/usr/lib* || die
+
+ dodoc AUTHORS NEWS ChangeLog README OChangeLog THANKS TODO
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}