summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-07 05:04:11 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-07 05:04:11 +0000
commit64fdce745415b47ecf3ee4c6944b89c25ee43f1e (patch)
treef5f6a48a7492fb8e07eea3d2f7382f0935a84980 /sys-devel/bin86
parentAdded ~mips, bug 345605. (diff)
downloadgentoo-2-64fdce745415b47ecf3ee4c6944b89c25ee43f1e.tar.gz
gentoo-2-64fdce745415b47ecf3ee4c6944b89c25ee43f1e.tar.bz2
gentoo-2-64fdce745415b47ecf3ee4c6944b89c25ee43f1e.zip
Version bump. Add patch by David J Cozatt #347817.
(Portage version: 2.2.0_alpha5/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/bin86')
-rw-r--r--sys-devel/bin86/ChangeLog11
-rw-r--r--sys-devel/bin86/bin86-0.16.18.ebuild38
-rw-r--r--sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch6
-rw-r--r--sys-devel/bin86/files/bin86-0.16.18-headers.patch34
4 files changed, 85 insertions, 4 deletions
diff --git a/sys-devel/bin86/ChangeLog b/sys-devel/bin86/ChangeLog
index e8bb5a475876..aa63ee3199ba 100644
--- a/sys-devel/bin86/ChangeLog
+++ b/sys-devel/bin86/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/bin86
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.19 2009/10/05 23:26:10 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.20 2010/12/07 05:04:10 vapier Exp $
+
+*bin86-0.16.18 (07 Dec 2010)
+
+ 07 Dec 2010; Mike Frysinger <vapier@gentoo.org>
+ files/bin86-0.16.17-amd64-build.patch, +bin86-0.16.18.ebuild,
+ +files/bin86-0.16.18-headers.patch:
+ Version bump. Add patch by David J Cozatt #347817.
05 Oct 2009; Mike Frysinger <vapier@gentoo.org> bin86-0.16.17.ebuild:
Update HOMEPAGE and SRC_URI.
diff --git a/sys-devel/bin86/bin86-0.16.18.ebuild b/sys-devel/bin86/bin86-0.16.18.ebuild
new file mode 100644
index 000000000000..9ded497423b3
--- /dev/null
+++ b/sys-devel/bin86/bin86-0.16.18.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.16.18.ebuild,v 1.1 2010/12/07 05:04:08 vapier Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Assembler and loader used to create kernel bootsector"
+HOMEPAGE="http://www.debath.co.uk/"
+SRC_URI="http://www.debath.co.uk/dev86/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
+ -e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
+ -e '/^INSTALL_OPTS/s:-s::' \
+ -e "/^CFLAGS/s:=.*:=${CFLAGS} -D_POSIX_SOURCE ${CPPFLAGS}:" \
+ -e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
+ Makefile || die
+ epatch "${FILESDIR}"/${P}-headers.patch #347817
+ use amd64 && epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ emake install DESTDIR="${D}" || die
+ dodoc README* ChangeLog
+}
diff --git a/sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch b/sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch
index b9397261686f..496d79020383 100644
--- a/sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch
+++ b/sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch
@@ -1,5 +1,7 @@
---- ld/x86_aout.h.orig 2003-01-28 17:17:14.000000000 -0500
-+++ ld/x86_aout.h 2005-05-07 22:40:05.000000000 -0400
+This should make it built on other archictectures as well
+
+--- ld/x86_aout.h
++++ ld/x86_aout.h
@@ -13,7 +13,9 @@
typedef long Long;
#define __OUT_OK 1
diff --git a/sys-devel/bin86/files/bin86-0.16.18-headers.patch b/sys-devel/bin86/files/bin86-0.16.18-headers.patch
new file mode 100644
index 000000000000..16c9fa1d8db8
--- /dev/null
+++ b/sys-devel/bin86/files/bin86-0.16.18-headers.patch
@@ -0,0 +1,34 @@
+fix implicit function decl warnings
+
+by David J Cozatt
+
+--- bin86-0.16.18/ld/catimage.c
++++ bin86-0.16.18/ld/catimage.c
+@@ -21,6 +21,8 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include "x86_aout.h"
+
+ #ifndef __OUT_OK
+--- bin86-0.16.18/ld/dumps.c
++++ bin86-0.16.18/ld/dumps.c
+@@ -6,6 +6,7 @@
+ #include "obj.h"
+ #include "type.h"
+ #include "globvar.h"
++#include <string.h>
+
+ /* print list of modules and whether they are loaded */
+
+--- bin86-0.16.18/ld/objchop.c
++++ bin86-0.16.18/ld/objchop.c
+@@ -1,5 +1,6 @@
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "x86_aout.h"
+
+ #ifndef __OUT_OK