summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2015-03-23 12:12:44 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2015-03-23 12:12:44 +0000
commiteaa6e11e506711f850d5d228e25ed6ad8e456a4a (patch)
tree2a44afe1191da5e5a5c7d353e90bc8cc3a923b07 /sys-cluster
parentFix python stuff, bug #542434 (diff)
downloadgentoo-2-eaa6e11e506711f850d5d228e25ed6ad8e456a4a.tar.gz
gentoo-2-eaa6e11e506711f850d5d228e25ed6ad8e456a4a.tar.bz2
gentoo-2-eaa6e11e506711f850d5d228e25ed6ad8e456a4a.zip
version bump, drop vulnerable
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/glusterfs/ChangeLog13
-rw-r--r--sys-cluster/glusterfs/files/glusterd-r2.initd33
-rw-r--r--sys-cluster/glusterfs/glusterfs-3.3.0.ebuild131
-rw-r--r--sys-cluster/glusterfs/glusterfs-3.4.2-r1.ebuild145
-rw-r--r--sys-cluster/glusterfs/glusterfs-3.4.4-r2.ebuild149
-rw-r--r--sys-cluster/glusterfs/glusterfs-3.4.4.ebuild147
-rw-r--r--sys-cluster/glusterfs/glusterfs-3.5.2.ebuild174
-rw-r--r--sys-cluster/glusterfs/glusterfs-3.5.3.ebuild (renamed from sys-cluster/glusterfs/glusterfs-3.5.1.ebuild)12
8 files changed, 50 insertions, 754 deletions
diff --git a/sys-cluster/glusterfs/ChangeLog b/sys-cluster/glusterfs/ChangeLog
index 8fe6206268de..153f6dbea564 100644
--- a/sys-cluster/glusterfs/ChangeLog
+++ b/sys-cluster/glusterfs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-cluster/glusterfs
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/ChangeLog,v 1.61 2014/10/08 09:10:21 ultrabug Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/ChangeLog,v 1.62 2015/03/23 12:12:44 ultrabug Exp $
+
+*glusterfs-3.5.3 (23 Mar 2015)
+
+ 23 Mar 2015; Ultrabug <ultrabug@gentoo.org> -glusterfs-3.3.0.ebuild,
+ -glusterfs-3.4.2-r1.ebuild, -glusterfs-3.4.4.ebuild,
+ -glusterfs-3.4.4-r2.ebuild, -glusterfs-3.5.1.ebuild, -glusterfs-3.5.2.ebuild,
+ +glusterfs-3.5.3.ebuild, +files/glusterd-r2.initd:
+ version bump, drop old and vulnerable wrt #541540, fix #536606 thx to Jaco
+ Kroon, fix #529676 thx to Christian Affolter
*glusterfs-3.5.2 (08 Oct 2014)
diff --git a/sys-cluster/glusterfs/files/glusterd-r2.initd b/sys-cluster/glusterfs/files/glusterd-r2.initd
new file mode 100644
index 000000000000..4993f6355993
--- /dev/null
+++ b/sys-cluster/glusterfs/files/glusterd-r2.initd
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/files/glusterd-r2.initd,v 1.1 2015/03/23 12:12:44 ultrabug Exp $
+
+description="Gluster elastic volume management daemon"
+command="/usr/sbin/glusterd"
+pidfile="/var/run/${SVCNAME}.pid"
+command_args="-N"
+
+command_background="yes"
+
+depend() {
+ need net
+ before netmount
+}
+
+start_pre() {
+ # Ensure that the GlusterFS auxiliary mount parent directory exists
+ checkpath --directory --owner root:root --mode 0700 /var/run/gluster
+}
+
+start_post() {
+ local c=0
+ ebegin "Waiting for glusterd to start up"
+ while ! /usr/sbin/gluster volume list &>/dev/null && [ "${c}" -lt "${glusterd_max_wait_start-60}" ]; do
+ (( ++c ))
+ done
+ [ "${c}" -lt "${glusterd_max_wait_start-60}" ]
+ eend $?
+
+ return 0
+}
diff --git a/sys-cluster/glusterfs/glusterfs-3.3.0.ebuild b/sys-cluster/glusterfs/glusterfs-3.3.0.ebuild
deleted file mode 100644
index ffa0c83ab5bd..000000000000
--- a/sys-cluster/glusterfs/glusterfs-3.3.0.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.3.0.ebuild,v 1.5 2014/08/11 22:28:30 blueness Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2"
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils elisp-common eutils multilib python versionator
-
-DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
-HOMEPAGE="http://www.gluster.org/"
-SRC_URI="http://ftp.gluster.com/pub/gluster/${PN}/$(get_version_component_range '1-2')/${PV}/${P}.tar.gz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="emacs extras +fuse infiniband static-libs vim-syntax"
-
-RDEPEND="emacs? ( virtual/emacs )
- fuse? ( >=sys-fs/fuse-2.7.0 )
- infiniband? ( sys-infiniband/libibverbs )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/bison
- sys-devel/flex"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-PATCHES=(
- "${FILESDIR}/${P}-parallel-build.patch"
- "${FILESDIR}/${P}-docdir.patch"
- "${FILESDIR}/${P}-silent_rules.patch"
- "${FILESDIR}/${P}-avoid-version.patch"
-)
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- sed -e "s/ -ggdb3//g" \
- -i argp-standalone/configure.ac || die
- autotools-utils_src_prepare
- cd argp-standalone && eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-dependency-tracking
- --disable-silent-rules
- $(use_enable fuse fuse-client)
- $(use_enable infiniband ibverbs)
- $(use_enable static-libs static)
- --enable-georeplication
- --docdir=/usr/share/doc/${PF}
- --localstatedir=/var
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- if use emacs ; then
- elisp-compile extras/glusterfs-mode.el || die
- fi
-}
-
-src_install() {
- autotools-utils_src_install
-
- if use emacs ; then
- elisp-install ${PN} extras/glusterfs-mode.el* || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
- insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
- fi
-
- if use extras ; then
- newbin extras/backend-xattr-sanitize.sh ${PN}-backend-xattr-sanitize
- newbin extras/backend-cleanup.sh ${PN}-backend-cleanup
- newbin extras/migrate-unify-to-distribute.sh ${PN}-migrate-unify-to-distribute
- newbin extras/disk_usage_sync.sh ${PN}-disk-usage-sync
- fi
-
- newinitd "${FILESDIR}/${PN}.initd" glusterfsd
- newinitd "${FILESDIR}/glusterd.initd" glusterd
- newconfd "${FILESDIR}/${PN}.confd" glusterfsd
-
- keepdir /var/log/${PN}
- keepdir /var/lib/glusterd
-
- python_convert_shebangs -r 2 "${ED}"
-}
-
-pkg_postinst() {
- elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
- elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
- elog " /etc/init.d/glusterd start"
- elog
- elog "For static configurations, the glusterfsd startup script can be multiplexed."
- elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
- elog "separate service. To create additional instances of the glusterfsd service"
- elog "simply create a symlink to the glusterfsd startup script."
- elog
- elog "Example:"
- elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
- elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
- elog "You can now treat glusterfsd2 like any other service"
- elog
- ewarn "You need to use a ntp client to keep the clocks synchronized across all"
- ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
- ewarn "run GlusterFS."
-
- elog
- elog "You are upgrading from a previous version of ${PN}, please read:"
- elog "http://vbellur.wordpress.com/2012/05/31/upgrading-to-glusterfs-3-3/"
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sys-cluster/glusterfs/glusterfs-3.4.2-r1.ebuild b/sys-cluster/glusterfs/glusterfs-3.4.2-r1.ebuild
deleted file mode 100644
index 60423a0ac7d6..000000000000
--- a/sys-cluster/glusterfs/glusterfs-3.4.2-r1.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.4.2-r1.ebuild,v 1.2 2014/08/11 22:28:30 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils elisp-common eutils multilib python-single-r1 versionator
-
-DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
-HOMEPAGE="http://www.gluster.org/"
-SRC_URI="http://download.gluster.org/pub/gluster/${PN}/$(get_version_component_range '1-2')/${PV}/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 LGPL-3+ )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="bd-xlator debug emacs extras +fuse +georeplication infiniband static-libs systemtap vim-syntax"
-
-REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="bd-xlator? ( sys-fs/lvm2 )
- emacs? ( virtual/emacs )
- fuse? ( >=sys-fs/fuse-2.7.0 )
- georeplication? ( ${PYTHON_DEPS} )
- infiniband? ( sys-infiniband/libibverbs sys-infiniband/librdmacm )
- systemtap? ( dev-util/systemtap )
- sys-libs/readline
- dev-libs/libaio
- dev-libs/libxml2
- dev-libs/openssl
- || ( sys-libs/glibc sys-libs/argp-standalone )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/bison
- sys-devel/flex"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.4.0-silent_rules.patch"
- "${FILESDIR}/${PN}-3.4.0-build-shared-only.patch"
- "${FILESDIR}/${PN}-3.4.0-nfs-exit-when-all-volumes-are-disabled.patch"
-)
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-
-# Maintainer notes:
-# * The build system will always configure & build argp-standalone but it'll never use it
-# if the argp.h header is found in the system. Which should be the case with
-# glibc or if argp-standalone is installed.
-
-pkg_setup() {
- use georeplication && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-dependency-tracking
- --disable-silent-rules
- --disable-fusermount
- $(use_enable debug)
- $(use_enable bd-xlator )
- $(use_enable fuse fuse-client)
- $(use_enable georeplication)
- $(use_enable infiniband ibverbs)
- $(use_enable static-libs static)
- $(use_enable systemtap)
- --docdir=/usr/share/doc/${PF}
- --localstatedir=/var
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
-
- use emacs && elisp-compile extras/glusterfs-mode.el
-}
-
-src_install() {
- autotools-utils_src_install
-
- rm "${D}/etc/glusterfs/glusterfs-logrotate" || die "removing false logrotate failed"
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/glusterfs.logrotate glusterfs
-
- if use emacs ; then
- elisp-install ${PN} extras/glusterfs-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
- insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
- fi
-
- if use extras ; then
- sed -i -e "s|quota-remove-xattr.sh|${PN}-quota-remove-xattr|" extras/quota-metadata-cleanup.sh || die "sed failed"
- for e in backend-xattr-sanitize backend-cleanup migrate-unify-to-distribute quota-metadata-cleanup quota-remove-xattr ; do
- newbin extras/${e}.sh ${PN}-${e}
- done
- newbin extras/disk_usage_sync.sh ${PN}-disk-usage-sync
- fi
-
- newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
- newinitd "${FILESDIR}/glusterd-r1.initd" glusterd
- newconfd "${FILESDIR}/${PN}.confd" glusterfsd
-
- keepdir /var/log/${PN}
- keepdir /var/lib/glusterd
-
- use georeplication && python_fix_shebang "${ED}"
-}
-
-pkg_postinst() {
- elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
- elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
- elog " /etc/init.d/glusterd start"
- elog
- elog "For static configurations, the glusterfsd startup script can be multiplexed."
- elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
- elog "separate service. To create additional instances of the glusterfsd service"
- elog "simply create a symlink to the glusterfsd startup script."
- elog
- elog "Example:"
- elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
- elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
- elog "You can now treat glusterfsd2 like any other service"
- elog
- ewarn "You need to use a ntp client to keep the clocks synchronized across all"
- ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
- ewarn "run GlusterFS."
-
- elog
- elog "If you are upgrading from a previous version of ${PN}, please read:"
- elog " https://vbellur.wordpress.com/2013/07/15/upgrading-to-glusterfs-3-4/"
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sys-cluster/glusterfs/glusterfs-3.4.4-r2.ebuild b/sys-cluster/glusterfs/glusterfs-3.4.4-r2.ebuild
deleted file mode 100644
index a5f9b7ecb547..000000000000
--- a/sys-cluster/glusterfs/glusterfs-3.4.4-r2.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.4.4-r2.ebuild,v 1.2 2014/08/11 22:28:30 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils elisp-common eutils multilib python-single-r1 versionator
-
-DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
-HOMEPAGE="http://www.gluster.org/"
-SRC_URI="http://download.gluster.org/pub/gluster/${PN}/$(get_version_component_range '1-2')/${PV}/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 LGPL-3+ )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="bd-xlator debug emacs extras +fuse +georeplication infiniband static-libs systemtap vim-syntax"
-
-REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="bd-xlator? ( sys-fs/lvm2 )
- emacs? ( virtual/emacs )
- fuse? ( >=sys-fs/fuse-2.7.0 )
- georeplication? ( ${PYTHON_DEPS} )
- infiniband? ( sys-infiniband/libibverbs sys-infiniband/librdmacm )
- systemtap? ( dev-util/systemtap )
- sys-libs/readline
- dev-libs/libaio
- dev-libs/libxml2
- dev-libs/openssl
- || ( sys-libs/glibc sys-libs/argp-standalone )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/bison
- sys-devel/flex"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.4.0-silent_rules.patch"
- "${FILESDIR}/${PN}-3.4.0-build-shared-only.patch"
- "${FILESDIR}/${PN}-3.4.4-fuse-fix-memory-leak-in-fuse_getxattr.patch"
- "${FILESDIR}/${PN}-3.4.4-cluster-dht-Don-t-do-extra-unref-in-dht-migration-ch.patch"
-)
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-
-# Maintainer notes:
-# * The build system will always configure & build argp-standalone but it'll never use it
-# if the argp.h header is found in the system. Which should be the case with
-# glibc or if argp-standalone is installed.
-
-pkg_setup() {
- use georeplication && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-dependency-tracking
- --disable-silent-rules
- --disable-fusermount
- $(use_enable debug)
- $(use_enable bd-xlator )
- $(use_enable fuse fuse-client)
- $(use_enable georeplication)
- $(use_enable infiniband ibverbs)
- $(use_enable static-libs static)
- $(use_enable systemtap)
- --docdir=/usr/share/doc/${PF}
- --localstatedir=/var
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
-
- use emacs && elisp-compile extras/glusterfs-mode.el
-}
-
-src_install() {
- autotools-utils_src_install
-
- rm "${D}/etc/glusterfs/glusterfs-logrotate" || die "removing false logrotate failed"
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/glusterfs.logrotate glusterfs
-
- if use emacs ; then
- elisp-install ${PN} extras/glusterfs-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
- insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
- fi
-
- if use extras ; then
- sed -i -e "s|quota-remove-xattr.sh|${PN}-quota-remove-xattr|" extras/quota-metadata-cleanup.sh || die "sed failed"
- for e in backend-xattr-sanitize backend-cleanup migrate-unify-to-distribute quota-metadata-cleanup quota-remove-xattr ; do
- newbin extras/${e}.sh ${PN}-${e}
- done
- newbin extras/disk_usage_sync.sh ${PN}-disk-usage-sync
- fi
-
- newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
- newinitd "${FILESDIR}/glusterd-r1.initd" glusterd
- newconfd "${FILESDIR}/${PN}.confd" glusterfsd
-
- keepdir /var/log/${PN}
- keepdir /var/lib/glusterd
-
- # QA
- rm -rf "${ED}/var/run/"
-
- use georeplication && python_fix_shebang "${ED}"
-}
-
-pkg_postinst() {
- elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
- elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
- elog " /etc/init.d/glusterd start"
- elog
- elog "For static configurations, the glusterfsd startup script can be multiplexed."
- elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
- elog "separate service. To create additional instances of the glusterfsd service"
- elog "simply create a symlink to the glusterfsd startup script."
- elog
- elog "Example:"
- elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
- elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
- elog "You can now treat glusterfsd2 like any other service"
- elog
- ewarn "You need to use a ntp client to keep the clocks synchronized across all"
- ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
- ewarn "run GlusterFS."
-
- elog
- elog "If you are upgrading from a previous version of ${PN}, please read:"
- elog " https://vbellur.wordpress.com/2013/07/15/upgrading-to-glusterfs-3-4/"
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sys-cluster/glusterfs/glusterfs-3.4.4.ebuild b/sys-cluster/glusterfs/glusterfs-3.4.4.ebuild
deleted file mode 100644
index fc456d1fea81..000000000000
--- a/sys-cluster/glusterfs/glusterfs-3.4.4.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.4.4.ebuild,v 1.2 2014/08/11 22:28:30 blueness Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils elisp-common eutils multilib python-single-r1 versionator
-
-DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
-HOMEPAGE="http://www.gluster.org/"
-SRC_URI="http://download.gluster.org/pub/gluster/${PN}/$(get_version_component_range '1-2')/${PV}/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 LGPL-3+ )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="bd-xlator debug emacs extras +fuse +georeplication infiniband static-libs systemtap vim-syntax"
-
-REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="bd-xlator? ( sys-fs/lvm2 )
- emacs? ( virtual/emacs )
- fuse? ( >=sys-fs/fuse-2.7.0 )
- georeplication? ( ${PYTHON_DEPS} )
- infiniband? ( sys-infiniband/libibverbs sys-infiniband/librdmacm )
- systemtap? ( dev-util/systemtap )
- sys-libs/readline
- dev-libs/libaio
- dev-libs/libxml2
- dev-libs/openssl
- || ( sys-libs/glibc sys-libs/argp-standalone )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/bison
- sys-devel/flex"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.4.0-silent_rules.patch"
- "${FILESDIR}/${PN}-3.4.0-build-shared-only.patch"
-)
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-
-# Maintainer notes:
-# * The build system will always configure & build argp-standalone but it'll never use it
-# if the argp.h header is found in the system. Which should be the case with
-# glibc or if argp-standalone is installed.
-
-pkg_setup() {
- use georeplication && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-dependency-tracking
- --disable-silent-rules
- --disable-fusermount
- $(use_enable debug)
- $(use_enable bd-xlator )
- $(use_enable fuse fuse-client)
- $(use_enable georeplication)
- $(use_enable infiniband ibverbs)
- $(use_enable static-libs static)
- $(use_enable systemtap)
- --docdir=/usr/share/doc/${PF}
- --localstatedir=/var
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
-
- use emacs && elisp-compile extras/glusterfs-mode.el
-}
-
-src_install() {
- autotools-utils_src_install
-
- rm "${D}/etc/glusterfs/glusterfs-logrotate" || die "removing false logrotate failed"
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/glusterfs.logrotate glusterfs
-
- if use emacs ; then
- elisp-install ${PN} extras/glusterfs-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
- insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
- fi
-
- if use extras ; then
- sed -i -e "s|quota-remove-xattr.sh|${PN}-quota-remove-xattr|" extras/quota-metadata-cleanup.sh || die "sed failed"
- for e in backend-xattr-sanitize backend-cleanup migrate-unify-to-distribute quota-metadata-cleanup quota-remove-xattr ; do
- newbin extras/${e}.sh ${PN}-${e}
- done
- newbin extras/disk_usage_sync.sh ${PN}-disk-usage-sync
- fi
-
- newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
- newinitd "${FILESDIR}/glusterd-r1.initd" glusterd
- newconfd "${FILESDIR}/${PN}.confd" glusterfsd
-
- keepdir /var/log/${PN}
- keepdir /var/lib/glusterd
-
- # QA
- rm -rf "${ED}/var/run/"
-
- use georeplication && python_fix_shebang "${ED}"
-}
-
-pkg_postinst() {
- elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
- elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
- elog " /etc/init.d/glusterd start"
- elog
- elog "For static configurations, the glusterfsd startup script can be multiplexed."
- elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
- elog "separate service. To create additional instances of the glusterfsd service"
- elog "simply create a symlink to the glusterfsd startup script."
- elog
- elog "Example:"
- elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
- elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
- elog "You can now treat glusterfsd2 like any other service"
- elog
- ewarn "You need to use a ntp client to keep the clocks synchronized across all"
- ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
- ewarn "run GlusterFS."
-
- elog
- elog "If you are upgrading from a previous version of ${PN}, please read:"
- elog " https://vbellur.wordpress.com/2013/07/15/upgrading-to-glusterfs-3-4/"
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sys-cluster/glusterfs/glusterfs-3.5.2.ebuild b/sys-cluster/glusterfs/glusterfs-3.5.2.ebuild
deleted file mode 100644
index 8e99bfffe5ba..000000000000
--- a/sys-cluster/glusterfs/glusterfs-3.5.2.ebuild
+++ /dev/null
@@ -1,174 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.5.2.ebuild,v 1.1 2014/10/08 09:10:21 ultrabug Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils elisp-common eutils multilib python-single-r1 versionator
-
-DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
-HOMEPAGE="http://www.gluster.org/"
-SRC_URI="http://download.gluster.org/pub/gluster/${PN}/$(get_version_component_range '1-2')/${PV}/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 LGPL-3+ )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="bd-xlator crypt-xlator debug emacs +fuse +georeplication glupy infiniband qemu-block rsyslog static-libs +syslog systemtap vim-syntax +xml"
-
-REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )
- glupy? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="bd-xlator? ( sys-fs/lvm2 )
- emacs? ( virtual/emacs )
- fuse? ( >=sys-fs/fuse-2.7.0 )
- georeplication? ( ${PYTHON_DEPS} )
- infiniband? ( sys-infiniband/libibverbs sys-infiniband/librdmacm )
- qemu-block? ( dev-libs/glib:2 )
- systemtap? ( dev-util/systemtap )
- xml? ( dev-libs/libxml2 )
- sys-libs/readline
- dev-libs/libaio
- dev-libs/openssl
- || ( sys-libs/glibc sys-libs/argp-standalone )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/bison
- sys-devel/flex"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.4.0-silent_rules.patch"
- "${FILESDIR}/${PN}-3.5.1-Add-libraries-using-LIBADD-instead-of-LDFLAGS.patch"
- "${FILESDIR}/${PN}-3.5.1-build-shared-only.patch"
-)
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-
-# Maintainer notes:
-# * The build system will always configure & build argp-standalone but it'll never use it
-# if the argp.h header is found in the system. Which should be the case with
-# glibc or if argp-standalone is installed.
-
-pkg_setup() {
- ( use georeplication || use glupy ) && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-dependency-tracking
- --disable-silent-rules
- --disable-fusermount
- $(use_enable debug)
- $(use_enable bd-xlator)
- $(use_enable crypt-xlator)
- $(use_enable fuse fuse-client)
- $(use_enable georeplication)
- $(use_enable glupy)
- $(use_enable infiniband ibverbs)
- $(use_enable qemu-block)
- $(use_enable static-libs static)
- $(use_enable syslog)
- $(use_enable systemtap)
- $(use_enable xml xml-output)
- --docdir=/usr/share/doc/${PF}
- --localstatedir=/var
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
-
- use emacs && elisp-compile extras/glusterfs-mode.el
-}
-
-src_install() {
- autotools-utils_src_install
-
- rm \
- "${D}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
- "${D}"/etc/glusterfs/gluster-rsyslog-*.conf \
- "${D}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/glusterfs.logrotate glusterfs
-
- if use rsyslog ; then
- insinto /etc/rsyslog.d
- newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
- fi
-
- if use emacs ; then
- elisp-install ${PN} extras/glusterfs-mode.el*
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
- insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
- fi
-
- # insert some other tools which might be useful
- insinto /usr/share/glusterfs/scripts
- doins \
- extras/backend-{cleanup,xattr-sanitize}.sh \
- extras/clear_xattrs.sh \
- extras/migrate-unify-to-distribute.sh
-
- # correct permissions on installed scripts
- # fperms 0755 /usr/share/glusterfs/scripts/*.sh
- chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
-
- if use georeplication ; then
- # move the gsync-sync-gfid tool to a binary path
- # and set a symlink to be compliant with all other distros
- mv "${ED}"/usr/{share/glusterfs/scripts/gsync-sync-gfid,libexec/glusterfs/} || die
- dosym ../../../libexec/glusterfs/gsync-sync-gfid /usr/share/glusterfs/scripts/gsync-sync-gfid
- fi
-
- newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
- newinitd "${FILESDIR}/glusterd-r1.initd" glusterd
- newconfd "${FILESDIR}/${PN}.confd" glusterfsd
-
- keepdir /var/log/${PN}
- keepdir /var/lib/glusterd
-
- # QA
- rm -rf "${ED}/var/run/" || die
-
- use georeplication && python_fix_shebang "${ED}"
-}
-
-pkg_postinst() {
- elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
- elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
- elog " /etc/init.d/glusterd start"
- echo
- elog "For static configurations, the glusterfsd startup script can be multiplexed."
- elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
- elog "separate service. To create additional instances of the glusterfsd service"
- elog "simply create a symlink to the glusterfsd startup script."
- echo
- elog "Example:"
- elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
- elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
- elog "You can now treat glusterfsd2 like any other service"
- echo
- ewarn "You need to use a ntp client to keep the clocks synchronized across all"
- ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
- ewarn "run GlusterFS."
-
- elog
- elog "If you are upgrading from a previous version of ${PN}, please read:"
- elog " http://www.gluster.org/community/documentation/index.php/Upgrade_to_3.5"
-
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sys-cluster/glusterfs/glusterfs-3.5.1.ebuild b/sys-cluster/glusterfs/glusterfs-3.5.3.ebuild
index 00a2c700563a..ef2ad325f161 100644
--- a/sys-cluster/glusterfs/glusterfs-3.5.1.ebuild
+++ b/sys-cluster/glusterfs/glusterfs-3.5.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.5.1.ebuild,v 1.3 2014/08/11 22:28:30 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/glusterfs/glusterfs-3.5.3.ebuild,v 1.1 2015/03/23 12:12:44 ultrabug Exp $
EAPI=5
@@ -25,13 +25,13 @@ RDEPEND="bd-xlator? ( sys-fs/lvm2 )
emacs? ( virtual/emacs )
fuse? ( >=sys-fs/fuse-2.7.0 )
georeplication? ( ${PYTHON_DEPS} )
- infiniband? ( sys-infiniband/libibverbs sys-infiniband/librdmacm )
+ infiniband? ( sys-infiniband/libibverbs:* sys-infiniband/librdmacm:* )
qemu-block? ( dev-libs/glib:2 )
systemtap? ( dev-util/systemtap )
xml? ( dev-libs/libxml2 )
- sys-libs/readline
+ sys-libs/readline:=
dev-libs/libaio
- dev-libs/openssl
+ dev-libs/openssl:=
|| ( sys-libs/glibc sys-libs/argp-standalone )"
DEPEND="${RDEPEND}
virtual/pkgconfig
@@ -131,7 +131,7 @@ src_install() {
fi
newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
- newinitd "${FILESDIR}/glusterd-r1.initd" glusterd
+ newinitd "${FILESDIR}/glusterd-r2.initd" glusterd
newconfd "${FILESDIR}/${PN}.confd" glusterfsd
keepdir /var/log/${PN}