summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-06-01 04:32:10 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-06-01 04:32:10 +0000
commitde9f2245da9435f4da0b4ce1b6f86ac7943a30b4 (patch)
tree6848e47cd608382623e0aea054b5e83749fecd22 /sys-cluster
parentclean old ebuilds and files (diff)
downloadgentoo-2-de9f2245da9435f4da0b4ce1b6f86ac7943a30b4.tar.gz
gentoo-2-de9f2245da9435f4da0b4ce1b6f86ac7943a30b4.tar.bz2
gentoo-2-de9f2245da9435f4da0b4ce1b6f86ac7943a30b4.zip
latest version
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charm/ChangeLog9
-rw-r--r--sys-cluster/charm/charm-5.9.ebuild4
-rw-r--r--sys-cluster/charm/charm-6.1.2.ebuild143
-rw-r--r--sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch26
-rw-r--r--sys-cluster/charm/files/charm-6.1.2-charmrun.patch11
-rw-r--r--sys-cluster/charm/metadata.xml1
6 files changed, 192 insertions, 2 deletions
diff --git a/sys-cluster/charm/ChangeLog b/sys-cluster/charm/ChangeLog
index c7d0c1e9bfae..53911e046c35 100644
--- a/sys-cluster/charm/ChangeLog
+++ b/sys-cluster/charm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/charm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/ChangeLog,v 1.19 2009/05/30 09:10:54 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/ChangeLog,v 1.20 2009/06/01 04:32:10 je_fro Exp $
+
+*charm-6.1.2 (01 Jun 2009)
+
+ 01 Jun 2009; Jeff Gardner <je_fro@gentoo.org> +charm-6.1.2.ebuild,
+ +files/charm-6.1.2-charmc-gentoo.patch, +files/charm-6.1.2-charmrun.patch,
+ metadata.xml:
+ Latest version.
30 May 2009; Ulrich Mueller <ulm@gentoo.org> charm-5.9.ebuild:
Remove app-text/tetex from dependencies, bug 227443.
diff --git a/sys-cluster/charm/charm-5.9.ebuild b/sys-cluster/charm/charm-5.9.ebuild
index 75e7c36208f6..5537283ad0d4 100644
--- a/sys-cluster/charm/charm-5.9.ebuild
+++ b/sys-cluster/charm/charm-5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/charm-5.9.ebuild,v 1.16 2009/05/30 09:10:54 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/charm-5.9.ebuild,v 1.17 2009/06/01 04:32:10 je_fro Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -25,6 +25,8 @@ DEPEND="
app-text/ptex )
)"
+RDEPEND="${DEPEND}"
+
CHARM_ARCH="net-linux"
CHARM_DOWNLOAD="http://charm.cs.uiuc.edu/download/"
diff --git a/sys-cluster/charm/charm-6.1.2.ebuild b/sys-cluster/charm/charm-6.1.2.ebuild
new file mode 100644
index 000000000000..ae891ea10cc8
--- /dev/null
+++ b/sys-cluster/charm/charm-6.1.2.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/charm-6.1.2.ebuild,v 1.3 2009/06/01 04:32:10 je_fro Exp $
+
+inherit eutils toolchain-funcs flag-o-matic multilib
+
+DESCRIPTION="Charm++ is a message-passing parallel language and runtime system."
+LICENSE="charm"
+HOMEPAGE="http://charm.cs.uiuc.edu/"
+SRC_URI="${PN}_src.tar.gz"
+S="${WORKDIR}/${PN}"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cmkopt tcp smp doc icc"
+
+DEPEND="icc? ( >=dev-lang/icc-8.1 )
+ doc? (
+ app-text/poppler
+ dev-tex/latex2html
+ virtual/tex-base
+ )"
+
+RDEPEND="${DEPEND}"
+
+case ${ARCH} in
+
+ x86)
+ CHARM_ARCH="net-linux" ;;
+
+ amd64)
+ CHARM_ARCH="net-linux-amd64" ;;
+esac
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-charmrun.patch"
+
+ # TCP instead of default UDP for socket comunication
+ # protocol
+ if use tcp; then
+ CHARM_OPTS="${CHARM_OPTS} tcp"
+ fi
+
+ # enable direct SMP support using shared memory
+# if use smp && [ "${ARCH}" != "amd64" ]; then
+ if use smp; then
+ CHARM_OPTS="${CHARM_OPTS} smp"
+ fi
+
+ # compile with icc if requested
+ if use icc; then
+ if [ $(tc-getCC) != "icc" ]; then
+ die "You cannot use $(tc-getCC) with USE='icc'"
+ fi
+ CHARM_OPTS="${CHARM_OPTS} icc"
+ else
+ CHARM_OPTS="${CHARM_OPTS} gcc gfortran"
+ fi
+
+ # CMK optimization
+ if use cmkopt; then
+ append-flags -DCMK_OPTIMIZE=1
+ fi
+
+ echo "charm opts: ${CHARM_OPTS}"
+}
+
+src_compile() {
+ # build charmm++ first
+ cd "${S}"
+ ./build charm++ ${CHARM_ARCH} ${CHARM_OPTS} ${CFLAGS} || \
+ die "Failed to build charm++"
+
+ # make pdf/html docs
+ if use doc; then
+ cd "${S}"/doc
+ make doc || die "failed to create pdf/html docs"
+ fi
+}
+
+src_install() {
+ # make charmc play well with gentoo before
+ # we move it into /usr/bin
+ epatch "${FILESDIR}/${P}-charmc-gentoo.patch"
+
+ sed -e "s|gentoo-include|${P}|" \
+ -e "s|gentoo-libdir|$(get_libdir)|g" \
+ -e "s|VERSION|${P}/VERSION|" \
+ -i ./src/scripts/charmc || die "failed patching charmc script"
+
+ # install binaries
+ cd "${S}"/bin
+ dobin ./charmd ./charmd_faceless ./charmr* ./charmc ./charmxi \
+ ./conv-cpm ./dep.pl || die "Failed to install binaries"
+
+ # install headers
+ cd "${S}"/include
+ insinto /usr/include/${P}
+ doins * || die "failed to install header files"
+
+ # install static libs
+ cd "${S}"/lib
+ dolib.a * || die "failed to install static libs"
+
+ # install shared libs
+ cd "${S}"/lib_so
+ dolib.so * || die "failed to install shared libs"
+
+ # basic docs
+ cd "${S}"
+ dodoc CHANGES README || die "Failed to install docs"
+
+ # install examples
+ find examples/ -name 'Makefile' | xargs sed \
+ -r "s:(../)+bin/charmc:/usr/bin/charmc:" -i || \
+ die "Failed to fix examples"
+ find examples/ -name 'Makefile' | xargs sed \
+ -r "s:./charmrun:./charmrun ++local:" -i || \
+ die "Failed to fix examples"
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/charm++/*
+
+ # pdf/html docs
+ if use doc; then
+ cd "${S}"/doc
+ # install pdfs
+ insinto /usr/share/doc/${PF}/pdf
+ doins doc/pdf/* || die "failed to install pdf docs"
+ # install html
+ docinto html
+ dohtml -r doc/html/* || die "failed to install html docs"
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "Please test your charm installation by copying the"
+ einfo "content of /usr/share/doc/${PF}/examples to a"
+ einfo "temporary location and run 'make test'."
+ echo
+}
diff --git a/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch b/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch
new file mode 100644
index 000000000000..4c4cfceeaa4a
--- /dev/null
+++ b/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch
@@ -0,0 +1,26 @@
+--- src/scripts/charmc.old 2009-05-31 23:09:12.285687725 -0500
++++ src/scripts/charmc 2009-05-31 23:08:49.782155308 -0500
+@@ -335,19 +335,9 @@
+ PROG_EXT=".exe"
+ fi
+
+-CHARMLIB="$CHARMBIN/../lib"
+-CHARMINC="$CHARMBIN/../include"
+-CHARMLIBSO=
+-if test -d "$CHARMBIN/../lib_so"
+-then
+- CHARMLIBSO=`cd $CHARMBIN/../lib_so 2>/dev/null && pwd`
+- #getting absolute path is harder than thought because of symbolic links and ..
+- #ksh needs cd -P to resolve werid symbolic links, however -P is not portable
+- #csh is ok too if it exists
+- test -z "$CHARMLIBSO" && CHARMLIBSO=`cd -P $CHARMBIN/../lib_so 2>/dev/null && pwd`
+- test -z "$CHARMLIBSO" && CHARMLIBSO=`csh -c "cd $CHARMBIN/../lib_so >& /dev/null && pwd"`
+- test -z "$CHARMLIBSO" && echo "$CHARMBIN/../lib_so: not found" && exit 1
+-fi
++CHARMLIB="$/usr/gentoo-libdir"
++CHARMINC="/usr/include/gentoo-include"
++CHARMLIBSO="/usr/gentoo-libdir"
+
+ ##############################################################################
+ #
+
diff --git a/sys-cluster/charm/files/charm-6.1.2-charmrun.patch b/sys-cluster/charm/files/charm-6.1.2-charmrun.patch
new file mode 100644
index 000000000000..d677051c8e9d
--- /dev/null
+++ b/sys-cluster/charm/files/charm-6.1.2-charmrun.patch
@@ -0,0 +1,11 @@
+--- src/arch/net/charmrun/charmrun.c.orig 2009-05-30 10:37:32.676819167 -0500
++++ src/arch/net/charmrun/charmrun.c 2009-05-30 10:38:08.835027500 -0500
+@@ -1291,7 +1291,7 @@
+ char *tmp=tmpnam(NULL);/*This was once /tmp/fnord*/
+ #endif
+ unlink(tmp);
+- fd = open(tmp,O_RDWR | O_CREAT | O_TRUNC);
++ fd = open(tmp,O_RDWR | O_CREAT | O_TRUNC, 0666);
+ if (fd<0) {
+ fprintf(stderr,"cannot open temp file /tmp/fnord");
+ exit(1);
diff --git a/sys-cluster/charm/metadata.xml b/sys-cluster/charm/metadata.xml
index 53f9cc0dcbc1..05a203d477d3 100644
--- a/sys-cluster/charm/metadata.xml
+++ b/sys-cluster/charm/metadata.xml
@@ -9,5 +9,6 @@
<use>
<flag name='cmkopt'>Enable CMK optimisation</flag>
<flag name='tcp'>Use TCP (instead of UPD) for socket communication</flag>
+ <flag name='icc'>Use Intel compiler to build package</flag>
</use>
</pkgmetadata>