summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-05-01 16:42:43 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-05-01 16:42:43 +0000
commit92367c2735f6ae4488de1a3173e18fb9b9f7ee83 (patch)
tree7b53dcd0fc5f1966f4c082c9c134fab3888e2158 /sys-cluster
parentSecurity bumps (bug #468110). (diff)
downloadgentoo-2-92367c2735f6ae4488de1a3173e18fb9b9f7ee83.tar.gz
gentoo-2-92367c2735f6ae4488de1a3173e18fb9b9f7ee83.tar.bz2
gentoo-2-92367c2735f6ae4488de1a3173e18fb9b9f7ee83.zip
switch out refrences from xattr to pyxattr in requires.txt and pip-requires
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/swift/ChangeLog6
-rw-r--r--sys-cluster/swift/swift-1.7.6-r2.ebuild7
-rw-r--r--sys-cluster/swift/swift-1.8.0-r1.ebuild7
-rw-r--r--sys-cluster/swift/swift-9999.ebuild7
4 files changed, 23 insertions, 4 deletions
diff --git a/sys-cluster/swift/ChangeLog b/sys-cluster/swift/ChangeLog
index 3a4d625b9b2f..7bd1d9e121e0 100644
--- a/sys-cluster/swift/ChangeLog
+++ b/sys-cluster/swift/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/swift
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.7 2013/05/01 15:22:46 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/ChangeLog,v 1.8 2013/05/01 16:42:43 prometheanfire Exp $
+
+ 01 May 2013; Matthew Thode <prometheanfire@gentoo.org> swift-1.7.6-r2.ebuild,
+ swift-1.8.0-r1.ebuild, swift-9999.ebuild:
+ switch out refrences from xattr to pyxattr in requires.txt and pip-requires
*swift-1.8.0-r1 (01 May 2013)
*swift-1.7.6-r2 (01 May 2013)
diff --git a/sys-cluster/swift/swift-1.7.6-r2.ebuild b/sys-cluster/swift/swift-1.7.6-r2.ebuild
index 622779988715..238a1cd908a7 100644
--- a/sys-cluster/swift/swift-1.7.6-r2.ebuild
+++ b/sys-cluster/swift/swift-1.7.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.7.6-r2.ebuild,v 1.1 2013/05/01 15:22:46 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.7.6-r2.ebuild,v 1.2 2013/05/01 16:42:43 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
@@ -53,6 +53,11 @@ pkg_setup() {
enewgroup swift
}
+src_prepare() {
+ sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
+ sed -i 's/xattr/pyxattr/g' "${S}/tools/pip-requires"
+}
+
python_install() {
distutils-r1_python_install
keepdir /etc/swift
diff --git a/sys-cluster/swift/swift-1.8.0-r1.ebuild b/sys-cluster/swift/swift-1.8.0-r1.ebuild
index 0c47f5121f21..b1eefbe11605 100644
--- a/sys-cluster/swift/swift-1.8.0-r1.ebuild
+++ b/sys-cluster/swift/swift-1.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.8.0-r1.ebuild,v 1.1 2013/05/01 15:22:46 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-1.8.0-r1.ebuild,v 1.2 2013/05/01 16:42:43 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -54,6 +54,11 @@ pkg_setup() {
enewgroup swift
}
+src_prepare() {
+ sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
+ sed -i 's/xattr/pyxattr/g' "${S}/tools/pip-requires"
+}
+
python_install() {
distutils-r1_python_install
keepdir /etc/swift
diff --git a/sys-cluster/swift/swift-9999.ebuild b/sys-cluster/swift/swift-9999.ebuild
index 05ec4e168209..102329babefd 100644
--- a/sys-cluster/swift/swift-9999.ebuild
+++ b/sys-cluster/swift/swift-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-9999.ebuild,v 1.2 2013/05/01 15:22:46 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/swift/swift-9999.ebuild,v 1.3 2013/05/01 16:42:43 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -54,6 +54,11 @@ pkg_setup() {
enewgroup swift
}
+src_prepare() {
+ sed -i 's/xattr/pyxattr/g' "${S}/swift.egg-info/requires.txt"
+ sed -i 's/xattr/pyxattr/g' "${S}/tools/pip-requires"
+}
+
python_install() {
distutils-r1_python_install
keepdir /etc/swift