summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2006-12-19 21:19:14 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2006-12-19 21:19:14 +0000
commit70fab0da8ed0ec50c11d36541035e65a64b8ab50 (patch)
tree3c3629785bb8bd69d33e5055dfb8a580c0815cb7 /sys-cluster
parentVersion bumping beryl to catch up with upstream #157727 (diff)
downloadgentoo-2-70fab0da8ed0ec50c11d36541035e65a64b8ab50.tar.gz
gentoo-2-70fab0da8ed0ec50c11d36541035e65a64b8ab50.tar.bz2
gentoo-2-70fab0da8ed0ec50c11d36541035e65a64b8ab50.zip
Version bump.
(Portage version: 2.1-r1)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/drbd/ChangeLog7
-rw-r--r--sys-cluster/drbd/drbd-8.0_pre6.ebuild80
-rw-r--r--sys-cluster/drbd/files/digest-drbd-8.0_pre63
3 files changed, 89 insertions, 1 deletions
diff --git a/sys-cluster/drbd/ChangeLog b/sys-cluster/drbd/ChangeLog
index da0bb6ba1713..aec52e28347d 100644
--- a/sys-cluster/drbd/ChangeLog
+++ b/sys-cluster/drbd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/drbd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/ChangeLog,v 1.56 2006/12/19 21:15:56 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/ChangeLog,v 1.57 2006/12/19 21:19:14 xmerlin Exp $
+
+*drbd-8.0_pre6 (19 Dec 2006)
+
+ 19 Dec 2006; Christian Zoffoli <xmerlin@gentoo.org> +drbd-8.0_pre6.ebuild:
+ Version bump.
*drbd-0.7.22 (19 Dec 2006)
diff --git a/sys-cluster/drbd/drbd-8.0_pre6.ebuild b/sys-cluster/drbd/drbd-8.0_pre6.ebuild
new file mode 100644
index 000000000000..474a148bcecb
--- /dev/null
+++ b/sys-cluster/drbd/drbd-8.0_pre6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/drbd-8.0_pre6.ebuild,v 1.1 2006/12/19 21:19:14 xmerlin Exp $
+
+inherit eutils versionator linux-mod linux-info
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+MY_PV="${PV/_/}"
+MY_MAJ_PV="$(get_version_component_range 1-2 ${PV})"
+DESCRIPTION="mirror/replicate block-devices across a network-connection"
+SRC_URI="http://oss.linbit.com/drbd/${MY_MAJ_PV}/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.drbd.org"
+
+IUSE=""
+
+DEPEND="virtual/linux-sources"
+RDEPEND=""
+SLOT="0"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+}
+
+src_compile() {
+ set_arch_to_kernel
+
+ einfo ""
+ einfo "Your kernel-sources in /usr/src/linux-${KV} must be properly configured"
+ einfo "If otherwise -> build will fail."
+ einfo ""
+
+ if kernel_is 2 6; then
+ emake KDIR=${KERNEL_DIR} || die "compile problem"
+ else
+ cp -R /usr/src/linux-${KV} ${WORKDIR}
+ emake KDIR=/${WORKDIR}/linux-${KV} || die "compile problem"
+ fi
+}
+
+src_install() {
+ emake PREFIX=${D} install || die "install problem"
+
+ # gentoo-ish init-script
+ newinitd ${FILESDIR}/${PN}-0.7.rc ${PN} || die
+
+ # needed by drbd startup script
+ #keepdir /var/lib/drbd
+
+ # docs
+ dodoc README ChangeLog COPYING ROADMAP INSTALL
+ #dodoc documentation/NFS-Server-README.txt
+
+ # we put drbd.conf into docs
+ # it doesnt make sense to install a default conf in /etc
+ # put it to the docs
+ rm -f ${D}/etc/drbd.conf
+ dodoc scripts/drbd.conf || die
+ #dodoc upgrade*.txt || die
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo ""
+ einfo "Please remember to re-emerge drbd when you upgrade your kernel!"
+ einfo ""
+ einfo "Please copy and gunzip the configuration file"
+ einfo "from /usr/share/doc/${PF}/drbd.conf.gz to /etc"
+ einfo "and edit it to your needs. Helpful commands:"
+ einfo "man 5 drbd.conf"
+ einfo "man 8 drbdsetup"
+ einfo "man 8 drbdadm"
+ einfo "man 8 drbddisk"
+ einfo "man 8 drbdmeta"
+ einfo ""
+}
diff --git a/sys-cluster/drbd/files/digest-drbd-8.0_pre6 b/sys-cluster/drbd/files/digest-drbd-8.0_pre6
new file mode 100644
index 000000000000..4d1c0af3d0d5
--- /dev/null
+++ b/sys-cluster/drbd/files/digest-drbd-8.0_pre6
@@ -0,0 +1,3 @@
+MD5 17967d6bcf27c56aea3fc9b7481c0851 drbd-8.0pre6.tar.gz 460800
+RMD160 1aaf06cf95d2ca76ac228a5c9d9e96365f935c0c drbd-8.0pre6.tar.gz 460800
+SHA256 2323d8e9d99f9d7ab630c8b3cc358768404b2a7bf77d036ab1073c8478b047d9 drbd-8.0pre6.tar.gz 460800