summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-01-15 08:21:14 +0000
committerYixun Lan <dlan@gentoo.org>2014-01-15 08:21:14 +0000
commit45ceab32803179e38d88eb875ead089b3926274c (patch)
tree7d66a8fe7ab1c7f2729b87d7dd982bdcfb0b9120 /sys-cluster
parentBump to mlton-20130715, fixes bug 480750. Thanks to David Brown, jer and Jaso... (diff)
downloadgentoo-2-45ceab32803179e38d88eb875ead089b3926274c.tar.gz
gentoo-2-45ceab32803179e38d88eb875ead089b3926274c.tar.bz2
gentoo-2-45ceab32803179e38d88eb875ead089b3926274c.zip
vesrion bump, fix bug #496118, #469564
1) version 0.67.5, 0.72.2 added 2) live ebuild updated 3) add myself as co-maintainer (Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ChangeLog12
-rw-r--r--sys-cluster/ceph/ceph-0.67.5.ebuild121
-rw-r--r--sys-cluster/ceph/ceph-0.72.2.ebuild120
-rw-r--r--sys-cluster/ceph/ceph-9999.ebuild37
-rw-r--r--sys-cluster/ceph/metadata.xml8
5 files changed, 281 insertions, 17 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 219a17077e22..372b08b06949 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/ceph
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.41 2013/08/18 18:57:39 alexxy Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.42 2014/01/15 08:21:14 dlan Exp $
+
+*ceph-0.67.5 (15 Jan 2014)
+*ceph-0.72.2 (15 Jan 2014)
+
+ 15 Jan 2014; Yixun Lan <dlan@gentoo.org> +ceph-0.67.5.ebuild,
+ +ceph-0.72.2.ebuild, ceph-9999.ebuild, metadata.xml:
+ vesrion bump, fix bug #496118, #469564 1) version 0.67.5, 0.72.2 added 2)
+ live ebuild updated 3) add myself as co-maintainer
*ceph-0.61.7-r1 (18 Aug 2013)
diff --git a/sys-cluster/ceph/ceph-0.67.5.ebuild b/sys-cluster/ceph/ceph-0.67.5.ebuild
new file mode 100644
index 000000000000..bfadefc73694
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.67.5.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.67.5.ebuild,v 1.1 2014/01/15 08:21:14 dlan Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="
+ git://github.com/ceph/ceph.git
+ https://github.com/ceph/ceph.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools eutils multilib python-r1 udev ${scm_eclass}
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="debug fuse gtk libatomic +libaio radosgw static-libs tcmalloc"
+
+CDEPEND="
+ app-arch/snappy
+ dev-libs/boost[threads]
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/leveldb[snappy]
+ dev-libs/crypto++
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sys-apps/keyutils
+ sys-apps/hdparm
+ sys-apps/util-linux
+ sys-block/parted
+ sys-fs/cryptsetup
+ dev-libs/libxml2
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-fs/btrfs-progs"
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+src_prepare() {
+ if [ ! -z ${PATCHES[@]} ]; then
+ epatch ${PATCHES[@]}
+ fi
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+ sed -e '/^ceph_sbindir =/s:$(exec_prefix)::' -i src/Makefile.am || die
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libaio) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ python_replicate_script \
+ "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
+ "${ED}"/usr/bin/{ceph,ceph-rest-api}
+
+ #install udev rules
+ udev_dorules udev/50-rbd.rules
+ udev_dorules udev/95-ceph-osd.rules
+}
diff --git a/sys-cluster/ceph/ceph-0.72.2.ebuild b/sys-cluster/ceph/ceph-0.72.2.ebuild
new file mode 100644
index 000000000000..63a81bb0fc78
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.72.2.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.72.2.ebuild,v 1.1 2014/01/15 08:21:14 dlan Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-r3
+ EGIT_REPO_URI="
+ git://github.com/ceph/ceph.git
+ https://github.com/ceph/ceph.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://ceph.com/download/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools eutils multilib python-r1 udev ${scm_eclass}
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.com/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="debug fuse gtk libatomic +libaio radosgw static-libs tcmalloc"
+
+CDEPEND="
+ app-arch/snappy
+ dev-libs/boost[threads]
+ dev-libs/fcgi
+ dev-libs/libaio
+ dev-libs/libedit
+ dev-libs/leveldb[snappy]
+ dev-libs/crypto++
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sys-apps/keyutils
+ sys-apps/hdparm
+ sys-apps/util-linux
+ sys-block/parted
+ sys-fs/cryptsetup
+ dev-libs/libxml2
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ net-misc/curl
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-fs/btrfs-progs"
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+src_prepare() {
+ if [ ! -z ${PATCHES[@]} ]; then
+ epatch ${PATCHES[@]}
+ fi
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libaio) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ python_replicate_script \
+ "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
+ "${ED}"/usr/bin/{ceph,ceph-rest-api}
+
+ #install udev rules
+ udev_dorules udev/50-rbd.rules
+ udev_dorules udev/95-ceph-osd.rules
+}
diff --git a/sys-cluster/ceph/ceph-9999.ebuild b/sys-cluster/ceph/ceph-9999.ebuild
index dfd987400e17..752768997cde 100644
--- a/sys-cluster/ceph/ceph-9999.ebuild
+++ b/sys-cluster/ceph/ceph-9999.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.4 2013/04/12 10:21:14 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-9999.ebuild,v 1.5 2014/01/15 08:21:14 dlan Exp $
EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
if [[ $PV = *9999* ]]; then
- scm_eclass=git-2
+ scm_eclass=git-r3
EGIT_REPO_URI="
git://github.com/ceph/ceph.git
https://github.com/ceph/ceph.git"
@@ -16,24 +17,31 @@ else
KEYWORDS="~amd64 ~x86"
fi
-inherit autotools eutils multilib udev ${scm_eclass}
+inherit autotools eutils multilib python-r1 udev ${scm_eclass}
DESCRIPTION="Ceph distributed filesystem"
HOMEPAGE="http://ceph.com/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="debug fuse gtk libatomic radosgw static-libs tcmalloc"
+IUSE="debug fuse gtk libatomic +libaio radosgw static-libs tcmalloc"
CDEPEND="
app-arch/snappy
- dev-libs/boost
+ dev-libs/boost[threads]
dev-libs/fcgi
dev-libs/libaio
dev-libs/libedit
- dev-libs/leveldb
+ dev-libs/leveldb[snappy]
dev-libs/crypto++
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
sys-apps/keyutils
+ sys-apps/hdparm
+ sys-apps/util-linux
+ sys-block/parted
+ sys-fs/cryptsetup
+ dev-libs/libxml2
fuse? ( sys-fs/fuse )
libatomic? ( dev-libs/libatomic_ops )
gtk? (
@@ -47,6 +55,7 @@ CDEPEND="
net-misc/curl
)
tcmalloc? ( dev-util/google-perftools )
+ virtual/python-argparse[${PYTHON_USEDEP}]
"
DEPEND="${CDEPEND}
virtual/pkgconfig"
@@ -59,13 +68,10 @@ src_prepare() {
if [ ! -z ${PATCHES[@]} ]; then
epatch ${PATCHES[@]}
fi
- sed -e 's:invoke-rc\.d.*:/etc/init.d/ceph reload >/dev/null:' \
- -i src/logrotate.conf || die
- sed -i "/^docdir =/d" src/Makefile.am || die #fix doc path
- # disable testsnaps
- sed -e '/testsnaps/d' -i src/Makefile.am || die
sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
> "${T}"/${PN}.initd || die
+
+ epatch_user
eautoreconf
}
@@ -76,6 +82,7 @@ src_configure() {
--includedir=/usr/include \
$(use_with debug) \
$(use_with fuse) \
+ $(use_with libaio) \
$(use_with libatomic libatomic-ops) \
$(use_with radosgw) \
$(use_with gtk gtk2) \
@@ -88,8 +95,6 @@ src_install() {
prune_libtool_files --all
- rmdir "${ED}/usr/sbin"
-
exeinto /usr/$(get_libdir)/ceph
newexe src/init-ceph ceph_init.sh
@@ -105,6 +110,10 @@ src_install() {
newinitd "${T}/${PN}.initd" ${PN}
newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ python_replicate_script \
+ "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
+ "${ED}"/usr/bin/{ceph,ceph-rest-api}
+
#install udev rules
udev_dorules udev/50-rbd.rules
udev_dorules udev/95-ceph-osd.rules
diff --git a/sys-cluster/ceph/metadata.xml b/sys-cluster/ceph/metadata.xml
index 2eeec3696ab5..ca60e61af651 100644
--- a/sys-cluster/ceph/metadata.xml
+++ b/sys-cluster/ceph/metadata.xml
@@ -1,13 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>cluster</herd>
+ <herd>cluster</herd>
+ <maintainer>
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ <description>Co Maintainer</description>
+ </maintainer>
<longdescription>
Ceph is a distributed network file system designed to provide excellent performance, reliability, and scalability.
</longdescription>
<use>
<flag name='fuse'>Build fuse client</flag>
<flag name='libatomic'>Use libatomic instead of builtin atomic operations</flag>
+ <flag name='libaio'>Use libaio as asynchronous input/output library</flag>
<flag name='radosgw'>Add radosgw support</flag>
</use>
</pkgmetadata>