summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-12-02 14:30:00 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-12-02 14:30:00 +0000
commit442b7b40c45c227aab9d8066e12bf9fc249e4c0f (patch)
tree4d7eaa7101636139f7b5cfb69b53424f0b869f46 /sys-cluster
parentStabilize for all. Drop old EAPI=1 ebuild. (diff)
downloadgentoo-2-442b7b40c45c227aab9d8066e12bf9fc249e4c0f.tar.gz
gentoo-2-442b7b40c45c227aab9d8066e12bf9fc249e4c0f.tar.bz2
gentoo-2-442b7b40c45c227aab9d8066e12bf9fc249e4c0f.zip
version bump, drop old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/corosync/ChangeLog8
-rw-r--r--sys-cluster/corosync/corosync-2.3.4.ebuild (renamed from sys-cluster/corosync/corosync-1.4.5.ebuild)39
-rw-r--r--sys-cluster/corosync/files/corosync-2.3.4-docs.patch23
3 files changed, 57 insertions, 13 deletions
diff --git a/sys-cluster/corosync/ChangeLog b/sys-cluster/corosync/ChangeLog
index 4ecffde9f74c..d71fb12ac123 100644
--- a/sys-cluster/corosync/ChangeLog
+++ b/sys-cluster/corosync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/corosync
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.31 2014/08/12 15:27:41 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/ChangeLog,v 1.32 2014/12/02 14:30:00 ultrabug Exp $
+
+*corosync-2.3.4 (02 Dec 2014)
+
+ 02 Dec 2014; Ultrabug <ultrabug@gentoo.org> -corosync-1.4.5.ebuild,
+ +corosync-2.3.4.ebuild, +files/corosync-2.3.4-docs.patch:
+ version bump, drop old
*corosync-2.3.3 (12 Aug 2014)
*corosync-1.4.7 (12 Aug 2014)
diff --git a/sys-cluster/corosync/corosync-1.4.5.ebuild b/sys-cluster/corosync/corosync-2.3.4.ebuild
index 56cf54b67011..d13f38361605 100644
--- a/sys-cluster/corosync/corosync-1.4.5.ebuild
+++ b/sys-cluster/corosync/corosync-2.3.4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-1.4.5.ebuild,v 1.1 2013/01/18 10:22:53 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/corosync/corosync-2.3.4.ebuild,v 1.1 2014/12/02 14:30:00 ultrabug Exp $
EAPI=4
inherit autotools base
-MY_TREE="5b75f8c"
+MY_TREE="4dc01e3"
DESCRIPTION="OSI Certified implementation of a complete cluster engine"
HOMEPAGE="http://www.corosync.org/"
@@ -14,24 +14,29 @@ SRC_URI="https://github.com/corosync/corosync/tarball/v${PV} -> ${P}.tar.gz"
LICENSE="BSD-2 public-domain"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
-IUSE="doc infiniband ssl static-libs"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc infiniband static-libs"
+# TODO: support those new configure flags
+# --enable-watchdog : Watchdog support
+# --enable-augeas : Install the augeas lens for corosync.conf
+# --enable-snmp : SNMP protocol support
+# --enable-xmlconf : XML configuration support
+# --enable-systemd : Install systemd service files
RDEPEND="!sys-cluster/heartbeat
- ssl? ( dev-libs/nss )
infiniband? (
sys-infiniband/libibverbs
sys-infiniband/librdmacm
- )"
+ )
+ dev-libs/nss
+ >=sys-cluster/libqb-0.14.4"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( sys-apps/groff )"
-PATCHES=(
- "${FILESDIR}/${PN}-docs.patch"
-)
+PATCHES=( "${FILESDIR}/${PN}-2.3.4-docs.patch" )
-DOCS=( README.recovery README.devmap SECURITY TODO AUTHORS )
+DOCS=( README.recovery SECURITY AUTHORS )
S="${WORKDIR}/${PN}-${PN}-${MY_TREE}"
@@ -47,7 +52,6 @@ src_configure() {
--localstatedir=/var \
--docdir=/usr/share/doc/${PF} \
$(use_enable doc) \
- $(use_enable ssl nss) \
$(use_enable infiniband rdma)
}
@@ -62,3 +66,14 @@ src_install() {
keepdir /var/lib/corosync
use static-libs || rm -rf "${D}"/usr/$(get_libdir)/*.a || die
}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} < 2.0 ]]; then
+ ewarn "!! IMPORTANT !!"
+ ewarn " "
+ ewarn "Migrating from a previous version of corosync can be dangerous !"
+ ewarn " "
+ ewarn "Make sure you backup your cluster configuration before proceeding"
+ ewarn " "
+ fi
+} \ No newline at end of file
diff --git a/sys-cluster/corosync/files/corosync-2.3.4-docs.patch b/sys-cluster/corosync/files/corosync-2.3.4-docs.patch
new file mode 100644
index 000000000000..53dbd7d29c75
--- /dev/null
+++ b/sys-cluster/corosync/files/corosync-2.3.4-docs.patch
@@ -0,0 +1,23 @@
+--- a/configure.ac 2014-12-02 15:21:35.511819113 +0100
++++ b/configure.ac 2014-12-02 15:23:02.162487868 +0100
+@@ -655,7 +655,7 @@
+ INCLUDE_DIRS="$INCLUDE_DIRS -I\$(top_builddir)/include/corosync -I\$(top_srcdir)/include/corosync"
+
+ # final build of *FLAGS
+-CFLAGS="$ENV_CFLAGS $lt_prog_compiler_pic $SEC_FLAGS $OPT_CFLAGS $GDB_FLAGS \
++CFLAGS="$ENV_CFLAGS $lt_prog_compiler_pic $OS_CFLAGS \
+ $COVERAGE_CFLAGS $EXTRA_WARNINGS \
+ $WERROR_CFLAGS $NSS_CFLAGS $LIBQB_CFLAGS \
+ $SNMP_INCLUDES"
+@@ -685,7 +685,10 @@
+ AM_CONDITIONAL(AUGTOOL, test -n "${AUGTOOL}")
+ AC_SUBST([NSS_LDFLAGS])
+
+-AM_CONDITIONAL(BUILD_HTML_DOCS, test -n "${GROFF}")
++AC_ARG_ENABLE([doc],
++ AS_HELP_STRING([--enable-doc],[Build html documentation])
++)
++AM_CONDITIONAL(BUILD_HTML_DOCS, [test -n "${GROFF}" && test "x$enable_doc" = "xyes"] )
+
+ AC_SUBST([LINT_FLAGS])
+