summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-06-17 21:10:37 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-06-17 21:10:37 +0000
commit2f534bc635e752c7ac38e7e32d9c7b0d550ffec2 (patch)
tree9377da1646134b5a70435c63690396093e21176a /sys-cluster
parentrev bump to backport a patch that closes stdin/out/err unless we are in debug... (diff)
downloadgentoo-2-2f534bc635e752c7ac38e7e32d9c7b0d550ffec2.tar.gz
gentoo-2-2f534bc635e752c7ac38e7e32d9c7b0d550ffec2.tar.bz2
gentoo-2-2f534bc635e752c7ac38e7e32d9c7b0d550ffec2.zip
adding memcached as a use flag'd dep
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nova/ChangeLog9
-rw-r--r--sys-cluster/nova/metadata.xml1
-rw-r--r--sys-cluster/nova/nova-2015.1.0-r3.ebuild (renamed from sys-cluster/nova/nova-2015.1.0-r2.ebuild)7
-rw-r--r--sys-cluster/nova/nova-2015.1.9999.ebuild7
4 files changed, 17 insertions, 7 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index a631760d4843..d1f63ef46ced 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.99 2015/05/27 05:48:31 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.100 2015/06/17 21:10:37 prometheanfire Exp $
+
+*nova-2015.1.0-r3 (17 Jun 2015)
+
+ 17 Jun 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +nova-2015.1.0-r3.ebuild, -nova-2015.1.0-r2.ebuild, metadata.xml,
+ nova-2015.1.9999.ebuild:
+ adding memcached as a use flag'd dep
27 May 2015; Matthew Thode <prometheanfire@gentoo.org>
nova-2015.1.0-r2.ebuild, nova-2015.1.9999.ebuild:
diff --git a/sys-cluster/nova/metadata.xml b/sys-cluster/nova/metadata.xml
index 27c5b074629f..d8ca67bd04d6 100644
--- a/sys-cluster/nova/metadata.xml
+++ b/sys-cluster/nova/metadata.xml
@@ -15,6 +15,7 @@
<flag name="compute-only">only install stuff needed for a compute host</flag>
<flag name="iscsi">Installs iscsi helper udev scripts</flag>
<flag name="kvm">qemu-kvm hypervisor support</flag>
+ <flag name="memcached">Installs the memcached server</flag>
<flag name="network">Installs the initscripts for the nova network service</flag>
<flag name="novncproxy">Installs the initscripts for the nova novncproxy service</flag>
<flag name="openvswitch">Installs openvswitch for the neutron openvswitch support</flag>
diff --git a/sys-cluster/nova/nova-2015.1.0-r2.ebuild b/sys-cluster/nova/nova-2015.1.0-r3.ebuild
index a2a51ab60d55..4a8207ae233e 100644
--- a/sys-cluster/nova/nova-2015.1.0-r2.ebuild
+++ b/sys-cluster/nova/nova-2015.1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.0-r2.ebuild,v 1.2 2015/05/27 05:48:31 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.0-r3.ebuild,v 1.1 2015/06/17 21:10:37 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -14,9 +14,9 @@ SRC_URI="http://launchpad.net/${PN}/kilo/${PV}/+download/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+compute compute-only +kvm +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen iscsi"
+IUSE="+compute compute-only +kvm +memcached +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen iscsi"
REQUIRED_USE="!compute-only? ( || ( mysql postgres sqlite ) )
- compute-only? ( compute !rabbitmq !mysql !postgres !sqlite )
+ compute-only? ( compute !rabbitmq !memcached !mysql !postgres !sqlite )
compute? ( ^^ ( kvm xen ) )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
@@ -109,6 +109,7 @@ RDEPEND="
sys-apps/iproute2
openvswitch? ( net-misc/openvswitch )
rabbitmq? ( net-misc/rabbitmq-server )
+ memcached? ( net-misc/memcached )
sys-fs/sysfsutils
sys-fs/multipath-tools
net-misc/bridge-utils
diff --git a/sys-cluster/nova/nova-2015.1.9999.ebuild b/sys-cluster/nova/nova-2015.1.9999.ebuild
index 2daed4ebc1ae..7c78430ebaf1 100644
--- a/sys-cluster/nova/nova-2015.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2015.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.12 2015/05/27 05:48:31 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2015.1.9999.ebuild,v 1.13 2015/06/17 21:10:37 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -15,9 +15,9 @@ EGIT_BRANCH="stable/kilo"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="+compute compute-only +kvm +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen iscsi"
+IUSE="+compute compute-only +kvm +memcached +novncproxy openvswitch +rabbitmq sqlite mysql postgres xen iscsi"
REQUIRED_USE="!compute-only? ( || ( mysql postgres sqlite ) )
- compute-only? ( compute !rabbitmq !mysql !postgres !sqlite )
+ compute-only? ( compute !rabbitmq !memcached !mysql !postgres !sqlite )
compute? ( ^^ ( kvm xen ) )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
@@ -110,6 +110,7 @@ RDEPEND="
sys-apps/iproute2
openvswitch? ( net-misc/openvswitch )
rabbitmq? ( net-misc/rabbitmq-server )
+ memcached? ( net-misc/memcached )
sys-fs/sysfsutils
sys-fs/multipath-tools
net-misc/bridge-utils