summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-06-10 20:13:41 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-06-10 20:13:41 +0000
commitf192131787cc4d801589d476b6514940242605f7 (patch)
treee981df687e60d707533982412edc95a9b487ab0f /sys-cluster/torque
parentstable on amd64 wrt bug 95347 (diff)
downloadgentoo-2-f192131787cc4d801589d476b6514940242605f7.tar.gz
gentoo-2-f192131787cc4d801589d476b6514940242605f7.tar.bz2
gentoo-2-f192131787cc4d801589d476b6514940242605f7.zip
Add DEPEND on sys-apps/ed, and make sure makedepend-sh uses $TMPDIR.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/ChangeLog6
-rw-r--r--sys-cluster/torque/torque-1.0.1_p6.ebuild8
-rw-r--r--sys-cluster/torque/torque-1.2.0_p1.ebuild18
3 files changed, 23 insertions, 9 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index 7fced4406900..ac567d3bf1b3 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/torque
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.9 2005/03/15 21:59:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.10 2005/06/10 20:13:41 robbat2 Exp $
+
+ 10 Jun 2005; Robin H. Johnson <robbat2@gentoo.org> torque-1.0.1_p6.ebuild,
+ torque-1.2.0_p1.ebuild:
+ Add DEPEND on sys-apps/ed, and make sure makedepend-sh uses $TMPDIR.
*torque-1.0.1_p6 (15 Mar 2005)
diff --git a/sys-cluster/torque/torque-1.0.1_p6.ebuild b/sys-cluster/torque/torque-1.0.1_p6.ebuild
index 5293fe2d5e9b..8353b3a2ea80 100644
--- a/sys-cluster/torque/torque-1.0.1_p6.ebuild
+++ b/sys-cluster/torque/torque-1.0.1_p6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.0.1_p6.ebuild,v 1.1 2005/03/15 21:59:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.0.1_p6.ebuild,v 1.2 2005/06/10 20:13:41 robbat2 Exp $
MY_P=${P/_/}
S=${WORKDIR}/${MY_P}
@@ -13,7 +13,8 @@ SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
IUSE="X tcltk"
-DEPEND="virtual/libc
+DEPEND="sys-apps/ed
+ virtual/libc
X? ( virtual/x11 )
tcltk? ( dev-lang/tcl )"
RDEPEND="net-misc/openssh"
@@ -31,6 +32,9 @@ src_unpack() {
# Is this one needed??
# -e "s|\(PBS_DEFAULT_SERVER=\)\(@PBS_DEFAULT_SERVER@\)|\1\${D}\2|" \
+
+ # Tries to use absolute /tmp/ for tempfiles which fails miserably.
+ sed -i -e "s|/tmp/|\${TMPDIR}/|g" makedepend-sh || die "Failed TMPDIR change"
}
src_compile() {
diff --git a/sys-cluster/torque/torque-1.2.0_p1.ebuild b/sys-cluster/torque/torque-1.2.0_p1.ebuild
index 7c695ae37db6..f2376ccd7e60 100644
--- a/sys-cluster/torque/torque-1.2.0_p1.ebuild
+++ b/sys-cluster/torque/torque-1.2.0_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p1.ebuild,v 1.1 2005/02/20 09:40:02 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p1.ebuild,v 1.2 2005/06/10 20:13:41 robbat2 Exp $
inherit flag-o-matic
@@ -14,9 +14,11 @@ SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
IUSE="doc tcltk X"
+# ed is used by makedepend-sh
DEPEND="virtual/libc
X? ( virtual/x11 )
- tcltk? ( dev-lang/tcl )"
+ tcltk? ( dev-lang/tcl )
+ sys-apps/ed"
RDEPEND="net-misc/openssh"
S="${WORKDIR}/${MY_P}"
@@ -25,17 +27,21 @@ src_unpack() {
append-ldflags -Wl,-z,now
unpack ${A}
- epatch ${FILESDIR}/${PV}-respect-ldflags.patch
+ epatch ${FILESDIR}/${PV}-respect-ldflags.patch || die "Failed to fix ldflags"
# this thing doesn't use make install, but rather it's own install script
# fix it here so the install dirs are set to the ${D} directory
- cd ${S}/buildutils
- mv pbs_mkdirs.in pbs_mkdirs.in-orig
+ cd ${S}/buildutils && \
+ mv pbs_mkdirs.in pbs_mkdirs.in-orig && \
sed -e "s|prefix=@prefix@|prefix=\${D}@prefix@| ; \
s|PBS_SERVER_HOME=@PBS_SERVER_HOME@|PBS_SERVER_HOME=\${D}@PBS_SERVER_HOME@| ; \
s|PBS_DEFAULT_FILE=@PBS_DEFAULT_FILE@|PBS_DEFAULT_FILE=\${D}@PBS_DEFAULT_FILE@| ; \
s|PBS_ENVIRON=@PBS_ENVIRON@|PBS_ENVIRON=\${D}@PBS_ENVIRON@|" \
- pbs_mkdirs.in-orig > pbs_mkdirs.in
+ pbs_mkdirs.in-orig > pbs_mkdirs.in || \
+ die 'Failed to set build to use $D'
+
+ # Tries to use absolute /tmp/ for tempfiles which fails miserably.
+ sed -i -e "s|/tmp/|\${TMPDIR}/|g" makedepend-sh || die "Failed TMPDIR change"
}
src_compile() {