summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-28 03:13:23 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-28 03:13:23 +0000
commit7d036af3c02bcc2cf19bd103f9fe115d2928342f (patch)
tree3f5d9e057393487714fe1f7246dcc46897b3c301 /sys-cluster/torque
parentAdd php dep for posix (thanks to msfroh) (diff)
downloadgentoo-2-7d036af3c02bcc2cf19bd103f9fe115d2928342f.tar.gz
gentoo-2-7d036af3c02bcc2cf19bd103f9fe115d2928342f.tar.bz2
gentoo-2-7d036af3c02bcc2cf19bd103f9fe115d2928342f.zip
Change scp USE flag to crypt for compatibility with the rest of the tree (Eric Thibodeau).
(Portage version: 2.1.2_pre1-r3)
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/ChangeLog8
-rw-r--r--sys-cluster/torque/torque-1.2.0_p5-r1.ebuild6
-rw-r--r--sys-cluster/torque/torque-1.2.0_p5-r2.ebuild6
-rw-r--r--sys-cluster/torque/torque-2.1.2-r1.ebuild12
4 files changed, 19 insertions, 13 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index 975c58eac35b..c804380e9e79 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/torque
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.34 2006/09/26 21:35:46 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.35 2006/09/28 03:13:23 dberkholz Exp $
+
+ 28 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ torque-1.2.0_p5-r1.ebuild, torque-1.2.0_p5-r2.ebuild,
+ torque-2.1.2-r1.ebuild:
+ Change scp USE flag to crypt for compatibility with the rest of the tree
+ (Eric Thibodeau).
26 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
torque-2.1.2-r1.ebuild:
diff --git a/sys-cluster/torque/torque-1.2.0_p5-r1.ebuild b/sys-cluster/torque/torque-1.2.0_p5-r1.ebuild
index 2839913fbab8..ef0d533027a4 100644
--- a/sys-cluster/torque/torque-1.2.0_p5-r1.ebuild
+++ b/sys-cluster/torque/torque-1.2.0_p5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p5-r1.ebuild,v 1.5 2006/08/27 05:47:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p5-r1.ebuild,v 1.6 2006/09/28 03:13:23 dberkholz Exp $
inherit flag-o-matic eutils
@@ -16,7 +16,7 @@ LICENSE="openpbs"
SLOT="0"
KEYWORDS="~amd64 ~ppc ppc64 x86"
-IUSE="tcltk X scp"
+IUSE="tcltk X crypt"
PROVIDE="virtual/pbs"
# ed is used by makedepend-sh
@@ -68,7 +68,7 @@ src_compile() {
--enable-clients \
--enable-shared \
--enable-depend-cache \
- $(use_with scp) \
+ $(use_with crypt scp) \
$(use_enable tcltk tcl-qstat) \
--set-server-home=${PBS_SERVER_HOME} \
--set-environ=/etc/pbs_environment || die "./configure failed"
diff --git a/sys-cluster/torque/torque-1.2.0_p5-r2.ebuild b/sys-cluster/torque/torque-1.2.0_p5-r2.ebuild
index f241bfce9767..a6ef731bc88b 100644
--- a/sys-cluster/torque/torque-1.2.0_p5-r2.ebuild
+++ b/sys-cluster/torque/torque-1.2.0_p5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p5-r2.ebuild,v 1.2 2006/01/18 07:51:39 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-1.2.0_p5-r2.ebuild,v 1.3 2006/09/28 03:13:23 dberkholz Exp $
inherit flag-o-matic eutils
@@ -16,7 +16,7 @@ LICENSE="openpbs"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc tcltk X scp"
+IUSE="doc tcltk X crypt"
PROVIDE="virtual/pbs"
# ed is used by makedepend-sh
@@ -69,7 +69,7 @@ src_compile() {
--enable-clients \
--enable-shared \
--enable-depend-cache \
- $(use_with scp) \
+ $(use_with crypt scp) \
$(use_enable tcltk tcl-qstat) \
--set-server-home=${PBS_SERVER_HOME} \
--set-environ=/etc/pbs_environment || die "./configure failed"
diff --git a/sys-cluster/torque/torque-2.1.2-r1.ebuild b/sys-cluster/torque/torque-2.1.2-r1.ebuild
index 8df66192b53a..579fe2984a16 100644
--- a/sys-cluster/torque/torque-2.1.2-r1.ebuild
+++ b/sys-cluster/torque/torque-2.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.1.2-r1.ebuild,v 1.3 2006/09/26 21:35:46 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.1.2-r1.ebuild,v 1.4 2006/09/28 03:13:23 dberkholz Exp $
inherit autotools flag-o-matic eutils
@@ -14,7 +14,7 @@ LICENSE="openpbs"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="tk scp server"
+IUSE="tk crypt server"
PROVIDE="virtual/pbs"
# ed is used by makedepend-sh
@@ -28,8 +28,8 @@ DEPEND="${DEPEND_COMMON}
sys-apps/ed"
RDEPEND="${DEPEND_COMMON}
- scp? ( net-misc/openssh )
- !scp? ( net-misc/netkit-rsh )"
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )"
PDEPEND=">=sys-cluster/openpbs-common-1.1.1"
@@ -58,8 +58,8 @@ src_compile() {
myconf="--disable-server --with-default-server=$(hostname)"
fi
- if use scp; then
- myconf="${myconf} --with-rcp=scp"
+ if use crypt; then
+ myconf="${myconf} --with-rcp=crypt"
else
myconf="${myconf} --with-rcp=mom_rcp"
fi