summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-11-23 07:50:57 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-11-23 07:50:57 +0000
commit96229a5ae1199473e8dded8478a687b5e8b60e25 (patch)
tree9520e9f80775254f12ba142867e4e464c79d452c /sys-cluster/openmpi
parentstable on ppc (diff)
downloadgentoo-2-96229a5ae1199473e8dded8478a687b5e8b60e25.tar.gz
gentoo-2-96229a5ae1199473e8dded8478a687b5e8b60e25.tar.bz2
gentoo-2-96229a5ae1199473e8dded8478a687b5e8b60e25.zip
(#153968) Bump. Interesting changes include correctness and performance fixes for heterogenous nodes as well as TCP updates to support non-uniform TCP environments. More info at http://www.open-mpi.org/community/lists/announce/2006/10/0008.php.
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/ChangeLog11
-rw-r--r--sys-cluster/openmpi/files/digest-openmpi-1.1.23
-rw-r--r--sys-cluster/openmpi/openmpi-1.1.2.ebuild71
3 files changed, 84 insertions, 1 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 38aa52232738..f0b35fe6ef99 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.2 2006/09/25 15:29:11 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.3 2006/11/23 07:50:57 dberkholz Exp $
+
+*openmpi-1.1.2 (23 Nov 2006)
+
+ 23 Nov 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +openmpi-1.1.2.ebuild:
+ (#153968) Bump. Interesting changes include correctness and performance
+ fixes for heterogenous nodes as well as TCP updates to support non-uniform
+ TCP environments. More info at
+ http://www.open-mpi.org/community/lists/announce/2006/10/0008.php.
25 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>; openmpi-1.1.1.ebuild:
Add MPI to the description, drop some capital letters.
diff --git a/sys-cluster/openmpi/files/digest-openmpi-1.1.2 b/sys-cluster/openmpi/files/digest-openmpi-1.1.2
new file mode 100644
index 000000000000..1f23886b13cd
--- /dev/null
+++ b/sys-cluster/openmpi/files/digest-openmpi-1.1.2
@@ -0,0 +1,3 @@
+MD5 53877ec8bca5f6e505496b6b94b1d850 openmpi-1.1.2.tar.bz2 3222389
+RMD160 823f3f828ed9dd9af48d33d1fe50596fa0eee42b openmpi-1.1.2.tar.bz2 3222389
+SHA256 3bd8d9fe40b356be7f9c3d336013d3865f8ca6a79b3c6e7ef28784f6c3a2b8e6 openmpi-1.1.2.tar.bz2 3222389
diff --git a/sys-cluster/openmpi/openmpi-1.1.2.ebuild b/sys-cluster/openmpi/openmpi-1.1.2.ebuild
new file mode 100644
index 000000000000..ca93acb92211
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-1.1.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.1.2.ebuild,v 1.1 2006/11/23 07:50:57 dberkholz Exp $
+
+inherit eutils multilib flag-o-matic toolchain-funcs fortran
+
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v1.1/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pbs fortran threads"
+PROVIDE="virtual/mpi"
+DEPEND="virtual/libc
+ pbs? ( virtual/pbs )"
+
+FORTRAN="ifc gfortran g77"
+
+pkg_setup() {
+ if use threads; then
+ ewarn
+ ewarn "WARNING: use of threads is highly experimental."
+ ewarn "You may stop now and set USE=-threads"
+ ewarn
+ epause 5
+ fi
+ use fortran && fortran_pkg_setup
+}
+
+src_compile() {
+
+ einfo
+ einfo "OpenMPI has an overwhelming count of configuration options."
+ einfo "Don't forget the EXTRA_ECONF environment variable can let you"
+ einfo "specify configure options."
+ einfo
+
+ local myconf="--sysconfdir=/etc/${PN}"
+ myconf="${myconf} --enable-pretty-print-stacktrace"
+
+ if use threads; then
+ myconf="${myconf} --enable-mpi-threads"
+ myconf="${myconf} --with-progress-threads"
+ myconf="${myconf} --with-threads=posix"
+ fi
+
+ if use fortran; then
+ myconf="${myconf} $(use enable fortran mpi-f77)"
+ [ "${FORTRANC}" = "g77" ] && \
+ myconf="${myconf} --disable-mpi-f90" || \
+ myconf="${myconf} --enable-mpi-f90"
+ fi
+
+ use pbs && myconf="${myconf} $(use_with pbs tm /usr/$(get_libdir)/pbs)"
+ append-ldflags -Wl,-z,-noexecstack
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc README AUTHORS NEWS VERSION
+}