summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-12-06 23:48:55 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-12-06 23:48:55 +0000
commit4557b2d2691dcd8e00a7a7b2db5ac2dfa75525f5 (patch)
tree70bc4828c13dd0d330136dcd0eaae7eff522ffe1 /sys-cluster/mpich2/mpich2-1.0.3.ebuild
parentClean up. (diff)
downloadgentoo-2-4557b2d2691dcd8e00a7a7b2db5ac2dfa75525f5.tar.gz
gentoo-2-4557b2d2691dcd8e00a7a7b2db5ac2dfa75525f5.tar.bz2
gentoo-2-4557b2d2691dcd8e00a7a7b2db5ac2dfa75525f5.zip
Switch deps around so DEPEND is set to RDEPEND. This way, one could specify things that are only in DEPEND more easily, such as perl or coreutils. But I can't verify those now, so I'll leave it to someone else.
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'sys-cluster/mpich2/mpich2-1.0.3.ebuild')
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.3.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/sys-cluster/mpich2/mpich2-1.0.3.ebuild b/sys-cluster/mpich2/mpich2-1.0.3.ebuild
index 26f6c6d78c09..d01702d4be98 100644
--- a/sys-cluster/mpich2/mpich2-1.0.3.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3.ebuild,v 1.9 2006/09/26 01:16:29 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.0.3.ebuild,v 1.10 2006/12/06 23:48:55 dberkholz Exp $
inherit eutils autotools
@@ -15,16 +15,12 @@ KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE="crypt cxx doc debug mpe threads"
PROVIDE="virtual/mpi"
-DEPEND="virtual/libc
- sys-devel/autoconf
- sys-devel/automake
- sys-devel/libtool"
-RDEPEND="${DEPEND}
- crypt? ( net-misc/openssh )
+RDEPEND="crypt? ( net-misc/openssh )
!crypt? ( net-misc/netkit-rsh )
!virtual/mpi
!media-sound/mpd
!media-sound/mpd-svn"
+DEPEND="${RDEPEND}"
pkg_setup() {
if [ -n "${MPICH_CONFIGURE_OPTS}" ]; then