summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2006-10-13 22:19:04 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2006-10-13 22:19:04 +0000
commit1169ad22357719dc3f2322c1b5590a4cc95270ed (patch)
treeb3cc95534cef5093e9027b7addf55f11683eb072 /sys-cluster/keepalived
parentAdd gnome-screensaver; remove gnome-vfs-monikers; move sabayon behind ldap US... (diff)
downloadgentoo-2-1169ad22357719dc3f2322c1b5590a4cc95270ed.tar.gz
gentoo-2-1169ad22357719dc3f2322c1b5590a4cc95270ed.tar.bz2
gentoo-2-1169ad22357719dc3f2322c1b5590a4cc95270ed.zip
Version bump.
(Portage version: 2.1-r1)
Diffstat (limited to 'sys-cluster/keepalived')
-rw-r--r--sys-cluster/keepalived/ChangeLog8
-rw-r--r--sys-cluster/keepalived/files/digest-keepalived-1.1.133
-rw-r--r--sys-cluster/keepalived/keepalived-1.1.13.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-cluster/keepalived/ChangeLog b/sys-cluster/keepalived/ChangeLog
index eaee54db8f70..c25d9eee66ba 100644
--- a/sys-cluster/keepalived/ChangeLog
+++ b/sys-cluster/keepalived/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/keepalived
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.36 2006/08/12 23:38:45 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.37 2006/10/13 22:19:04 xmerlin Exp $
+
+*keepalived-1.1.13 (13 Oct 2006)
+
+ 13 Oct 2006; Christian Zoffoli <xmerlin@gentoo.org>
+ +keepalived-1.1.13.ebuild:
+ Version bump.
12 Aug 2006; Jason Wever <weeve@gentoo.org> keepalived-1.1.12.ebuild:
Stable on SPARC.
diff --git a/sys-cluster/keepalived/files/digest-keepalived-1.1.13 b/sys-cluster/keepalived/files/digest-keepalived-1.1.13
new file mode 100644
index 000000000000..899c89d04da3
--- /dev/null
+++ b/sys-cluster/keepalived/files/digest-keepalived-1.1.13
@@ -0,0 +1,3 @@
+MD5 578bdb8e3ff4cca50fc877893bad658c keepalived-1.1.13.tar.gz 222220
+RMD160 63f0ee6d767eb90f8b8e0621e59ed3365a5b5d4d keepalived-1.1.13.tar.gz 222220
+SHA256 2545bd681580a97f9c5c9bbe6fe2f8a91988d0c5f063bba048148b52ccde2568 keepalived-1.1.13.tar.gz 222220
diff --git a/sys-cluster/keepalived/keepalived-1.1.13.ebuild b/sys-cluster/keepalived/keepalived-1.1.13.ebuild
new file mode 100644
index 000000000000..a4dc4664b5cb
--- /dev/null
+++ b/sys-cluster/keepalived/keepalived-1.1.13.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.13.ebuild,v 1.1 2006/10/13 22:19:04 xmerlin Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="add a strong & robust keepalive facility to the Linux Virtual Server project"
+HOMEPAGE="http://www.keepalived.org/"
+SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug profile"
+
+DEPEND="dev-libs/popt
+ sys-apps/iproute2"
+
+src_compile() {
+ local myconf
+
+ myconf="--prefix=/"
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ # disable -fomit-frame-pointer for profiling
+ if use profile; then
+ filter-flags -fomit-frame-pointer
+ myconf="${myconf} --enable-profile"
+ fi
+
+ ./configure ${myconf} || die "configure failed"
+ emake || die "make failed (myconf=${myconf})"
+}
+
+src_install() {
+ einstall || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init-keepalived keepalived
+
+ dodoc doc/keepalived.conf.SYNOPSIS
+ doman doc/man/man*/*
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "If you want Linux Virtual Server support in keepalived then you must emerge an"
+ einfo "LVS patched kernel, compile with ipvs support either as a module or built into"
+ einfo "the kernel, emerge the ipvsadm userland tools, and reemerge keepalived."
+ einfo ""
+ einfo "For debug support add USE=\"debug\" to your /etc/make.conf"
+ einfo ""
+}